MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 (1 Viewer)

TBacker

Portal Member
June 23, 2011
25
4
Country flag
Tinkering with using MadVR. I'm still running a 1080p TV, but have plenty of old DVD rips that I haven't updated yet, and my next screen will be 4K capable anyway, so I figured I'd set it up.

This is on an 4-core i5 machine, 8GB RAM, GTX 1650 card (this is a SFF low profile machine) running Windows 10 Pro. MP 1.25 release. HDMI -> Receiver -> TV.

I've had this working smoothly with EVR, dynamic refresh rate changer, and Media Portal Audio Renderer for a while now. Using the latest LAV filters that I have installed (not the one packaged in the MP installer).

So I installed madVR, set conservative settings and set my monitors available refresh rates into it. I disabled MP's refresh rate control, changed the audio renderer back to my monitor, and changed LAV back to bitstreaming and A/V sync enabled. madVR works for material that is 1080p, but when it rescales, the render time goes up to around 85ms and it starts dropping tons of frames (with VERY conservative settings).

I've tried a massive number of combinations of LAV settings and madVR settings and can never get it to stop dropping frames during rescale. Even tried bilinear on everything. No global processing is turned on. Turning off smooth motion had no effect.

The weird thing is if I use the exact same settings (didn't touch LAV or madVR) in MPC-BE on the exact same source material, it's working perfectly and not even breaking a sweat. As a matter of fact, I can nearly max out the scaling settings in MPC-BE and it's still got some headroom. And I verified that MPC-BE is actually using madVR because I can pull up the stats.

Is MediaPortal doing something strange to the chain that would cause madVR to struggle?

I'm back on EVR for now until I have more ideas and a couple of hours to tinker.
 

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,719
    1,267
    Germany Germany
    Country flag
    Are you using the same LAV with MPC-BE and MP? MPC_BE's default settings use an internal version of LAV? To use and verify your LAV setup for MP using MPC-BE you need to deselect all internal filters and select all available LAV decoders and splitters in the external filters settings, in MPC-BE, that way both will be using the exact same version and LAV setup. Sorry if you have already done that but it was not clear in your post.
    I use Madvr though not yet at 4K, and have not noted any difference between the playback with MP or MPC-BE.
    If you click on the LAV video icon in the system tray when playing a video are you seeing your GPU listed as the "Active Hardware Accelerator"for both players?
     

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    Are you using the same LAV with MPC-BE and MP? MPC_BE's default settings use an internal version of LAV?
    Confirmed. I just started using MPC-BE not long ago for my general purpose media player, so being unfamiliar, I was careful to make sure it was using my LAV / madVR filters.

    If you click on the LAV video icon in the system tray when playing a video are you seeing your GPU listed as the "Active Hardware Accelerator"for both players?
    Yes, with either player, LAV reports it's using my GTX 1650.

    One thing I have determined is if I disable VSync in the nvidia driver control panel, the rendering time drops to normal with madVR in MP, but of course I start getting tearing. I tried this VSync off test after seeing another users post where it worked for him. He may have not noticed the tearing though.

    Out of an abundance of caution, I reset the nVidia settings to default, then just turned on VSync and the Performance power setting, but same results.

    Going to compare graphs next and see if there are any differences.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,719
    1,267
    Germany Germany
    Country flag
    What are you using for a "Hardware Decoder" in LAV? In the attached screenshot I use DXVA2 (copy-back) as I have an AMD GPU, for Nvidia DXVA2 (native) is recommended but also give D3D11 a try, for me that will play HDR vids without stuttering but has a problem with Madvr and TV channel changing. Though still don't understand why there is a difference with MPC-BE.:unsure:
    lav.jpg
     

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    Was on D3D11, but dxva2 native has the same result.

    madVR shows the render queue is very low and the present queue bottoming out in MP1. In MPC they're running at or near the queue depth setting (8).

    Very weird.

    I'm still horsing around trying to get current proppage.dll files so I can look at graphs, but I have to go to work in a couple of minutes, so this will have to wait for a while again.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,719
    1,267
    Germany Germany
    Country flag
    Might be interesting to compare CPU usage when playing the same vid with both players.
    For reference I have attached screenshots of Madvr stats and TaskManager, 1&2 are for MP and 3&4 are for MPC-BE for the same dvd up-scaled to FullHD. There does seem to be a higher GPU usage for MP.

    dvd_1.jpg dvd_2.jpg dvd_3.jpg dvd_4.jpg
     
    Last edited:

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    I will look at task manager stats in my next session.

    Also, supposedly there is a way to get madVR to display the amount of time it's using for each part of it's process (totalling up to the render time) but I haven't looked into how to turn that on.
     
    Last edited:

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    MediaPortal doesnt touch the video, correct? It just builds the graph for the file and runs it?

    The only difference between players should be their rendering of an osd when displayed?
     
    Last edited:

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    So no difference in CPU between MPC-BE and MP1. GPU difference was just 2-3%.

    Here is one thing I did notice:
    • In MPC-BE, in both windowed and full screen, madVR shows the display as 59.996 8 bit, RGB, limited
    • In MP1 windowed, madVR says display is 59.996 8 bit, RGB, limited
    • In MP1 full screen, madVR says display 23.9758 8 bit, RGB, limited
    Also, I noticed in MP full screen madVR stats shows scaling as "zoom 100%". I had watched an old DVD rip the other night (using EVR) and had to change the aspect to get it full width. Changing the aspect to "normal" tonight reduced the render time some. Interestingly, if the aspect is on zoom or stretch the render time dropped to a few MS.

    FWIW, I also tried an older version of LAV which had no effect on the problem.

    It's in use right now, but when I get a chance I'll see what EVR does between windowed and full screen.

    Here are some low res captures of the madVR stats (note CPU is usually 14% but I remote accessed the machine to get screen shots which bumped up the CPU a few percent but did not affect anything else).

    MPC.jpg


    MP1.jpg
     
    Last edited:

    TBacker

    Portal Member
    June 23, 2011
    25
    4
    Country flag
    Here's the log from MP1 from the time I started playing the file windowed through changing to full screen then stopping.

    By the way, I'm using the old StreamedMP skin, so there are a couple of warnings about obsolete calls.

    The transition from windowed to full is at 20:46:19.

    Code:
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] - g_Player.Play(\\192.168.9.30\Video Library\Movies\2012\2012.mp4 Video)
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] - Loading external players plugins
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] -   found plugin:MediaPortal.WinampPlayer.WinampPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] -   player:Winamp.  author: int_20h
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] -   found plugin:MediaPortal.ITunesPlayer.ITunesPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] -   player:iTunes.  author: Frodo
    [2020-06-01 20:46:16,147] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:play \\192.168.9.30\Video Library\Movies\2012\2012.mp4
    [2020-06-01 20:46:16,163] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Enabling DX9 exclusive mode
    [2020-06-01 20:46:16,163] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
    [2020-06-01 20:46:16,804] [Log    ] [MPMain   ] [INFO ] - VMR9: backup current refresh rate value 60Hz
    [2020-06-01 20:46:16,981] [Log    ] [MPMain   ] [INFO ] - VMR9: added madVR Renderer to graph
    [2020-06-01 20:46:17,211] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found H264 video out pin
    [2020-06-01 20:46:17,212] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found HEVC video out pin
    [2020-06-01 20:46:17,333] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Added filter: LAV Video Decoder to graph
    [2020-06-01 20:46:17,337] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: AddAudioRenderer - Attach volume handler device to audio renderer: LG TV (NVIDIA High Definition Audio)
    [2020-06-01 20:46:17,915] [Log    ] [MPMain   ] [INFO ] - Mixer: changed audio device to : LG TV (NVIDIA High Definition Audio)
    [2020-06-01 20:46:17,919] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: First try to insert new audio renderer LG TV (NVIDIA High Definition Audio)
    [2020-06-01 20:46:17,920] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Found audio renderer
    [2020-06-01 20:46:17,921] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found AAC LAVF Audio out pin
    [2020-06-01 20:46:17,922] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found AAC Audio out pin
    [2020-06-01 20:46:17,964] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Added filter: LAV Audio Decoder to graph
    [2020-06-01 20:46:18,641] [Log    ] [MPMain   ] [INFO ] - MpcEngine: Subtitle VideoPlayer CultureInfo en
    [2020-06-01 20:46:18,649] [Log    ] [MPMain   ] [INFO ] - VideoPlayerVMR7: AudioLanguage CultureInfo en
    [2020-06-01 20:46:18,653] [Log    ] [MPMain   ] [INFO ] - VideoPlayerVMR7: CultureInfo Selected active audio track language: English (0)
    [2020-06-01 20:46:18,658] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x800
    [2020-06-01 20:46:18,659] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:800
    [2020-06-01 20:46:18,659] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1659x933
    [2020-06-01 20:46:18,660] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    [2020-06-01 20:46:18,660] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    [2020-06-01 20:46:18,661] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,800)
    [2020-06-01 20:46:18,661] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,120)-(1659,811)
    [2020-06-01 20:46:18,711] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x800
    [2020-06-01 20:46:18,712] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:800
    [2020-06-01 20:46:18,712] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1659x933
    [2020-06-01 20:46:18,714] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    [2020-06-01 20:46:18,715] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    [2020-06-01 20:46:18,716] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,800)
    [2020-06-01 20:46:18,717] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,120)-(1659,811)
    [2020-06-01 20:46:18,718] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:Duration:9469.525
    [2020-06-01 20:46:18,719] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStarted() \\192.168.9.30\Video Library\Movies\2012\2012.mp4 media:Video
    [2020-06-01 20:46:18,768] [Log    ] [MPMain   ] [INFO ] - PlaneScene: video WxH  : 25x25
    [2020-06-01 20:46:18,769] [Log    ] [MPMain   ] [INFO ] - PlaneScene: screen WxH : 1659x933
    [2020-06-01 20:46:18,769] [Error  ] [MPMain   ] [ERROR] - PlaceScene: RenderLayers: Error in the application.
    [2020-06-01 20:46:18,796] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: video WxH  : 1660x933
    [2020-06-01 20:46:18,797] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: screen WxH : 1659x933
    [2020-06-01 20:46:19,057] [Log    ] [MPMain   ] [INFO ] - g_Player: ShowFullScreenWindow switching to fullscreen video
    [2020-06-01 20:46:19,174] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x800
    [2020-06-01 20:46:19,175] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:800
    [2020-06-01 20:46:19,175] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1659x933
    [2020-06-01 20:46:19,176] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    [2020-06-01 20:46:19,176] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    [2020-06-01 20:46:19,177] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,800)
    [2020-06-01 20:46:19,177] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,120)-(1659,811)
    [2020-06-01 20:46:19,707] [Log    ] [MPMain   ] [INFO ] - Main: Deactivation request received
    [2020-06-01 20:47:26,114] [Log    ] [MPMain   ] [INFO ] - Main: Activation request received
    [2020-06-01 20:47:30,309] [Log    ] [MPMain   ] [INFO ] - D3D: Switching from windowed mode to full screen
    [2020-06-01 20:47:30,316] [Log    ] [MPMain   ] [INFO ] - Main: Overriding size from 1678x1017 to 1678x973 (Skin resized to 1678x943)
    [2020-06-01 20:47:30,322] [Log    ] [MPMain   ] [INFO ] - Main: Overriding size from 1656x961 to 1656x931 (Skin resized to 1656x931)
    [2020-06-01 20:47:30,327] [Log    ] [MPMain   ] [INFO ] - D3D: Client Size: 1920x1080
    [2020-06-01 20:47:30,328] [Log    ] [MPMain   ] [INFO ] - D3D: Screen size: 1920x1080
    [2020-06-01 20:47:30,337] [Log    ] [MPMain   ] [INFO ] - Load fonts from: C:\ProgramData\Team MediaPortal\MediaPortal\Skin\StreamedMP\fonts.xml
    [2020-06-01 20:47:31,202] [Log    ] [MPMain   ] [INFO ] - xml:C:\ProgramData\Team MediaPortal\MediaPortal\Skin\StreamedMP\videoOSD.xml image id:350 width:0 height:0 gfx:-
    [2020-06-01 20:47:31,211] [Log    ] [MPMain   ] [INFO ] - xml:C:\ProgramData\Team MediaPortal\MediaPortal\Skin\StreamedMP\videoOSD.xml image id:350 width:0 height:0 gfx:-
    [2020-06-01 20:47:31,220] [Log    ] [MPMain   ] [INFO ] - PlaneScene: video WxH  : 25x25
    [2020-06-01 20:47:31,220] [Log    ] [MPMain   ] [INFO ] - PlaneScene: screen WxH : 1920x1080
    [2020-06-01 20:47:31,236] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x800
    [2020-06-01 20:47:31,236] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:800
    [2020-06-01 20:47:31,237] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1920x1080
    [2020-06-01 20:47:31,237] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    [2020-06-01 20:47:31,238] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    [2020-06-01 20:47:31,238] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,800)
    [2020-06-01 20:47:31,239] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,140)-(1920,940)
    [2020-06-01 20:47:31,671] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: video WxH  : 1920x1080
    [2020-06-01 20:47:31,671] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: screen WxH : 1920x1080
    [2020-06-01 20:47:31,695] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x1080
    [2020-06-01 20:47:31,695] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:800
    [2020-06-01 20:47:31,696] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1920x1080
    [2020-06-01 20:47:31,696] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    [2020-06-01 20:47:31,697] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    [2020-06-01 20:47:31,697] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,1080)
    [2020-06-01 20:47:31,698] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,140)-(1920,940)
    [2020-06-01 20:47:42,874] [Log    ] [MPMain   ] [INFO ] - Main: Deactivation request received
    [2020-06-01 20:48:19,633] [Log    ] [MPMain   ] [INFO ] - Main: Activation request received
    [2020-06-01 20:48:42,565] [Log    ] [MPMain   ] [INFO ] - Main: Stopping media
    [2020-06-01 20:48:42,567] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStopped()
    [2020-06-01 20:48:42,576] [Log    ] [MPMain   ] [INFO ] - GUIVideoFiles: OnPlayBackStopped idFile=30 timeMovieStopped=894 resumeData= bdtitle=0
    [2020-06-01 20:48:42,599] [Log    ] [MPMain   ] [INFO ] - RadioRecorded:OnPlayRecordingBackStopped Video \\192.168.9.30\Video Library\Movies\2012\2012.mp4
    [2020-06-01 20:48:42,600] [Log    ] [MPMain   ] [INFO ] - TvRecorded:OnPlayRecordingBackStopped Video \\192.168.9.30\Video Library\Movies\2012\2012.mp4
    [2020-06-01 20:48:42,609] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:ended \\192.168.9.30\Video Library\Movies\2012\2012.mp4
    [2020-06-01 20:48:42,610] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup DShow graph
    [2020-06-01 20:48:42,611] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VMR9
    [2020-06-01 20:48:42,614] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: video WxH  : 1920x1080
    [2020-06-01 20:48:42,615] [Log    ] [madVR - RenderGui] [INFO ] - PlaneScene: screen WxH : 1x1
    [2020-06-01 20:48:43,203] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VideoCodec
    [2020-06-01 20:48:43,214] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioCodec
    [2020-06-01 20:48:43,215] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioRenderer
    [2020-06-01 20:48:43,228] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup InterfaceSourceFilter
    [2020-06-01 20:48:43,229] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess
    [2020-06-01 20:48:43,229] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess MediaPortal AudioSwitcher
    [2020-06-01 20:48:43,231] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter madVR
    [2020-06-01 20:48:43,232] [Log    ] [MPMain   ] [INFO ] - Playback stopped and reverting volume OSD back to default device.
    [2020-06-01 20:48:43,828] [Log    ] [MPMain   ] [INFO ] - Mixer: changed audio device to default : LG TV (NVIDIA High Definition Audio)
    [2020-06-01 20:48:43,931] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Graphbuilder
    [2020-06-01 20:48:43,997] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Sub/PostProcess
    [2020-06-01 20:48:44,146] [Log    ] [MPMain   ] [INFO ] - Playback stopped and reverting volume OSD back to default device.
    [2020-06-01 20:48:44,389] [Log    ] [VMR9 madVR Stop thread] [INFO ] - VMR9: madVr CommandThread aborded Cannot access a disposed object.
    Object name: 'The event has been disposed.'.
    [2020-06-01 20:48:44,719] [Log    ] [MPMain   ] [INFO ] - Mixer: changed audio device to default : LG TV (NVIDIA High Definition Audio)
    [2020-06-01 20:48:44,720] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Disabling DX9 exclusive mode
    [2020-06-01 20:48:44,720] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
    [2020-06-01 20:48:44,722] [Log    ] [MPMain   ] [INFO ] - GUIVideoFullscreen:stop
    [2020-06-01 20:48:45,170] [Log    ] [MPMain   ] [INFO ] - TexturePacker:Dispose()
    [2020-06-01 20:48:45,170] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1999
    [2020-06-01 20:48:45,171] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1997
    [2020-06-01 20:48:45,172] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1995
    [2020-06-01 20:48:45,172] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1994
    [2020-06-01 20:48:45,172] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1996
    [2020-06-01 20:48:45,173] [Log    ] [MPMain   ] [INFO ] - TexturePacker: remove texture:1988
    [2020-06-01 20:48:45,174] [Log    ] [MPMain   ] [INFO ] - D3D: BuildPresentParams CalcMaxClientArea from: 1813x1020
    [2020-06-01 20:48:45,174] [Log    ] [MPMain   ] [INFO ] - D3D: BuildPresentParams screen WorkingArea from: 1920x1020
    [2020-06-01 20:48:45,175] [Log    ] [MPMain   ] [INFO ] - D3D: BuildPresentParams ClientSize from: 1920x1080
    [2020-06-01 20:48:45,175] [Log    ] [MPMain   ] [INFO ] - D3D: BuildPresentParams screen from: 1920x1080
    [2020-06-01 20:48:45,176] [Log    ] [MPMain   ] [INFO ] - D3D: BuildPresentParams size from: 1920x1080
    [2020-06-01 20:48:45,176] [Log    ] [MPMain   ] [INFO ] - D3D: Back Buffer, size: 1920x1080, windowed:False, count:4
     

    Users who are viewing this thread

    Similar threads

    Top Bottom