MCE Remote has no focus (1 Viewer)

Fab55
Country flag

Portal Pro
November 29, 2007
79
9
Home Country
Germany Germany
Hi,

I control the Mediaportal with a standard MCE remote control (IR).
Often, when I start the Mediaportal 2, the remote control or the Mediaportal has no focus - means: no button on remote will result in an action.
When I press any key on the keyboard (or moving the mouse), the focus is in Mediaportal and the remote works.
This happens also sometimes after standby.
Is there a setting (like 'Always focus in fullschreen')?
Or is there a chance to get the focus by pressing a 'special configured' button on remote?

Thanks and best regards
Fab55
 

CyberSimian
Country flag

Test Group
  • Team MediaPortal
  • June 10, 2013
    1,851
    1,109
    Southampton
    Home Country
    United Kingdom United Kingdom
    Or is there a chance to get the focus by pressing a 'special configured' button on remote?
    I am not familiar with MP2, but what happens when you press the START ("Green Marble") button on the remote? Does it cause MP2 to regain the focus?

    -- from CyberSimian in the UK
     

    HTPCSourcer
    Country flag

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,404
    2,329
    Home Country
    Germany Germany
    This is a known issue for some people in some cases. Sadly we have never been able to identify the root cause and find an ultimate solution. The software contains a lot of code that theoretically should ensure MP2 to gain the focus, but results prove us wrong.
     

    Fab55
    Country flag

    Portal Pro
    November 29, 2007
    79
    9
    Home Country
    Germany Germany
    I developed different software applications (under .Net), which have to be the topmost application.
    To set the 'Always on top' window properties was always enough.
    Is there a 'Watchdog' like Mediaportal 1 has? This watchdog can restart the Mediaportal in case of crash AND ensure, that the Mediaportal is always the focused, topmost application (if configured, or if in FullScreen-Mode).

    I am not familiar with MP2, but what happens when you press the START ("Green Marble") button on the remote? Does it cause MP2 to regain the focus?
    Unfortunately not. The focus comes not back. The only way to get the focus is: Click with the mouse anywhere on the Mediaportal GUI.
     

    joecrow
    Country flag

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,599
    1,204
    Home Country
    Germany Germany
    This is very curious, I have seen exactly the same problem for a long time on my desktop pc where I run various test versions both MP 1 & 2, it happens intermittently on both after a manual MP start (I never use sleep/hibernate or MP auto start on this PC). My HTPC runs the same version of Win 10 and has an identical remote but has never shown the same problem.
     
    Last edited:

    Fab55
    Country flag

    Portal Pro
    November 29, 2007
    79
    9
    Home Country
    Germany Germany
    I found and activated the MP2-ClientLauncher. I will try if this can fix my focus problem.
     

    Cordraconis
    Country flag

    Portal Pro
    July 26, 2016
    82
    2
    Home Country
    Belgium Belgium
    I just happened to pass by here.

    I had the same problem a few years ago on my unsupported OS. (Search the forum for my posts.) Stopped using the MCE remote since my wireless mini-keyboard was more usefull for the other stuff I do with the server, however ... I noticed the "focus problem" was when it came out of standby/screensaver.
    My solution was to first press one of the "up" buttons on the remote, wait a sec untill the screensaver was gone and the desktop became visible, THEN press the green button to power up Mediaportal 2 GUI. Then it had focus and kept it.
    (The up-button is the same as the one on the keyboard, while the other buttons are mostly keyboard-combinations (like shift+up) that do other stuff. By first pressing a "pure" button on the keyboard/MCE, it seems focus gets more ... well ... focused on the task at hand, i.e. MP2.)

    Hope this helps AND is still relevant, since I haven't tested it, but if my memory serves me right...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom