MP2 - V2.3.2 [solved] media import (1 Viewer)

kevin939

Portal Pro
June 16, 2007
141
3
Home Country
United Kingdom United Kingdom
Country flag
I have set up a server/client environment and imported media which are on the server.

Films and series imported OK but not all items appear in the library. Audio was worse - the directories for each album were imported and appear when I browse media. Looking at the server logs all the audio files were also imported - same number of imports as audio tracks. However, when I try and select the album the cover appears but there is no content. All audio is FLAC.

Not at all sure how to proceed - is it possible to increase the logging to confirm the import?

Thanks in advance for any pointer.
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    You can set the the log files to debug level to get more infos. All details incl. how to report them are described here.
    To get media items correctly importent, best is to tag them with tinyMediaManager or MediaBuddy in advance and just import the local data. In case online scrapping is enabled you need to ensure the correct names as described in wiki.
    FLAC files are ok, here also tagging or correct naming are important.

    You may also enable more online sources in settings to get better match results.
     

    kevin939

    Portal Pro
    June 16, 2007
    141
    3
    Home Country
    United Kingdom United Kingdom
    Country flag
    Thanks ge2301, I will adjust the debug level ASAP and see if that gives me a clue.
    As regard tagging - MP1 and Kodi handle the files perfectly as did a single PC installation (client/server) of MP2 where the files were accessed over the network.... ahhh I wonder if that is different?
    I added the same media as configured as server based to a client as "local" - just network connected. I get the same problem on accessing the media "no items to display"

    Is there something different about how MP2 handles the tags or the file structure in client/server mode?
     

    kevin939

    Portal Pro
    June 16, 2007
    141
    3
    Home Country
    United Kingdom United Kingdom
    Country flag
    I have set diagnostics to DEBUG and see that the media is being imported, lots of examples similar to this:

    [2021-05-05 13:00:09,548] [61387186] [332 ] [DEBUG] - MediaAccessor: Importing file 'G:\Music\AlbumsHD\Roxy Music - Flesh and Blood [24-88.2]\01 - In The Midnight Hour.flac'


    I have disabled online scraping. Still no joy - the directories which correspond to albums exist but selecting them shoes no content. I cannot see anything in the server or client log to indicate the media item is being selected

    Importing other media appears to work a little better but many files are missing - and they have the same permissions and format as the ones that have been imported.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Try once to import them as network share and not local share. I remember a case with similar issues and this helped.
     

    kevin939

    Portal Pro
    June 16, 2007
    141
    3
    Home Country
    United Kingdom United Kingdom
    Country flag
    Not sure what you mean by "network" and "local" share. The files are on a desktop PC which is running MP2 server. They are shared via Windows (//server/directory). I have configured MP2 clients (laptop and another desktop) to access these files as "local" to the client (//server/directory) and the directories/folders appear within MP2 but have no content. Same if I configure the server to access them (G:\directory)

    MP1/kodi have no problem with the content

    Really don't know where to go next - other than back to kodi/MP1 [the problem there is that kodi doesn't handle refresh changes well with my new TV and MP1 needs the TV server on the same PC - my TV cards are on the server PC not the client which is a laptop)
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Not sure what you mean by "network" and "local" share. The files are on a desktop PC which is running MP2 server. They are shared via Windows (//server/directory). I have configured MP2 clients (laptop and another desktop) to access these files as "local" to the client (//server/directory) and the directories/folders appear within MP2 but have no content. Same if I configure the server to access them (G:\directory)
    When adding media sources you have 2 choices:
    1620293232080.png


    You used the first one (local), please use the second one (also works for local data) and try another import.

    Apart from that you can attach your logs here, so we can look for problems.
     

    kevin939

    Portal Pro
    June 16, 2007
    141
    3
    Home Country
    United Kingdom United Kingdom
    Country flag
    Same directory structure containing audio imported both ways - no difference, structure there but no content. Will remove all media, restart both server and client to get smaller logs, then specify & import just audio directory then post both client and server logs.
     

    kevin939

    Portal Pro
    June 16, 2007
    141
    3
    Home Country
    United Kingdom United Kingdom
    Country flag
    Cleared all media down, reloaded server then client PCs. - TV Recording is persistent however.

    Imported AlbumsHD [folder with folders within, each is an album) as server import - logs siCleint & siServer. Clint has no audio media

    Cleared down again and restarted client/server PCs. Imported AlbumsHD as local filestore of client - //AMDA8/AlbumsHD. logs ciClient & ciServer. Client shows some files but certainly not all [there are about 150 folders within AlbumsHD] no covers are bing shown

    Any help appreciated
     

    Attachments

    • siClient.log
      253.2 KB · Views: 0
    • siServer.log
      1.2 MB · Views: 0
    • ciClient.log
      238.3 KB · Views: 0
    • ciServer.log
      87.7 KB · Views: 0

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Cleared all media down, reloaded server then client PCs. - TV Recording is persistent however.

    Imported AlbumsHD [folder with folders within, each is an album) as server import - logs siCleint & siServer. Clint has no audio media

    Cleared down again and restarted client/server PCs. Imported AlbumsHD as local filestore of client - //AMDA8/AlbumsHD. logs ciClient & ciServer. Client shows some files but certainly not all [there are about 150 folders within AlbumsHD] no covers are bing shown

    Any help appreciated
    I took a look, according to log files you are using different versions of MP2. Can this be?
    Client: MP2.2.3_Final-13631b - 2.2.1912.12158
    Server: MP2.3_Final-bd2b8b - 2.3.2010.13341

    Please install MP2.3.2 for all clients and server.
    You may also add the "network credentials". If you have no password, activate them and leave both fields empty.
     

    Users who are viewing this thread

    Similar threads

    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same problem exists with other EPG sources, such as the broadcast EPG that I use with DVB-T/T2. When a programme first appears in the EPG (7 days ahead of its broadcast time), some programmes have a generic...
    Thank you for performing this test, and confirming @joecrow 's suspicion as to the cause of the problem. In principle the same...
    TV Server 1.25. Windows 10. This has been an issue for many years, if not since inception, and I hoped it would be resolved...
    Replies
    10
    Views
    1K
    Please find the log files attached. At first I had all files in a simple "test" directory. This caused it to crash with a reference to line 36561. Searching for said line lead to to a forum post that hinted at the importance of the directory structure. Once I found that, I could sort the issue myself.
    Please find the log files attached. At first I had all files in a simple "test" directory. This caused it to crash with a reference...
    Hallo liebe Mediaportalcommunity, da ich recht neu zum MP2 gekommen bin, weiß ich nicht ob mein Problem ein echter Bug oder nur...
    Replies
    26
    Views
    1K
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
    We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
    Replies
    4
    Views
    2K
    • Sticky
    We are proud to present MediaPortal 2.3.2 MediaPortal 2.3.2 is a full-blown media center software that addresses the most common user requirements out of the box. Aside from its support for Live TV and Radio, it offers a complete media server for music, movies, and TV shows. Info is automatically downloaded from various sources to...
    We are proud to present MediaPortal 2.3.2 MediaPortal 2.3.2 is a full-blown media center software that addresses the most common...
    We are proud to present MediaPortal 2.3.2 MediaPortal 2.3.2 is a full-blown media center software that addresses the most common...
    Replies
    0
    Views
    799
    I have just tested the dll, and it works fine on my thpc too :)(y) Thanks
    I have just tested the dll, and it works fine on my thpc too :)(y) Thanks
    Since the update to MediaPortal 1.27 it takes about three seconds to jump to the next or previous track. Also adding files and...
    Replies
    11
    Views
    2K
    Top Bottom