media portal crashes when moving pictures configuration is opened

Discussion in 'Moving Pictures' started by Buttmnky, September 24, 2012.

  1. Buttmnky

    Buttmnky New Member

    Joined:
    September 24, 2012
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    I installed the latest Media Portal and Moving Pictures. Had about 300+ movies matches up with Moviespictures and then received the following error below. Now whenever i try to open the moving pictures configuration to add more movies, it keeps locking up and giving teh same error.

    Running Win 7 Enterprise.


     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Paranoid Delusion
    • Team MediaPortal

    Paranoid Delusion Moderation Manager

    Joined:
    June 13, 2005
    Messages:
    13,062
    Likes Received:
    1,481
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Cheshire
    Ratings:
    +1,482 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Buttmnky, lol what a name ;)

    What you can try, go to the windows Start menu, find Team-Mediaportal\Mediaportal\user files, look in the database folder and try moving the movingpictures.db to the desktop, now can you start config.exe.

    If that is not the problem, then we need logs, follow the instructions from the link in my signature.

    Regards
     
  4. Buttmnky

    Buttmnky New Member

    Joined:
    September 24, 2012
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    All it did by moving the database file was start me with a fresh empty database. I will submit the logs, but is there something i am missing in your instructions as well? If i import my movies again, it just does the same thing. I uninstalled and reinstalled with the same results.[DOUBLEPOST=1348494338][/DOUBLEPOST]Attached is the log file. To recap.

    I was importing about 30 movies and the moving pictures config page locked up and gave the error that started this thread. I receive the error everytime i try to launch the mving pictures config or media portal. I removed the movingpics db file and started a fresh session with no issues. As soon as i get so far in adding movies, it does the same thing.
     
  5. Paranoid Delusion
    • Team MediaPortal

    Paranoid Delusion Moderation Manager

    Joined:
    June 13, 2005
    Messages:
    13,062
    Likes Received:
    1,481
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Cheshire
    Ratings:
    +1,482 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    But you could open MP config, which confirmed it is related to MovPics, now we need logs, mediaportal debug mode (watchdog) option 3 and upload them here.
     
  6. Paranoid Delusion
    • Team MediaPortal

    Paranoid Delusion Moderation Manager

    Joined:
    June 13, 2005
    Messages:
    13,062
    Likes Received:
    1,481
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Cheshire
    Ratings:
    +1,482 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    @RoChess
    @fforde

    Sadly besides seeing config.exe crashing in windows eventlog, cannot see anything in MovingPictures log to give me a idea of where the failure is occurring :(
     
  7. Buttmnky

    Buttmnky New Member

    Joined:
    September 24, 2012
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    I open Media Portal config. When i click on moving pictures then config, the window opens on the updating screen. It immediately just locks up, then gives me the original error, then closes. It does the same thing launching Media Portal as well. If I remove the database file, all works fine. Something in the file is causing the lockup.
     
  8. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,455
    Likes Received:
    4,239
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,379 / 0
    Home Country:
    Australia Australia
    From your event log the crash is residing in MediaInfo library. I think what is happening is that upon startup MovingPictures is scanning your library for missing mediainfo and encounters a file which freaks mediainfo out.

    There is a few things you can possibly do:

    1. Remove any new movies you recently added into your import paths before issue occurred, if you open successfully try adding one movie at a time until problem presents itself...you have then tracked down the problem file.

    2. Update MediaInfo library, you currently have
    Code (Text):
    1.  
    2. Faulting module name: MediaInfo.dll, version: 0.7.53.0
    3.  
    The latest version is 0.7.60: http://sourceforge.net/projects/med....60_Windows_i386_WithoutInstaller.7z/download
    Simply replace the file you currently have, maybe it was a known problem which has already been fixed.

    3. Disable MediaInfo scanning, since movingpics cant be opened you will need a db tool to open it with e.g. SQLite Database Browser .Open your MovingPictures database file with this tool and select Settings from the table dropdown list. Update the value importer_use_mediainfo to False. Save and try again.

    Hope that helps you.
     
    Last edited: September 25, 2012
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!