Media portal resumes with wrong screen resolution (1 Viewer)

robcarter

Portal Pro
February 19, 2010
99
4
England England
Country flag
Hi
using v1.21.000.0
When mediaportal resumes the screen resolution is set to a low resolution, if I exit mediaportal the desktop has the correct 1920 x 1080 resolution, then restart mediaportal everything is fine until the next standby / resume
Looking in the log (attached) there is this:
[2019-07-30 21:16:54,818] [Log ] [MPMain ] [DEBUG] - Main: Ignore spurious WM_GETMINMAXINFO for Windows native resolution
[2019-07-30 21:16:54,819] [Log ] [MPMain ] [DEBUG] - Main: WM_SIZE (SIZE_RESTORED: 1024x768)
I'm not sure if this is the issue, can anyone help?
Regards
Rob Carter
 

Attachments

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,136
    1,323
    Southampton
    United Kingdom United Kingdom
    Country flag
    using v1.21.000.0. When mediaportal resumes the screen resolution is set to a low resolution, if I exit mediaportal the desktop has the correct 1920 x 1080 resolution, then restart mediaportal everything is fine until the next standby/resume
    I don't have a specific solution for you, but this area of MP has been problematic for several releases now. This is a very complex area, and I think that it is the case that the developer who knows about this part of MP cannot reproduce the problem on his own system (making it exceedingly difficult to identify the origin of the problem).

    A possible solution is to upgrade to MP 1.22, as this may solve your problem (MP 1.22 contains some fixes that address this area).

    As a workaround, remember that you can avoid the problem by exiting to the Windows desktop before you sleep or hibernate your system. Your can define a button on your remote to invoke MP's exit dialogue, and the START button on your remote can start MP from the desktop when your next wake the system. (This is how I use my HTPC.)

    -- from CyberSimian in the UK
     

    robcarter

    Portal Pro
    February 19, 2010
    99
    4
    England England
    Country flag
    Thanks for the reply, I updated the package to the latest release (1.23 pre) but the problem still seems to occur. I'll try your suggestion with the remote.
    Regards
    Rob
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,136
    1,323
    Southampton
    United Kingdom United Kingdom
    Country flag
    I updated the package to the latest release (1.23 pre) but the problem still seems to occur.
    I notice that there is an MP start-up setting that may affect this, namely this one:

    startup_resume.jpg

    Whichever value that setting currently has, it might be worthwhile trying the other value, just to see if it makes a difference.

    -- from CyberSimian in the UK
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    J Copying Old VHS tapes Newcomers Forum 8
    C Media Portal 1.22 hängt neuerdings beim Start Allgemeines Supportforum 3
    O No Video playback on Media Portal 2.2.3 Newcomers Forum 2
    F Remote goes tos Media Center after Media Portal Remotes 2
    S Kommerzielle HTPC´s mit "selbst entwickelter Media center Distribution auf Basis von Media Portal" MediaPortal Café 9
    J Will Media Portal meet my requirements? General Support 4
    D media portal 2.2 have movies shown on genre not name General 6
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    D Media Portal wake schedule General Support 29
    P WMC on Windows 7 migrating to Media Portal on Windows 10 Newcomers Forum 5
    C DVB-C Empfänger Hauppauge Win TV dual wird in Media Portal nicht aktiviert TV / Streaming 1
    Patrik-See Unitymedia HD+ Fernsehen mit Media Portal legal möglich? TV / Streaming 0
    N What dvb-t/t2 dual or quad tuners work with media portal (in the UK)? Newcomers Forum 8
    A Enigma2 receiver channels on Windows PC with Media Portal help General Support 0
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    Wilma Fingerdo New to Media Portal General 2
    J Media Portal changes master volume level General Support 7
    G Media portal 2.2 erkennt Cam Modul nicht Allgemeines Support- und Diskussionsforum 33
    A media portal 2 genpix skywalker General 1
    T Media Portal 2 EPG data missing General 16
    S [solved] HOW TO INSTALL Media Portal Url Source Splitter Plugin Development 3
    toricred MP2 - V2.3 MP 2.3 Media Library Duplicates General 20
    F Media Port 1.16 to 1.25 Installation, configuration support 1
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    J Navigating media drive General 4

    Similar threads

    Top Bottom