MediaPortal 2 SR'15 Update 1 snapshot (2015-08-03)

Discussion in 'Development Snapshots' started by morpheus_xx, August 3, 2015.

  1. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,156
    Likes Received:
    4,788
    Ratings:
    +6,864 / 11
    Home Country:
    Germany Germany
    Show System Specs
    This is a TEST build for our upcoming "Update 1" of the Summer'15 Release.

    Main changes compared to Summer'15 Release are:
    • Reworked installer, it uses a bootstrapper to install dependencies
    • Fixes for SlimTV / TVE 3:
      • IPTV was broken, loading of plugins fixed, ini-file in correct location now (thanks to @mm1352000 !)
      • Fixed missing registration of MPEG muxer filter for analog (thanks @mm135200)
      • Updated core to MP1.12 version
      • Radio groups are visible in SlimTV client
      • New: allow parallel use of TVE3/3.5: ProgramData\Team MediaPortal\MP2-Server\SlimTvCore\v3.0 or v3.5 folders will be used for different data (due to differences in tuning details!). But still only one version can be run concurrently, of course!
      • New: allow "auto tune last channel" when entering TV
      • New: automatic creation of media sources for recordings. Note: this works only after you ran TV configuration once (settings need to be saved). Then you need to restart MP2-Server once.
      • New: Icon for TV configuration
    • Log collector now included, with link on desktop and start menu (using new icon as well)
    • Fix for NetworkConnectionTracker (improved detection of virtual NICs)
    • Update for "OneTrueError" service plugin to avoid huge amount of TVE3 exceptions to be reported
    • OnlineVideos 2 plugin is not contained, please backup and restore it after install
    If you experience errors, please post logfiles here. A link to Log Collector can be found on your Desktop and Start Menu!



    Download link: http://tinyurl.com/nqajwtm

    @Testers , @Developers , @Designers

    Please post feedback about installation result and also TV related fixes!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    I did a completed uninstall on my server (WV-Server) and my client (Sylvester)
    Completed the install for Server Only on WV-Server and configured all the TV Side

    Completed Client Only install on Sylvester and configured.
    When starting TV on Sylvester I get the following

    [2015-08-03 13:40:00,335] [13458 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to show screen 'SlimTvClient-main'...
    [2015-08-03 13:40:00,367] [13489 ] [Thread9 ] [ERROR] - Error invoking action 'GetNowNextProgramForGroup'
    [2015-08-03 13:40:10,335] [23458 ] [AMQ 'NotificationsModel'] [ERROR] - Unhandled exception in message handler of async message queue 'NotificationsModel' when handling a message of type 'StatePushed'
    MediaPortal.UI.Presentation.Workflow.WorkflowManagerLockException: The workflow manager cannot be locked for read operation 'CurrentNavigationContext' (deadlock?)
    at MediaPortal.UI.Services.Workflow.WorkflowManager.EnterReadLock(String operation)
    at MediaPortal.UI.Services.Workflow.WorkflowManager.get_CurrentNavigationContext()
    at MediaPortal.UiComponents.SkinBase.Models.NotificationsModel.Update()
    at MediaPortal.UiComponents.SkinBase.Models.NotificationsModel.OnMessageReceived(AsynchronousMessageQueue queue, SystemMessage message)
    at MediaPortal.Common.Messaging.AsynchronousMessageQueue.DoWork()
    [2015-08-03 13:40:10,678] [23801 ] [Thread28 ] [ERROR] - Error invoking action 'GetNowNextProgramForGroup'
    [2015-08-03 13:40:10,912] [24035 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'SlimTvClient-main' successfully shown
     
  4. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    Went to start a TV Show on my client Sylvester.
    Tried 2 channels, all I got was a black screen

    [2015-08-03 14:40:01,091] [213825 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'SlimTvClient-main' successfully shown
    [2015-08-03 14:40:04,960] [217694 ] [InputMgr ] [INFO ] - Releasing filter System.__ComObject, remaining references: 1
    [2015-08-03 14:40:05,243] [217976 ] [AMQ 'SynchronizeToPrimaryPlayer'] [INFO ] - SkinEngine MainForm: SynchronizeToVideoPlayerFramerate: Restore default rendering, no new Player!
    [2015-08-03 14:40:16,976] [229710 ] [AMQ 'SynchronizeToPrimaryPlayer'] [INFO ] - SkinEngine MainForm: Synchronized render framerate to video player 'LiveTvPlayer: stream4.0'
     
  5. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,156
    Likes Received:
    4,788
    Ratings:
    +6,864 / 11
    Home Country:
    Germany Germany
    Show System Specs
    Thanks breese, if the playback problem remains for you, please set log level to ALL and create new logfiles.
     
  6. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    What file is that in again?
    Damn search is doing nothing for me
     
  7. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,156
    Likes Received:
    4,788
    Ratings:
    +6,864 / 11
    Home Country:
    Germany Germany
    Show System Specs
    C:\Program Files (x86)\Team MediaPortal\MP2-Client\MP2-Client.exe.config, line 51
     
  8. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    I turned the logging to ALL.
    Tried Live TV (CBS2), all I got was a black screen.

    To make sure it was not something else, I played a movie (A Bugs Life), worked as expected.
    [2015-08-04 05:35:01,560] [310457 ] [AMQ 'SynchronizeToPrimaryPlayer'] [INFO ] - SkinEngine MainForm: Synchronized render framerate to video player 'VideoPlayer: A Bug's Life.avi'
     
  9. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    Update.... The new machine I build somehow download and installed a new CC Video driver and killed the screen.
    I restored to last month and all is working!
    I am watching a OTA channel and am going to let it run All Night Long...
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  10. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 1
    Home Country:
    United States of America United States of America
    Show System Specs
    After leaving the TV running on my client Sylvester all night I found the TV locked up this morning.
    Seems there was an issue with the live4-0.tsbuffer roll overs.
    As you can see, there are a number of these files taking over 4G of space. btw: I thought the default was 4 or 5 files...
    Timeshift Folder.jpg

    As I look thru the logs I found
    [2015-08-05 03:59:54,844] [463bb28] [12d0] - pmtgrabber: got new pmt version:5 4, service_id:1
    [2015-08-05 03:59:54,844] [463bb28] [12d0] - pmtgrabber: NO callback done because a/v pids still the same.
    [2015-08-05 04:42:31,152] [463bb28] [12d0] - MultiFileWriter: failed to create file F:\Timeshifting\live4-0.ts.tsbuffer4.ts

    EDIT:
    I have no clients running and went to delete the buffer files in my timeshift folder, 3 files came up locked???
    live4-0.ts.tsbuffer
    live4-0.ts.tsbuffer2
    live4-0.ts.tsbuffer4
    I can understand these being locked but the just from #2 to #4? Would have expected #2 and #3
     

    Attached Files:

    • TsWriter.bak
      File size:
      32.3 KB
      Uploaded:
      August 5, 2015
      Views:
      132
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    Default is 6 files. The fact that you have 20 and that some files were locked suggests that TsWriter may have thought that TV at the client was paused.

    This part is normal.

    Yes, this part is related to whatever happened here.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!