[fixed] Mediaportal crashes on tuning some channels (1 Viewer)

elliottmc

Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    I have a sample ready but I'm not eager to upload this because of the adult content.:D
    Any volunteers?
    PMSL.

    As long as it doesn't involve children or animals, I'll take a look :D
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Hi,

    This file simply crashes Windows Media Player on my Vista machine.

    It plays fine in VideoReDo, and a quick stream fix reports

    Audio frame errors: 2
    Input Sequence Errors: 2
    Video resync frames removed: 3
    Video output frames: 798
    Audio output frames: 1330
    Processing time (secs): 0
    Processed frames/sec: 1378.24
    Actual Video Bitrate: 1.61 Mbps

    When playing the file in VideoReDo, there are a lot of video artifacts. My gut feeling is that you have poor signal quality, and some programs are not as capable of playing the stream.

    MediaPortal will not play this file (similar error to that you report) and error.log has

    Code:
    2011-05-19 22:38:38.254000 [ERROR][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    2011-05-19 22:38:38.287000 [ERROR][MPMain(1)]: TSReaderPlayer:GetInterfaces() failed
    2011-05-19 22:38:38.409000 [ERROR][MPMain(1)]: PlaylistPlayer: *** unable to play - E:\Misc Video\Dorcel TV.ts - skipping track!
    I am pretty sure my memory is not corrupt, so I assume that this is a bug, or at least there is enough wrong with this file that MediaPortal cannot cope.

    Full logs are attached.

    Mark
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Yeah, it isn't a memory issue. I've seen those kinds of errors before when trying to access variables that have gone out of scope etc.
     

    neefs

    Portal Member
    March 22, 2009
    33
    0
    Belgium Belgium
    It's surely not a bad signal issue (signal=100%).
    I think it's more a codec problem. I don't know how TS-reader is build up but i believe it uses the same codecs that Windows Mediaplayer uses. After my testing i know one thing: when Windows Mediaplayer can't play the file, Mediadioportal can't either.
    Changing codecs in Mediaportal setup doesn't change anything (in fact, I have never seen any visual difference when I changed codecs in the tv section)
    Isn't there any way to build up ts-reader the same way like e.g. VLC player (it can play almost any file unlike Windows Mediaplayer)? Perhaps this is something for the devs of MP2.:)

    I've uploaded a screenshot of MediaInfo with more info on the file I uploaded before.
    Maybe someone with codec experience can take a look at it.
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi again

    No, I'm pretty sure this is not a signal problem.
    - my installation of MP 1.2.0b using PDVD 10 video, AC3Filter and Monogram also doesn't play it
    - VLC 1.1.7 plays it perfectly (except for one small glitch, which could be a signal problem)
    - if I change the extension from TS to MPG then MP *does* play it, but not well - the audio is fine, but only the top half/third of the video shows

    I think there is something wrong at the stream level, and I don't have the skills to debug it :)sorry:). I will ask our C++ filter gurus. ;)
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    It's surely not a bad signal issue (signal=100%).
    Unfortunately those numbers are meaningless since there is no standard across different card manufacturers. I am going on the appearance of glitches in the stream.

    Mark
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi again neefs

    I know it has been a long time since anyone commented - this has been a tough problem. I think I have a solution! :D
    Are you able to try a patch for 1.2.0b?

    mm
     

    neefs

    Portal Member
    March 22, 2009
    33
    0
    Belgium Belgium
    A patch?
    I didn't know anyone was working on this.
    Sure I wanna play test dummie.
    Fire Away!
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    A patch?
    I didn't know anyone was working on this.
    Sure I wanna play test dummie.
    Fire Away!
    Hi neefs

    Yeah, I've got a handful of stream samples that wouldn't play in MediaPortal, so I decided to do some investigating. These things aren't always the highest priority but they eventually get looked at. If you're still using 1.2.0b then there is a patch -->here<-- that you can try. I'm told that Dorcel TV is not a 24 hour channel, so please keep in mind that you may need to test late at night. ;)

    mm
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    U [solved] MediaPortal crashing on startup General Support 10
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    Y MediaPortal/MP Configuration crashes after update 1.21 Pre Release 3
    A MediaPortal crashes when stepping through DVR-MS files Listen Music 2
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    Similar threads

























    Top Bottom