[Bug] MediaPortal crashing intermittently when interacting with the TV Guide (1 Viewer)

Andy_113

MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    Hi I found a problem on my system,

    The issue occurs while Interacting with the tv guide, and especially when adding/editing tv shows to the recording schedule the system will freeze and then crash. Before it crashes navigation and selecting a show in the column main guide stops working but you can still browse forward and backward in time as well as manually select a channel from the list to scroll down works as before. If continue to use it without exiting to the home screen it will then crash. If, however you exit to the home screen then re-enter to the tv guide functionality is then back to normal.
    I should mention i'm in the uk, am using freeview hd over DVB-T2 and the guide is the standard Broadcast over the air.
    I've included the debug information from the last crash.

    I should also mention this behavior has occurred on another system as well as on version 1.5 of mediaportal (the previous version tended to crash much more frequently than this version).
     
    Last edited by a moderator:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello and welcome Andy_113 :)

    Thanks for an excellent bug report! (y)

    Crash is here:
    [collapse]
    "26/11/2013 19:36:03";"Application Error";"Application Crashing Events";"Error";"Faulting application name: MediaPortal.exe, version: 1.5.100.0, time stamp: 0x528797b3 Faulting module name: clr.dll, version: 4.0.30319.1008, time stamp: 0x517a1be7 Exception code: 0xc00000fd Fault offset: 0x00025f8e Faulting process id: 0x1850 Faulting application start time: 0x01ceeadc2d87e800 Faulting application path: C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll Report Id: fbb98296-56d1-11e3-9b2a-aa625d8989ee";"1000"
    "26/11/2013 19:36:15";"Windows Error Reporting";"(0)";"Information";"Fault bucket 3986422091, type 1 Event Name: APPCRASH Response: Not available Cab Id: 0 Problem signature: P1: MediaPortal.exe P2: 1.5.100.0 P3: 528797b3 P4: clr.dll P5: 4.0.30319.1008 P6: 517a1be7 P7: c00000fd P8: 00025f8e P9: P10: Attached files: C:\Users\Andrew Bird\AppData\Local\Temp\WER7AFB.tmp.WERInternalMetadata.xml These files may be available here: C:\Users\Andrew Bird\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_MediaPortal.exe_9a698f8f8248aa82f78ad310e88bd3f435aee6f4_0727a90c Analysis symbol: Rechecking for solution: 0 Report Id: fbb98296-56d1-11e3-9b2a-aa625d8989ee Report Status: 0";"1001"[/collapse]

    I wonder if it is related to this:
    [collapse]
    [2013-11-26 19:35:13,950] [Log ] [Channel state thread] [ERROR] - ChannelState.DoSetChannelStates: An unknown error occured while setting channel states - select idTuning, idChannel, name, provider, channelType, channelNumber, frequency, countryId, isRadio, isTv, networkId, transportId, serviceId, pmtPid, freeToAir, modulation, polarisation, symbolrate, diseqc, switchingFrequency, bandwidth, majorChannel, minorChannel, videoSource, audioSource, isVCRSignal, tuningSource, band, satIndex, innerFecRate, pilot, rollOff, url, bitrate from TuningDetail where idChannel = ?idChannel;
    Error: StatementErrorUnclassified
    Gentle.Common.GentleException: select idTuning, idChannel, name, provider, channelType, channelNumber, frequency, countryId, isRadio, isTv, networkId, transportId, serviceId, pmtPid, freeToAir, modulation, polarisation, symbolrate, diseqc, switchingFrequency, bandwidth, majorChannel, minorChannel, videoSource, audioSource, isVCRSignal, tuningSource, band, satIndex, innerFecRate, pilot, rollOff, url, bitrate from TuningDetail where idChannel = ?idChannel; ---> System.Threading.ThreadAbortException: Thread was being aborted.
    at System.Net.UnsafeNclNativeMethods.OSSOCK.recv(IntPtr socketHandle, Byte* pinnedBuffer, Int32 len, SocketFlags socketFlags)
    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, SocketError& errorCode)
    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    at System.IO.BufferedStream.ReadByte()
    at MySql.Data.MySqlClient.MySqlStream.LoadPacket()
    at MySql.Data.MySqlClient.MySqlStream.OpenPacket()
    at MySql.Data.MySqlClient.NativeDriver.ReadResult(UInt64& affectedRows, Int64& lastInsertId)
    at MySql.Data.MySqlClient.MySqlDataReader.GetResultSet()
    at MySql.Data.MySqlClient.MySqlDataReader.NextResult()
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior behavior)
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteDbDataReader(CommandBehavior behavior)
    at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()
    at Gentle.Framework.SqlStatement.Execute(IDbConnection conn, IDbTransaction tr)
    --- End of inner exception stack trace ---
    at Gentle.Framework.SqlStatement.Execute(IDbConnection conn, IDbTransaction tr)
    at Gentle.Framework.PersistenceBroker.Execute(SqlStatement stmt, IDbConnection dbConnection, IDbTransaction dbTransaction)
    at TvDatabase.Channel.ReferringTuningDetail()
    at TvDatabase.TvBusinessLayer.GetTuningChannelsByDbChannel(Channel channel)
    at TvService.ChannelStates.DoSetChannelStates(IDictionary`2 cards, ICollection`1 channels, ICollection`1 allUsers, IController tvController)System.Threading.ThreadAbortException: Thread was being aborted.
    at System.Net.UnsafeNclNativeMethods.OSSOCK.recv(IntPtr socketHandle, Byte* pinnedBuffer, Int32 len, SocketFlags socketFlags)
    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, SocketError& errorCode)
    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    at System.IO.BufferedStream.ReadByte()
    at MySql.Data.MySqlClient.MySqlStream.LoadPacket()
    at MySql.Data.MySqlClient.MySqlStream.OpenPacket()
    at MySql.Data.MySqlClient.NativeDriver.ReadResult(UInt64& affectedRows, Int64& lastInsertId)
    at MySql.Data.MySqlClient.MySqlDataReader.GetResultSet()
    at MySql.Data.MySqlClient.MySqlDataReader.NextResult()
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior behavior)
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteDbDataReader(CommandBehavior behavior)
    at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()
    at Gentle.Framework.SqlStatement.Execute(IDbConnection conn, IDbTransaction tr)[/collapse]

    The timing is not exact, but it seems too close to ignore.
     

    Andy_113

    MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    Thanks, makes sense the problem starts before the crash as the browsing behavior changes so you cannot select the program info. I have another log i'll attach from a crash that has just happened if this is of any help.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hmmm, this time no exception in the log, so that blows my theory out of the water. :(
    Are you able to tell us exactly how you reproduce the crash so we can try to reproduce, or does it appear to be semi-random?
     

    Andy_113

    MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    It is semi random, sometimes just browsing the tv guide, does seem adding tv recordings triggers it. it was much worse on v1.5 also repeatable on a different maching with different tv tuner.

    Edit: If it would help i can try v1.5 and upload the logs for that aswell might give more information?

    Edit 2: I have uploaded logs for v1.5. On this version the crash happens when you return (By pressing back button on mce remote) from scheduleing a recording from the tv guide.
     
    Last edited:

    Andy_113

    MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    Ok, i've spent a lot of time troubleshooting this issue, it happens in versions 1.4, 1.5 and 1.6 (haven't tried any earlier versions). It also occurs on Windows 8.1 x64 as well as Windows 7 x64 SP1 (Both os's with full windows updates). It also occurs when using Microsoft's SQL Server Express 2008 R2. So its definately a mediaportal problem not a my sql database problem.

    The procedure to replicate:
    using the broadcast over-the-air dvb guide with all freeview + the hd channels over DVB-T2 on a Blackgold bgt3620 v8.1.1.2 driver System specs are in my details.
    1. go to the guide
    2. Select the channel then scroll down to a program
    3. select program, click advanced record
    4. select all episode on this channel
    5. go back twice to the main tuide.
    at this point is when the system crashes.

    Hope this Helps
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Thanks for the update.

    Unfortunately I'm not able to reproduce. :(
    Anybody else?
    I note that the TV tuner is definitely not related to the problem. I suspect the location and guide data source are not either.
     

    Andy_113

    MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    you're right its isn't the tv tuner as i've tried with a tbs tuner i have. I've also tried with guide sourced both from the webepg and xmltv with xmltv gui and it still crashes. As you can't replicate the issues is puzzling as i've replicated it on another machine with different hardware (still intel based but with onboard intel video). I've also tried, as i think i mentioned before, with a fresh install of windows 7 sp1 64 bit with just drivers and windows updates with the same result and again with windows 8.1 64 bit.

    So it has to be mediaportal client itself as i've ruled out everything else. Is defineatly one of the most puzzling issues i've ever come across. I'm determined though to find out what is happening, although out of ideas at the moment. i'd like too thank you and the other developers for the time and dedication to this project.

    Update: After further testing it appears the last version of mp without this problem is v1.2.3. Every version after is affected. I've also tested with my laptop which is a samsung r710 with a fresh windows 7 sp1 64 bit install and a hauppauge dvb-t card and found the same problem.
     
    Last edited:

    Andy_113

    MP Donator
  • Premium Supporter
  • November 26, 2013
    29
    8
    38
    United Kingdom United Kingdom
    ok, i've now tried with windows 7 sp1 32 bit with the same result. I've also tried a server/client combination but the client still crashes. I don't think there is anything more i can do now, the problem seems to be os independent, as it happens on different windows versions. Seems to also be hardware independent as it happens on different systems. The only thing that they all have in common is mediaportal client, and tv server setup using dvb-t/t2. It doesn't matter if i use webepg or xmltvgui or dvb broadcast guide data. It also seems to be database independent as i've tried microsoft sql 2008 and my sql 5.1 and 5.6.

    I've pinpointed it to something that has changed from v1.2.3 (last version that worked properly) to 1.3+ I did think it was the default theme but unfortunately it crashes with the frames theme too.

    Am very greatfull too the developers and hope can find the source of the problem.
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Thanks for investigating so thoroughly Andy_113. Unfortunately unless somebody is able to reproduce this we're not going to be able to find or fix the problem.

    Anybody else reading this thread: could you please take a moment to try and reproduce this problem. Please let us know your results whether you're able to reproduce the problem or not. From Andy_113's tests it seems unlikely that the problem is confined to his systems, however you never know...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    U [solved] MediaPortal crashing on startup General Support 10
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    Y MediaPortal/MP Configuration crashes after update 1.21 Pre Release 3
    A MediaPortal crashes when stepping through DVR-MS files Listen Music 2
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    Similar threads

























    Top Bottom