[solved] MediaPortal crashing on startup (1 Viewer)

ultimatejoe

Portal Member
October 14, 2007
44
5
Canada Canada
Country flag
MediaPortal is crashing on startup. This problem started yesterday; I hadn't made any changes to the software, installed any windows updates, or anything. I had added some new TV station logos but that's it. I went to start it and I'm now getting the dreaded "Failed to load your skin! Aborting startup. Out of memory" error.

When the error first showed up I assumed I tried a restart of the system. Then, looking at the log files I tried resizing a bunch of my TV logos because they were too large. I cleared my Skin cache (StreamedMP), tried switching skins, and even tried reinstalling the Arial font, so far nothing has made a lick of difference.

I've attached the Watchdog files for reference. If there is any additional information let me know. I can't find where to add my system specs to my profile (been a while since I've been to the forums so here goes:

MP Version: 1.23
OS: Windows 10
CPU: AMD Phenom II X4 965 (3.40gHz)
Memory: 6GB
GPU: NVIDI Geforce GT 710
 

Attachments

ultimatejoe

Portal Member
October 14, 2007
44
5
Canada Canada
Country flag
FYI, I tried upgrading to 1.24; I no longer get the out of memory pop-up, it just crashes to desktop with the same error logs.
 

ultimatejoe

Portal Member
October 14, 2007
44
5
Canada Canada
Country flag
Well, I was able to fix it. In desperation I tried removing all of my TV station logos, (I had added a half-dozen to the system a couple of days ago) and it loaded just fine.

I then tried to resize a bunch of them to make them smaller to see if it was a caching issue, and one of them apparently had an incorrect file extension. Deleting that one and resizing the rest seems to have solved the problem. Don't know it was, but the problem is solved. Apologies who took the time to actually read through my logs.
 

doskabouter

Development Group
  • Team MediaPortal
  • September 27, 2009
    3,887
    2,118
    Nuenen
    Netherlands Netherlands
    Country flag
    Can you give me the offenfing logo? I want to see if there is at least some proper errorhandling and logging, so this can be more easily identified next time
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,887
    2,118
    Nuenen
    Netherlands Netherlands
    Country flag
    Hm, no issues here with that logo.
    And judging by the logfile of mediaportal I think the crashes had a different cause...
    What exactly is a bit of a mystery for me
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,653
    8,196
    Kyiv
    Ukraine Ukraine
    Country flag
    Here is the main problem, this happens when font registration has flown.
    Code:
    [2020-05-08 10:06:19,750] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Exception loading fonts C:\ProgramData\Team MediaPortal\MediaPortal\Skin\StreamedMP\fonts.xml err:Cannot access a disposed object.
    Object name: 'MediaPortalApp'. stack:   at System.Windows.Forms.Control.CreateHandle()
       at System.Windows.Forms.Form.CreateHandle()
       at System.Windows.Forms.Control.get_Handle()
       at System.Windows.Forms.Control.CreateGraphicsInternal()
       at System.Windows.Forms.Control.CreateGraphics()
       at MediaPortal.GUI.Library.GUIFontManager.LoadFonts(String strFilename)
    You just had to re-register the fonts in the system ...
    Code:
    [2020-05-08 10:06:19,914] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream12c' does not exist
    [2020-05-08 10:06:19,919] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream14tc' does not exist
    [2020-05-08 10:06:19,921] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream12tc' does not exist
    [2020-05-08 10:06:19,922] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream11tc' does not exist
    [2020-05-08 10:06:19,925] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream11' does not exist
    [2020-05-08 10:06:19,940] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream10c' does not exist
    [2020-05-08 10:06:19,950] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream10tc' does not exist
    [2020-05-08 10:06:19,954] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream16c' does not exist
    [2020-05-08 10:06:19,966] [Log    ] [MPMain   ] [WARN ] - GUIFontManager: Font with the name 'mediastream12c' does not exist
     

    ultimatejoe

    Portal Member
    October 14, 2007
    44
    5
    Canada Canada
    Country flag
    I'm a bit confused then, as I was able to fix the problem without re-registering the fonts.

    However, if it crops up again, how do I re-register them?
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,653
    8,196
    Kyiv
    Ukraine Ukraine
    Country flag
    Font registration - select font (in skin folder, or...) press right mouse button on it, and select install... :)

    --
    WBR, ajs :):whistle::coffee:
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 12
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    A MediaPortal is still the best! (At least as far as I know...) MediaPortal 1 Talk 1
    ajs 1.28.0 MediaPortal 1.28 Pre-Release ready for testing! News and Announcements 39
    K MediaPortal 2.3.1 live tv freezes when inserting a usb memory stick or when mounting an external drive General 8
    C Can't Install MediaPortal 2 On Windows 10 Home General 13
    A mediaportal 1.27 embedded subtitles not working MediaPortal 1 Talk 3
    A MediaPortal Error log issue MediaPortal 1 Talk 26
    gpnash 1.27.0 mediaportal split between two monitors? MediaPortal 1 Talk 8
    Steve.Rayner61 MediaPortal won't start following W10 Update General Support 5
    Scheibes I must leave MediaPortal Team Lounge 2
    V Einstellen von ServusTV zum Aufnehmen provoziert Neustart von Mediaportal TV / Streaming 0
    R MpExtended fails to find MediaPortal TV Server Installation, configuration support 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 26
    ajs 1.27.0 MediaPortal 1 - 1.27 Released! News and Announcements 0
    M TechniSat CableStar HD2 / Windows 10? Und dann natürlich auch unter Mediaportal? TV / Streaming 1
    ge2301 MediaPortal 2.3.2 Release News and Announcements 0
    S mediaportal with headphone General Support 13
    ge2301 MediaPortal 2.3.1 Release News and Announcements 0
    ajs 1.27.0 MediaPortal 1.27 Pre-Release ready for testing! News and Announcements 2
    T Change tv subtitle in MediaPortal 1.26 Newcomers Forum 12
    T Change tv subtitle in MediaPortal 1.26 MediaPortal 1 Talk 0
    G 1.26.0 Errors when exiting Mediaportal GUI using StreamedMP 3.2.2.0 skin. StreamedMP 0

    Similar threads

    Top Bottom