MediaPortal/MP Configuration crashes after update

Discussion in '1.21 Pre Release' started by yahoodee, October 25, 2018.

  1. yahoodee
    • Premium Supporter

    yahoodee MP Donator

    Joined:
    July 17, 2006
    Messages:
    64
    Likes Received:
    6
    Location:
    Frankfurt am Main
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi,



    I updated my MP 1.2 stable single-seat-setup to 1.21 pr yesterday. I remember that I waited for a long time that the installer finishes the update when i recognized that there was an out-of-focus message-box saying something about "file not found". after clicking it away, the system restarted some moments later, and i dont know why.

    In the eventlog i found an entry about this saying that tvserver initiated the reboot. There was no evententry indicating a crash of windows/blue screen. I dont have the detailed eventlog entry anymore because of watchdog cropped my logs. (is there a backup?)​

    After that I was not able to start MP or MP-Config. It seems to crash that early, that even MP logging didn't start. An update-reinstallation doesnt fix it either. I did not try a clean installation until now.

    This system, with that particular OS installation is running since 2014 and only got updated with stable updates every now an then and i never experienced a problem like this.

    Is that a "special" problem only in my setup or a potential error for many upgrading users of 1.2 stable? Can I do something to get it running by keeping my config/plugins?

    Thanks in advance
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    Try to setup it again and disable your anti-virus :)
    Sometimes not all files get copied the first time, weird but can happen lol
     
    • Thank You! Thank You! x 1
  4. yahoodee
    • Premium Supporter

    yahoodee MP Donator

    Joined:
    July 17, 2006
    Messages:
    64
    Likes Received:
    6
    Location:
    Frankfurt am Main
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Thank you Sebastiii, I tried what you mentioned but it didnt work either. But i just recognized that mp setup is not trying to reinstall the MP client. It looks like it doesnt detect that it is installed. So I tried the third option of the installer: fresh install.
    Thats the point where i run into the "file not found"-error again mentioned in my first post. Actually it says "Invalid File Handle 32" as you can see in the first screenshot.
    So manually removed my mp-client dir and reinstalled it but with the same result.
    after that I used the "download files" option from the installer to run package-mediaportal.exe seperatly so i could see that setup fails when its installing some fonts to the windows dir! (see 2nd screenshot below)

    I think i mixed things up a bit. I am getting the error message everytime i try to reinstall, but mp is now working! so it seems that there were two separate problems?!

    nevertheless we can handle my issues as solved, because i dont see any problems with the failing setup anymore. If you want me to investigate it further because it could be a general issue, please let me know.

    cheers
     

    Attached Files:

    • Like Like x 1
  5. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,295
    Likes Received:
    6,247
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,268 / 9
    Home Country:
    France France
    Show System Specs
    Yep invalid file 32 is when font is not copied because already there or blocked and can't be overwritten.
    In final good that you have MP working again :p
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!