Mediaportal Standby prevented by Mediaportal system/ active ports

Discussion in 'General Support' started by juro, May 2, 2019.

  1. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi All,
    I use now Mediaportal for years with more less no problems. Beginning with 1.21 from time to time MP will not fall into sleep anymore e.g. after a recording and a backup with my server. I did not find the reasn so far. In the power scheduler Windows is set to handle the standby. What I see here in the setting is that the standyb is prevented by Mediaportal client?! When I close down the client the prevent message is gone. Since 1.22 now totally new is the message prevented by Active Ports?! even after a toatlly new start of the PC the message remaines the same?!

    Has anybody a solution for this or made same experience?

    Thanks



    JuRo
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,503
    Likes Received:
    2,774
    Location:
    Cambridge
    Ratings:
    +4,057 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  4. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi Owlsroost,

    thanks for you response. I saw this direct in the power scheduler plugin in the TV Server under standby prevented. powercfg /requests says that the system and then the tv server accplication itsself avoids standby.

    I will check this
     
  5. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Please see scree here: active Ports

    upload_2019-5-3_11-41-26.png

    upload_2019-5-3_11-42-8.png

    upload_2019-5-3_11-44-49.png

    And what I have to do now?

    I never had this message Active ports? Is there anything to set up where I Can exclude this port listening?
    Thanks!

    Whatever setting I do in the power scheduler plugin. The message standby prevented by active ports remains the same
     
    Last edited: May 3, 2019
  6. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I set up all the related stuff ere in the links no change :-(
     
  7. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,503
    Likes Received:
    2,774
    Location:
    Cambridge
    Ratings:
    +4,057 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    No, not at present.

    From the 'netstat -a' list you posted, the PC is listening for an RDP (remote desktop protocol) connection - try disabling 'Remote Desktop' in Win 10 settings (Settings -> System -> Remote Desktop):

    upload_2019-5-3_12-33-16.png

    upload_2019-5-3_12-30-0.png
     
  8. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Thanks!
    ahh I will try, ok from time to time I connect to my 2 Servers via RDP. Maybe I just closed to RDP connection and did not closed the RDP connetion in the right way. But again never had this before over years. Do I have to disable this and can I enable this later again ?
     
  9. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    hi, I deactivated the RDP. Problem solver ! Thanks!

    But now I cann not acces my computer anymore Rdp. Any clue why this happens now after years without a problem.?
     
  10. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,503
    Likes Received:
    2,774
    Location:
    Cambridge
    Ratings:
    +4,057 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    No - the PowerScheduler code hasn't changed since November 2015 (when the RDP and VNC port monitoring was added). This was probably in MP 1.16.

    Attached is a modified PowerScheduler.dll (for MP 1.22) with the RDP port monitoring disabled, which should allow RDP to be enabled/active without it preventing sleep.

    To install, stop TVService, copy the new dll into C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\Plugins and start TVService.
     

    Attached Files:

    • Thank You! Thank You! x 1
  11. juro

    juro Portal Pro

    Joined:
    March 23, 2009
    Messages:
    1,112
    Likes Received:
    32
    Ratings:
    +49 / 0
    Home Country:
    Germany Germany
    Show System Specs
    HI Owlsroost,

    thanks for that. I would appriciate if this could be configured via the user interface. On my server I use lights out for power management. Here almost everything can be configured.
    upload_2019-5-5_18-21-36.png

    Any chance to implement this
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!