MediaPortal SVN-Snapshot:-01-23-2009 22-00.rar (1 Viewer)

MediaPortal-Bot

Worlds greatest bot!
March 26, 2007
3,715
180
Germany Germany
Infos:
These Subversion-snaps are compiled automatically, every week on friday.
They are not pre-tested, so please use the backup option from time to time.
If you like to have the bleeding edge code and don't mind the inherent risks, upgrade to the snapshot releases as they become available.
If stability is important to you, you are advised to stay with the fully-tested releases.​

Report issues / bugs:
  1. Before you start an bugreport, make sure that your system meets the ::requirements::
  2. After you've checked the requirements, take a look at our ::Bugtracker:: to find out if your issue has already been reported.
    Roadmap/Changelog: MediaPortal 1 - TV-Server - Installers
  3. If the problem is not known yet, please have a look at the correct Bugreport forum.

How to install MediaPortal SVN-Snapshots in short:
  1. Install MediaPortal 1.0, not necessary if already done
  2. Run the Snapshot-Installer. You should create a backup.
  3. Run the Configuration. Sometimes the settings and database versions change from build to build, so you have to reconfigure your TV for example.
  4. Hopefully enjoy the new version.
  5. If not, restore your backup and you will have the former version back.

 

MediaPortal-Bot

Worlds greatest bot!
March 26, 2007
3,715
180
Germany Germany
===> DOWNLOAD <===


This thread is open to everyone to provide feedback for this particular snapshot.
If you found or confirm a bug please still open a single thread with full details in the related Bugsection. See first post for details.




There is an error in the included TsWriter of this SVN build. Please grab the attached one and register it!

For registering open a shell with administration rights and switch to the installation folder of TvServer. Than register it with: regsvr32 TsWriter.ax
 

NielsSF

Portal Pro
September 20, 2007
109
12
Netherlands Netherlands
for those who see above that they need to install RC4 before this build, like me.
Pleace note, this is wrong, RTV has changed that but somehow it is not showing correct.
 

rtv

Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    301
    Osnabruck
    Germany Germany
    Some of the features are quite new and will be improved with the next build; nevertheless they are in as they are supposed to work ;)
    Just keep in mind that they might need some polishing before 1.01 (like B3 skin, video overlay will be 16:9 soon, etc).

    We could also need more beautiful audio- /video type icons *hint* :)
     

    iosub

    Portal Pro
    April 26, 2006
    573
    30
    San Sebastian
    To developers:

    I would like to know your "trick".... how in the hell are you able to do so much work on this project with just so few developers in 4 weeks???? I have a ISV company and I would like to know your method :)

    This version is no just a 1.0.1 preview, you have change so many thinks is 1 month that I'm surprise, great job..
    Thanks For your work!

    Just 2 notes
    1.- Tv recording, I'm getting on mediaportal.log "2009-01-23 23:15:20.563200 [Info.][PoolThread12]: RecordedTV: No thumbnail created for Smallville - FOX GE - 2009-01-21.ts" for each of the .ts files, I'm on multisite Any idea why I don't see thumbnails on any of the "recorded tv" files??? maybe I'm missing some seting?

    2.- When are you going to update the svn server?
     

    rtv

    Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    301
    Osnabruck
    Germany Germany
    To developers:

    I would like to know your "trick".... how in the hell are you able to do so much work on this project with just so few developers in 4 weeks???? I have a ISV company and I would like to know your method :)
    Hehe - let your employes have fun at work ;)

    1.- Tv recording, I'm getting on mediaportal.log "2009-01-23 23:15:20.563200 [Info.][PoolThread12]: RecordedTV: No thumbnail created for Smallville - FOX GE - 2009-01-21.ts" for each of the .ts files, I'm on multisite Any idea why I don't see thumbnails on any of the "recorded tv" files??? maybe I'm missing some seting?
    No - unfortunately the thumbnail process needs a true filename. In multiseat environments only "RTSP" URLs are passed to MP. However there's a workaround: If you e.g. use Partition "T:\" for your recordings on the server you could map a network drive to those recordings on the client which also uses "T:\". ;)

    2.- When are you going to update the svn server?
    Already working on it :D
     

    iosub

    Portal Pro
    April 26, 2006
    573
    30
    San Sebastian
    hehe... I think my developers have fun at work... there must be something else :)

    I using multisite but with the GIBman trick "<entry name="usertsp">no</entry>" on tvservice, on mediaportal.log I get "2009-01-23 23:15:39.058200 [Info.][MPMain]: TvRecorded Play:\\sala\d\Recordings\El Peliculón_ Diamantes de sangre - ANTENA 3 - 2009-01-21.ts - using rtsp mode:False"

    maybe gibman need to add something to the Tv thumbnail creating so his trick for no using rtsp works without mapping the drive...

    Thanks!


    Iosu
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,806
    9,222
    Lanzarote
    Germany Germany
    Country flag
    Works much better than the svn before - BUT: Is webEPG broken again? Excerpt from error log:

    2009-01-24 02:51:05.869750 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: br-online.de grabber error
    2009-01-24 02:52:45.885375 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: swr.de grabber error
    2009-01-24 02:54:25.901000 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: zdf.de grabber error and so on for ALL stations...
     

    iosub

    Portal Pro
    April 26, 2006
    573
    30
    San Sebastian
    Hi

    I'm using Multisite, so I have map the recording folder to T: (as rtv has told before)
    Now tumbnail are created.. But I have found a problem

    I have two clients conected to the same TvServer computer...
    The first computer that created the Thumbnail works ok, but the second computer does not get the Thumnail because on tvRecorded.cs class "RecordingThumbCacher" line "88 if (!File.Exists(thumbNail))"

    I have check on configuration on the thumbnail section and there is a option "leave a thumb in recording folder" if I don't check this the the thumb is created on both computer..

    I think this is confusing..

    I think you should check first if there is a thumb for file.ts on the database, if you don't find one then :
    1.- Check if there is a file.JPG on the recording folder, if is true add it to the database
    2.- If there is not a File.JPG, create one, Leave allways a file.jpg on the recording folder and after add the file.jpg to the database-

    Anothere solution would be if Tvserver is the one creating the "Thumbnails" and save them to the Sqlserver or MySql database. So RSTP clients would be able to have thumbnails also.

    Just an idea

    Iosu

    Another couple of problems
    1.- "Layout Big Icon List" there are not thumbnails.
    2.- Configuration.exe saves for value "defaultar" Non-linear Stretch and MediaPortal.exe saves for "defaultar" nonlinear
     

    metropolis

    Portal Pro
    June 1, 2007
    316
    24
    Orpington
    United Kingdom United Kingdom
    After installing this svn I just get "unknown error occured" whn I try and watch Live TV. If I try a scan I get "No signal" accross the board. Had to go back to last svn. Logs attached.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    S [solved] access the desktop without leaving mediaportal General Support 5
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    M.Hulot Warum Blu-ray-Menü nicht anwendbar bei MediaPortal? Allgemeines Supportforum 5
    Similar threads

























    Top Bottom