MediaPortal SVN-Snapshot:-01-23-2009 22-00.rar

Discussion in '[untested] MediaPortal and TV-Server 1.0 svn-build' started by MediaPortal-Bot, January 23, 2009.

  1. MediaPortal-Bot

    MediaPortal-Bot Worlds greatest bot!

    Joined:
    March 26, 2007
    Messages:
    3,715
    Likes Received:
    90
    Ratings:
    +93 / 0
    Home Country:
    Germany Germany
    Infos:
    These Subversion-snaps are compiled automatically, every week on friday.
    They are not pre-tested, so please use the backup option from time to time.
    If you like to have the bleeding edge code and don't mind the inherent risks, upgrade to the snapshot releases as they become available.
    If stability is important to you, you are advised to stay with the fully-tested releases.​

    Report issues / bugs:
    1. Before you start an bugreport, make sure that your system meets the ::requirements::
    2. After you've checked the requirements, take a look at our ::Bugtracker:: to find out if your issue has already been reported.
      Roadmap/Changelog: MediaPortal 1 - TV-Server - Installers
    3. If the problem is not known yet, please have a look at the correct Bugreport forum.

    How to install MediaPortal SVN-Snapshots in short:
    1. Install MediaPortal 1.0, not necessary if already done
    2. Run the Snapshot-Installer. You should create a backup.
    3. Run the Configuration. Sometimes the settings and database versions change from build to build, so you have to reconfigure your TV for example.
    4. Hopefully enjoy the new version.
    5. If not, restore your backup and you will have the former version back.




     
    • Like Like x 2
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. MediaPortal-Bot

    MediaPortal-Bot Worlds greatest bot!

    Joined:
    March 26, 2007
    Messages:
    3,715
    Likes Received:
    90
    Ratings:
    +93 / 0
    Home Country:
    Germany Germany
    ===> DOWNLOAD <===


    This thread is open to everyone to provide feedback for this particular snapshot.
    If you found or confirm a bug please still open a single thread with full details in the related Bugsection. See first post for details.




    There is an error in the included TsWriter of this SVN build. Please grab the attached one and register it!

    For registering open a shell with administration rights and switch to the installation folder of TvServer. Than register it with: regsvr32 TsWriter.ax
     
    • Like Like x 1
  4. NielsSF

    NielsSF Portal Pro

    Joined:
    September 20, 2007
    Messages:
    109
    Likes Received:
    12
    Ratings:
    +12 / 0
    Home Country:
    Netherlands Netherlands
    for those who see above that they need to install RC4 before this build, like me.
    Pleace note, this is wrong, RTV has changed that but somehow it is not showing correct.
     
  5. rtv
    • Team MediaPortal

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Some of the features are quite new and will be improved with the next build; nevertheless they are in as they are supposed to work ;)
    Just keep in mind that they might need some polishing before 1.01 (like B3 skin, video overlay will be 16:9 soon, etc).

    We could also need more beautiful audio- /video type icons *hint* :)
     
  6. iosub

    iosub Portal Pro

    Joined:
    April 26, 2006
    Messages:
    573
    Likes Received:
    30
    Occupation:
    Computer Bussines
    Location:
    San Sebastian
    Ratings:
    +30 / 0
    To developers:

    I would like to know your "trick".... how in the hell are you able to do so much work on this project with just so few developers in 4 weeks???? I have a ISV company and I would like to know your method :)

    This version is no just a 1.0.1 preview, you have change so many thinks is 1 month that I'm surprise, great job..
    Thanks For your work!

    Just 2 notes
    1.- Tv recording, I'm getting on mediaportal.log "2009-01-23 23:15:20.563200 [Info.][PoolThread12]: RecordedTV: No thumbnail created for Smallville - FOX GE - 2009-01-21.ts" for each of the .ts files, I'm on multisite Any idea why I don't see thumbnails on any of the "recorded tv" files??? maybe I'm missing some seting?

    2.- When are you going to update the svn server?
     
  7. rtv
    • Team MediaPortal

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hehe - let your employes have fun at work ;)

    No - unfortunately the thumbnail process needs a true filename. In multiseat environments only "RTSP" URLs are passed to MP. However there's a workaround: If you e.g. use Partition "T:\" for your recordings on the server you could map a network drive to those recordings on the client which also uses "T:\". ;)

    Already working on it :D
     
  8. iosub

    iosub Portal Pro

    Joined:
    April 26, 2006
    Messages:
    573
    Likes Received:
    30
    Occupation:
    Computer Bussines
    Location:
    San Sebastian
    Ratings:
    +30 / 0
    hehe... I think my developers have fun at work... there must be something else :)

    I using multisite but with the GIBman trick "<entry name="usertsp">no</entry>" on tvservice, on mediaportal.log I get "2009-01-23 23:15:39.058200 [Info.][MPMain]: TvRecorded Play:\\sala\d\Recordings\El Peliculón_ Diamantes de sangre - ANTENA 3 - 2009-01-21.ts - using rtsp mode:False"

    maybe gibman need to add something to the Tv thumbnail creating so his trick for no using rtsp works without mapping the drive...

    Thanks!


    Iosu
     
  9. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,102
    Likes Received:
    4,854
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,207 / 38
    Home Country:
    Germany Germany
    Show System Specs
    Works much better than the svn before - BUT: Is webEPG broken again? Excerpt from error log:

    2009-01-24 02:51:05.869750 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: br-online.de grabber error
    2009-01-24 02:52:45.885375 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: swr.de grabber error
    2009-01-24 02:54:25.901000 [ERROR][WebEPG-xmltv]: WebEPG: ChannelId: zdf.de grabber error and so on for ALL stations...
     
  10. iosub

    iosub Portal Pro

    Joined:
    April 26, 2006
    Messages:
    573
    Likes Received:
    30
    Occupation:
    Computer Bussines
    Location:
    San Sebastian
    Ratings:
    +30 / 0
    Hi

    I'm using Multisite, so I have map the recording folder to T: (as rtv has told before)
    Now tumbnail are created.. But I have found a problem

    I have two clients conected to the same TvServer computer...
    The first computer that created the Thumbnail works ok, but the second computer does not get the Thumnail because on tvRecorded.cs class "RecordingThumbCacher" line "88 if (!File.Exists(thumbNail))"

    I have check on configuration on the thumbnail section and there is a option "leave a thumb in recording folder" if I don't check this the the thumb is created on both computer..

    I think this is confusing..

    I think you should check first if there is a thumb for file.ts on the database, if you don't find one then :
    1.- Check if there is a file.JPG on the recording folder, if is true add it to the database
    2.- If there is not a File.JPG, create one, Leave allways a file.jpg on the recording folder and after add the file.jpg to the database-

    Anothere solution would be if Tvserver is the one creating the "Thumbnails" and save them to the Sqlserver or MySql database. So RSTP clients would be able to have thumbnails also.

    Just an idea

    Iosu

    Another couple of problems
    1.- "Layout Big Icon List" there are not thumbnails.
    2.- Configuration.exe saves for value "defaultar" Non-linear Stretch and MediaPortal.exe saves for "defaultar" nonlinear
     
  11. metropolis

    metropolis Portal Pro

    Joined:
    June 1, 2007
    Messages:
    316
    Likes Received:
    22
    Gender:
    Male
    Location:
    Orpington
    Ratings:
    +25 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    After installing this svn I just get "unknown error occured" whn I try and watch Live TV. If I try a scan I get "No signal" accross the board. Had to go back to last svn. Logs attached.
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!