MediaPortal SVN-Snapshot:-01-31-2010 14-51h - Revision:24923.rar (1 Viewer)

Status
Not open for further replies.

Seeco

Portal Pro
October 15, 2007
241
7
Linköping
Home Country
Sweden Sweden
Scythe42: The 23.976Hz refresh rate is named "23" in CCC, that's why I use that value. Are you saying that I should put 23.976 in the box instead? If so I will try it tomorrow, writing this from bed :)
 

Scythe42

Retired Team Member
  • Premium Supporter
  • June 20, 2009
    2,065
    2,703
    46
    Berlin
    Home Country
    Germany Germany
    Scythe42: The 23.976Hz refresh rate is named "23" in CCC, that's why I use that value. Are you saying that I should put 23.976 in the box instead? If so I will try it tomorrow, writing this from bed :)
    Yes, with this SVN build please use the actual refresh rate and not the label used in the display properties. MP communicates directly with the driver under Win7 by using the interface MS supplied. Exact rate should work for now. Anyway this has been fixed and 23 should work again in future builds.
     

    domb

    Portal Pro
    October 30, 2006
    213
    7
    When playing a movie/television and switching to fullscreen/window mode MediaPortal just shows a black screen/window but the top bar still works. Logs attached. Been the same as long as I've used MediaPortal.
     

    grubi

    Portal Pro
    June 16, 2007
    1,216
    80
    127.0.0.1
    Home Country
    Germany Germany
    AW: MediaPortal SVN-Snapshot:-01-31-2010 14-51h - Revision:24923.rar

    When choosing different codecs for MPEG2 and H.264 in "TV Codec" section a different from the selected codec may be used if one of the selected codecs support MPEG2 and H.264.

    Example:

    1.) Select "MPC" for MPEG2 and "Cyberlink Video Devoder (PDVD9)" for H.264.
    2.) Select a SD channel on TV an you'll see that the Cyberlink codec is used instead of "MPC".

    1.) Select "MPC" for MPEG2 and "ffdshow" for H.264.
    2.) Select a SD channel on TV an you'll see that "MPC" is used which is correct.

    See logs.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: AW: MediaPortal SVN-Snapshot:-01-31-2010 14-51h - Revision:24923.rar

    When choosing different codecs for MPEG2 and H.264 in "TV Codec" section a different from the selected codec may be used if one of the selected codecs support MPEG2 and H.264.

    Example:

    1.) Select "MPC" for MPEG2 and "Cyberlink Video Devoder (PDVD9)" for H.264.
    2.) Select a SD channel on TV an you'll see that the Cyberlink codec is used instead of "MPC".

    1.) Select "MPC" for MPEG2 and "ffdshow" for H.264.
    2.) Select a SD channel on TV an you'll see that "MPC" is used which is correct.
    Unfortunately this is how DS graph building in MP works. MP is not using exact match what user has configured in config, but instead relies on the directshows connection behavior. If there are two codecs in the graph (different codec for MPEG2 and H-264 configured and both are able to decode the specific video type) directshow will connect the source filter and video decoder based on the filter merits.

    Something that wont be changed in MP1 scope, maybe not even in MPII.
     

    Brownard
    Country flag

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,919
    1,260
    Home Country
    United Kingdom United Kingdom
    Hi,

    MP will crash if you jump around the timeshift buffer excessively, particularly if seeking to the beginning or end.

    :D
     

    cfforce

    MP Donator
  • Premium Supporter
  • March 4, 2008
    241
    21
    Home Country
    Netherlands Netherlands
    Got in this svn, a lot of dropped frames, and sync glitches, at some point, about 10min watching a HD channel; around 40% dropped. Also stutters a lot.
     

    catavolt
    Country flag

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    12,386
    8,915
    Lanzarote
    Home Country
    Germany Germany
    AW: MediaPortal SVN-Snapshot:-01-31-2010 14-51h - Revision:24923.rar

    Same as cfforde: A lot of dropped frames and sync glitches, display frequencies are not correct.
     

    Attachments

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: AW: MediaPortal SVN-Snapshot:-01-31-2010 14-51h - Revision:24923.rar

    A lot of dropped frames and sync glitches
    Please post other logs as well, it could be some 3rd party plugin that causes the stuttering / dropped frames (InfoService is one good canditate, at least it caused huge amount of dropped frames in gemx' testing).

    Also it could be a bug in MP's dshowhelper.dll, but not sure how much we can improve it (especially when I and Scythe don't have any extra HW available and for us it is working quite nicely althou not as good as it should be).

    display frequencies are not correct.
    That is queried from Windows itself, not much we can do if it reports wrong refresh rate. I assume you are using 60Hz, where as Windows reports 59.xxx. This could be as well a bug in display drivers if you use DVI/HDMI connection (refresh rate should be exact 60Hz at that case) and if you are using analog connection (s-video, vga) display adapter doesn't usually match the exact requested refresh rate (which is already one source for juddering and dropped frames in worst case).
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom