MediaPortal SVN-Snapshot:-05-31-2008 14-18h - Revision:19228.rar (1 Viewer)

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Ok that's not a relevant ticket, but the problem remains. Perhaps time for a tve3 version of that ticket? BTW i now don't beleive dvbt loss was the cause.. because same problem using an analog svideo source according to walts81. This problem confirmed in MP and graphedit. Tried file mode and rtsp mode.
    Unfortunately I still cannot reproduce the bug. I have been previously running timeshifting for many long nights without any errors. One possibility to track down this issue would be to add logging in TsWriter.ax for every incoming TS packet, so we could see at least where that issue happens (on a bigger scale).

    At some point I had the same error with XP & TVE2 engine, but it was caused by old version of quartz.dll (VMR9 comes from that.). Video was just freezing randomly.
     

    Ambass

    Retired Team Member
  • Premium Supporter
  • December 24, 2007
    555
    129
    France France
    binary64, tourette,

    The latest tsWriter/tsReader logs the ts stream discontinuities. Could be interresting to use it.

    Ambass.
     

    mpb

    Portal Member
    November 8, 2006
    42
    1
    Netherlands Netherlands
    Hi Ruud, yes same here.. my mem actually goes up a bit higher even (~200mb).
    If I try to change skins through the 'normal' MediaPortal-settings (so not the setup-app)
    it can actually blow up to ~360mb... does anyone else see that too? (not that a biggie,
    how often does one change skins at runtime anyway.. but still)
     

    Ruud

    MP Donator
  • Premium Supporter
  • December 5, 2004
    276
    6
    Netherlands Netherlands
    Hi Ruud, yes same here.. my mem actually goes up a bit higher even (~200mb).
    If I try to change skins through the 'normal' MediaPortal-settings (so not the setup-app)
    it can actually blow up to ~360mb... does anyone else see that too? (not that a biggie,
    how often does one change skins at runtime anyway.. but still)
    Hi, thanks for the reply. for me it is not related to 'skinning' because I have a multi seat setup and this is happening on the tv server (no front-end running here).

    gr.
    Ruud
     

    binary64

    Portal Pro
    July 30, 2006
    105
    1
    Ambass: cool! i updated to tsreader.ax 19270, but nothing got logged when it froze up:

    06-06-2008 16:35:15.591 [38c]CTsReaderFilter::Run(209851.43) -->done
    06-06-2008 16:51:37.075 [e78]CTsReaderFilter::confused:top()

    That Stop() was my application calling it. So in this test it took around 15 mins to freeze up. Let's crack the logging up and up until I get something useful logged. PM me for any new builds I can try from svn.

    EDIT: I ran a seperate, more stressful test (5 streams at once on same mux), and got some logs! Attached.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Ambass: cool! i updated to tsreader.ax 19270, but nothing got logged when it froze up:

    06-06-2008 16:35:15.591 [38c]CTsReaderFilter::Run(209851.43) -->done
    06-06-2008 16:51:37.075 [e78]CTsReaderFilter::confused:top()

    That Stop() was my application calling it. So in this test it took around 15 mins to freeze up. Let's crack the logging up and up until I get something useful logged. PM me for any new builds I can try from svn.
    We would be more interested on the TsWriter side of log as its telling if there are some errors in the stream at that moment when the stream freezes. If there isnt any then we need to log every single incoming TS packet and that will tell if the stream of TS packets is stopping on the lower level (like drivers).
     

    Ruud

    MP Donator
  • Premium Supporter
  • December 5, 2004
    276
    6
    Netherlands Netherlands
    Memory leak update with logs

    Hi,

    noticed yesterday that my TV server which is on for 24/7 had a memory usage of appr. 159MB. This after resetting the server 3 days earlier
    Normally the TV server hovers around the 35MB when idle.
    Yesterday I restarted the TV Service and the usage was again around the 35MB.... when I just had a look (appr. 24 hours on with minimal (analog) radio functionality for 1 client) it is up again to 122MB.

    Anyone else see this behaviour? I am sure that with the previous SVN I didn't see this kind of memory usage growth.

    I will regularly update the total amount of memory in use for as long as possible (until reset or new svn version)

    If any information is needed please do not hesitate to contact me.

    kind regards,
    Ruud.
    okay,

    so here is the score for today, with logs attached
    tvserver.exe -> 148 MB (growth in 24 hours of appr. 26MB)

    Update: 14:00 CET -> 178MB

    kind regards,
    Ruud.
     

    bigrider

    MP Donator
  • Premium Supporter
  • May 11, 2008
    38
    0
    Germany Germany
    Habe seit diesem SVN immer das Problem das ich diese Fehlermeldung beim Start von TVServer habe.
    Bei den vorherigen SVN war das nicht der fall.

    Gibt es dazu eine Lösung?
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    S [solved] access the desktop without leaving mediaportal General Support 5
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    M.Hulot Warum Blu-ray-Menü nicht anwendbar bei MediaPortal? Allgemeines Supportforum 5
    Similar threads

























    Top Bottom