[Bug] - Minimized Video Playback | Page 2

Discussion in 'MediaPortal 1.2.0 ALPHA' started by T-Buster, November 2, 2010.

  1. Bavarian
    • Premium Supporter

    Bavarian Retired Team Member

    Joined:
    April 4, 2005
    Messages:
    698
    Likes Received:
    167
    Location:
    Germany, Bayern
    Ratings:
    +167 / 0
    Home Country:
    Germany Germany
    Show System Specs
    bug is fixed in SVN 27167


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,253
    Likes Received:
    4,989
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,410 / 38
    Home Country:
    Germany Germany
    Show System Specs
    AW: Minimized Video Playback

    Hi Bav, many :D! What was the reason (if I may ask)?
     
  4. catavolt
    • Team MediaPortal
    • Administrator

    catavolt Design Group Manager

    Joined:
    August 13, 2007
    Messages:
    12,253
    Likes Received:
    4,989
    Gender:
    Male
    Occupation:
    Technical Documentation, Translation
    Location:
    Lanzarote
    Ratings:
    +7,410 / 38
    Home Country:
    Germany Germany
    Show System Specs
    AW: Minimized Video Playback

    Hmmm, just tested it. Now there is sometimes a video preview - the first time entering BasicHome the running TV/Video is shown. Entering Videos in list view, nothing is shown (as it should). Going back to BasicHome, now nothing is shown.
    Going to videos and changing layout to Covers or Coverflow (where it is allowed), preview may be shown, but mostly it is not shown. Now it´s very random....
    EDIT: Now I (possibly) found the reason: Opening the action menu displays a flickering overlay, and depending on when action menu is closed, the overlay displays (or not) :confused:
     
  5. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Re: AW: Minimized Video Playback

    I did reopen the issue. Fix causes some other issues to happen:

    1) start video
    2) press x
    3) go to home screen (video is ok)
    4) go to my videos (overlay is hidden correctly if big icons are used)
    5) go to home -> video is not rendered at all
     
    • Like Like x 1
  6. Dadeo
    • Premium Supporter

    Dadeo Docs Group Manager

    Joined:
    November 26, 2006
    Messages:
    5,340
    Likes Received:
    2,802
    Location:
    Himalayas, India
    Ratings:
    +3,053 / 0
    Home Country:
    Canada Canada
    Show System Specs
    Actually I can confirm the issue in 1.1.2 in exactly the case T-Buster first reported. I can also reproduce the error in almost any window and any skin by using the conditions for allowoverlay - i.e. in BlackGlass change the condition in myvideotitle.xml to the same as B3 skins ( <allowoverlay>[facadeview.filmstrip]</allowoverlay>) and you get the same behaviour.

    This also applies to shares view, if the condition does not support facadeview.list then the same issue occurs - the videoframe behaves correctly, but the videowindow (actual playback) does not.

    I have found that using <allowoverlay>player.hasmedia</allowoverlay> does 'workaround' the issue in some cases, which is what tgx did in BlackGlass, but it still does not work if you restrict the overlay to a facade and do not include facadeview.list, at least in all cases I tried.

    Hope that helps debug it.
     
    • Like Like x 1
  7. Bavarian
    • Premium Supporter

    Bavarian Retired Team Member

    Joined:
    April 4, 2005
    Messages:
    698
    Likes Received:
    167
    Location:
    Germany, Bayern
    Ratings:
    +167 / 0
    Home Country:
    Germany Germany
    Show System Specs
    :D for testing - I will once again have a look later today
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!