More Missed Recordings - Different Symptoms (1 Viewer)


Retired Team Member
  • Premium Supporter
  • January 27, 2005
    Home Country
    United Kingdom United Kingdom
    TV-Server Version: 1.0
    MediaPortal Version: 1.0
    MediaPortal Skin: Blue3 Wide
    Windows Version: XP Pro - SP3
    CPU Type: Intel E4500 2x2.2Ghz
    HDD: WD green 500Gb
    Memory: 2Gb DDR2-6400
    Motherboard: ASUS P5KPL-VM
    Video Card: ATI Radeon 3650
    Video Card Driver: Catalyst 8.11
    Sound Card: CMedia 8738 Generic Card
    Sound Card AC3:
    Sound Card Driver: Dogber's Drivers 1.2.2
    1. TV Card: Pinnacle 7010ix
    1. TV Card Type: Dual DVB-S and Dual DVB-T
    1. TV Card Driver: Latest
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: NVidia
    MPEG2 Audio Codec: NVidia
    h.264 Video Codec: PowerDVD 7
    Satelite/CableTV Provider: Freeview (DVB-T)
    HTPC Case: Antec Fusion
    Cooling: Scythe Mini-Ninja
    Power Supply: Antec 300W
    Remote: MCE
    TV: Sony 32v2000
    TV - HTPC Connection: VGA

    Been basically trying to soak test MP and get it to record left right and center going into and coming out of S3 standby.

    Over the weekend I was away and left it to record about 15 programmes. It suucessfully recorded about 10 but seems to have died at some point and never sorted itself out. When I got back machine was in standby (should have been recording) and when I tried to go in and delete recordings it said I couldn't. Had to reboot at which point everything worked and recording kicked in (50 mins into an hour programme)

    Typically the few recordings it missed were the ones I (and more importantly the other half) actually wanted to watch.

    A couple of odd things I noticed.

    in error.log (in bak) I have
    2009-01-17 03:06:10.031250 [14]: card: unable to connect to slave controller at:PVR
    plus lots of
    2009-01-17 18:12:20.203125 [PowerEventThread]: TV service PowerEventThread: Exception: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
       at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
       at System.Collections.Generic.List`1.Enumerator.MoveNext()
       at TvService.Service1.OnPowerEvent(PowerEventType powerStatus)
       at TvService.Service1.PowerEventThreadWndProc(IntPtr hWnd, UInt32 msg, IntPtr wParam, IntPtr lParam)
       at TvService.Service1.GetMessageA(MSG& msg, IntPtr hWnd, Int32 uMsgFilterMin, Int32 uMsgFilterMax)
       at TvService.Service1.PowerEventThread()
    I have queried the latter before without any response but the top one is something I have not seen before.

    The main odd thing however is that the TV log just seems to end (only have bak file now). The PC was set to wakeup at 21:00 and I get
    2009-01-17 20:56:01.515625 [PowerScheduler Waiter]: PowerScheduler: OnResume
    2009-01-17 20:56:10.015625 [PowerEventThread]: TV service PowerEventThread 30
    2009-01-17 20:56:10.078125 [WinController exit thread]: WindowsController: ExitWindows performed, result: True
    2009-01-17 20:56:10.078125 [PowerEventThread]: TV service PowerEventThread 30
    2009-01-17 20:56:14.437500 [20]: PowerScheduler: RegisterRemote tag: 23, uris: http://localhost:31458/8815a28f_4975_40c9_a2fd_477603aa04b0/8ofcj54sm4pkdqncinvxsi0m_1.rem, http://localhost:31458/8815a28f_4975_40c9_a2fd_477603aa04b0/8ofcj54sm4pkdqncinvxsi0m_1.rem
    2009-01-17 20:56:39.453125 [20]: PowerScheduler: User input detected at 1/17/2009 8:56:14 PM
    2009-01-17 20:58:17.250000 [23]: PowerScheduler: UnregisterRemote StandbyHandler 23
    2009-01-17 20:58:17.250000 [23]: PowerScheduler: UnregisterRemote WakeupHandler 23
    but then nothing else. In tv.log the next entry is
    2009-01-18 21:04:37.640625 [PowerEventThread]: TV service PowerEventThread 30
    when I switched the machine back on and nothing in between.

    More odd is the PC not working on resume and needing a reboot. Going into live TV I was getting the timeshifting can't be started popup but according to the tv log the server tuned in quite happily. Also when I was trying to delete the programmes that did record I was getting an error popup saying I couldn't. It was however writing logs at this point and when I rebooted at 21:17 everything starts working and the machine realises it is missing a recording and starts .

    Things seem to be getting better but missing her recordings is not nice ;)

    I am not sure if this is a client issue but seems as the client logs just get restarted everytime there are no useful client logs in here


    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    Home Country
    United Kingdom United Kingdom
    no-one looked or are the logs useless??

    This is kind of important to me. Missing recordings is very likely to result in me ditching MP as I can not live with the grief from the misses ;)


    MP Donator
  • Premium Supporter
  • May 21, 2008
    Home Country
    New Zealand New Zealand
    I too see the TV service PowerEventThread: Exception: System.InvalidOperationException errors in the TV log. MP is set to wake up at 6pm and record the news, even though I often get home in time, so I sit and watch the PC waiting for it to come to life and it doesn't.

    Users who are viewing this thread

    Top Bottom