MP2 - V2.3 [solved] MP 2.3 Install failed 0x80070643 Windows 10 ver 20H2 (1 Viewer)

Bucky O'Hare

Portal Member
April 24, 2008
35
2
United Kingdom United Kingdom
Country flag
Having issues installing MP 2.3 on an HP Probook G6 running Windows 10 20H2 build I had to install all the dependencies DX9 and Visual C++ Redistributable packs 2008 through to 2015 to 2019 because the instaler kept crashing out when it tried to load the DX9 downloader that got me to selecting the type of install from which I selected client only as this is going to be connected to my MP2.3 Server which runs same version of Windows 10 as this laptop. the Installation terminates with the 0x80070643 error.

I have disabled Windows Defender and tried again with the same error message.

As a test I used another laptop (Toshiba Satellite Pro) setup in a similar way running same win 10 build and had no issues installing MP2.3 without having to install DX9 and the Visual C packages first.
 

Attachments

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,748
    7,110
    Germany Germany
    Country flag
    @aspik don't we now include the minimum D3D files in our VideoPlayer project as nuget package? So we could in principle remove the complete DX9 setup stuff from current installer...
     

    aspik

    Development Group
  • Team MediaPortal
  • April 14, 2008
    1,386
    556
    @aspik don't we now include the minimum D3D files in our VideoPlayer project as nuget package?
    Yes, you made a nuget package from the required DLLs. Here's the commit, where we reference it:
    Not sure, if its also part of other branches, but in the new installer branch I already removed the DX setup from the installer and the client is working after the installation.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,308
    3,778
    Lehmden
    Germany Germany
    Country flag
    Hi.
    I already removed the DX setup
    Probably you've done this too early or too much. I needed to install DX9 manually before I could install MP 2.3 on a clean Win 10 20H2 system. Some VC runtime are also needed to be installed manually before the installation finally works...
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    D 2.3.2 Failed to install on Server 2012 R2 error 80072f76 General 0
    D 1.27.0 New installation of 1.27 fails because wmp11 fails Installation, configuration support 6
    D install failed 0x800b010a Installation, configuration support 4
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 16
    rexdog [solved] MP2 Instal failing on WIN10 General 2
    Holzi [solved] MediaPortal 2 will not install - Failed to start services MediaPortal 2 1
    B [further infos missing] Install failed Exit code: 0xfff7, restarting: No 2.2 Archive 1
    T [solved] Installation failing General 32
    tano_grasa New installation: watched status lost? My Films 2
    C Can't Install MediaPortal 2 On Windows 10 Home General 13
    A Installation failure on TV Server when doing single seat installation Installation, configuration support 36
    M 1.27.0 Update von MP1.16 aud MP1.27 auf WSE2016 nicht möglich Installation, configuration support 6
    T MP TV Service null reference after 1.26 install (server) Installation, configuration support 4
    G MP2 - V2.3 New install and crashing MP2-2.3 General 6
    A [solved] Upgraded HTPC. Cannot install MP anymore Installation, configuration support 3
    M Installing Plugins Newcomers Forum 2
    doskabouter Installing mediaportal MediaPortal 1 3
    toricred x64 Bit Installer for 2.2.3 General 2
    F Problems with new install of MP2 Newcomers Forum 3
    C Can't install any extensions - DLL error Installation, configuration support 19
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    ajs [fixed] 5022: Improving the MPE Installer, providing nicer GUI :) MediaPortal 1 42

    Similar threads

    Top Bottom