[solved] - MP not reading EPG from XMLTV

Discussion in 'xmlTV' started by Bdydrp, March 17, 2017.

  1. Bdydrp

    Bdydrp Portal Pro

    Joined:
    July 2, 2015
    Messages:
    56
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +5 / 1
    Home Country:
    Australia Australia
    So ive just realised there is a support thread for EPG and thought this may be a better place to post my issue after posting elsewhere.

    .I have followed all the guides relating to TV channels and XMLTV plugin, yet i'm unable to view any EPG Info in MP.
    Importing xml file from WebEPG+ has worked, and all channels have been mapped and saved.
    Watching Live TV is not an issue

    Not sure what i'm missing or doing wrong. Nothing seems to import into MP.
    I have attached my log files if that may assist

    Any suggestions welcome



    Thanks

    Adam
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    Hi Adam

    This place is no better or worse. Like you, we all have busy lives outside of MediaPortal, so responses can sometimes take a week or more. We appreciate your patience. :)

    I'm not sure either, because according to the log files attached to your earlier thread, the XMLTV plugin successfully imported details for almost 4000 programs:
    Show Spoiler

    [2017-03-16 20:21:28,667] [Log ] [XmlTvImporter] [DEBUG] - xmltvimport: Sorting TV programs
    [2017-03-16 20:21:28,673] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 242 programs for 7flix Sydney
    [2017-03-16 20:21:28,678] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 229 programs for 7mate Sydney
    [2017-03-16 20:21:28,681] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 97 programs for 7HD Sydney
    [2017-03-16 20:21:28,684] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 223 programs for 7TWO Sydney
    [2017-03-16 20:21:28,687] [Log ] [SQL EPG importer] [DEBUG] - BusinessLayer: InsertProgramsThread started
    [2017-03-16 20:21:28,690] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 74 programs for Extra
    [2017-03-16 20:21:28,693] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 64 programs for 9Gem
    [2017-03-16 20:21:28,699] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 307 programs for 9Go!
    [2017-03-16 20:21:28,702] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 95 programs for 9HD Sydney
    [2017-03-16 20:21:28,705] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 188 programs for 9Life
    [2017-03-16 20:21:28,708] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 398 programs for ABC ME
    [2017-03-16 20:21:28,712] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 157 programs for ABC News 24
    [2017-03-16 20:21:28,715] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 55 programs for ABC
    [2017-03-16 20:21:28,717] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 55 programs for ABC
    [2017-03-16 20:21:28,721] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 198 programs for ABC2/KIDS
    [2017-03-16 20:21:28,724] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 198 programs for ABC HD
    [2017-03-16 20:21:28,727] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 113 programs for ELEVEN
    [2017-03-16 20:21:28,731] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 53 programs for Channel 9 Sydney
    [2017-03-16 20:21:28,734] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 17 programs for ONE
    [2017-03-16 20:21:28,736] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 17 programs for ONE
    [2017-03-16 20:21:28,739] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 253 programs for RACING.COM
    [2017-03-16 20:21:28,742] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 50 programs for 7 Sydney
    [2017-03-16 20:21:28,746] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 50 programs for 7 Sydney
    [2017-03-16 20:21:28,749] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 366 programs for SpreeTV
    [2017-03-16 20:21:28,752] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 203 programs for TEN Digital
    [2017-03-16 20:21:28,755] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 141 programs for TEN HD
    [2017-03-16 20:21:28,758] [Log ] [XmlTvImporter] [INFO ] - XMLTVImport: Inserting 133 programs for TVSN
    [2017-03-16 20:21:28,763] [Log ] [XmlTvImporter] [INFO ] - Xmltv: imported 27 channels, 3976 programs status:tvguide.xml:File imported successfully;


    If you're still having a problem, you'll need to be more specific about what you're doing and where you're looking. Screenshots or a video are really helpful.

    Regards,
    mm
     
  4. Bdydrp

    Bdydrp Portal Pro

    Joined:
    July 2, 2015
    Messages:
    56
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +5 / 1
    Home Country:
    Australia Australia
    All good - didnt know which is more suited....
    Still cant get any EPG to show in MP.
    Below are the steps i take.
    Create XMLTV file with EPG Collector (this does find all channels) and save in XMLTV plugin folder.

    On General Tab, Click on Import

    Step 1.png


    On Mappings tab, press load/refresh - all channels are assigned correctly, the press Save,
    then,
    On general tab, press import again.
    The bottom message shows 29 channels imported and 7244 programs imported correctly.
    Press save to exit TVServer config
    Open Mediaportal and select guide.
    All channels appear, but no guide data is available.

    Am i missing a step so that mediaportal can show the guide data?

    I have attached latest logs and my TVGuide.xml file

    Thanks
     

    Attached Files:

  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    All that sounds good, and the log files and screenshot are unequivocal: the XMLTV plugin is successfully importing EPG data.

    Without a screenshot/video of what you're looking at in MediaPortal (sorry, I should have been more clear about what I meant) I can only guess the problem could be something like the following:
    • you're looking at channels which don't have EPG mapped to them
    • you've imported EPG for MP 1's TV Server and you're expecting to see EPG in MP2 (which won't work), or vice versa
    • you've enabled a second EPG source/grabber (DVB EPG?) which is overwriting/wiping the EPG data imported by the XMLTV plugin shortly after it finishes importing
     
  6. Bdydrp

    Bdydrp Portal Pro

    Joined:
    July 2, 2015
    Messages:
    56
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +5 / 1
    Home Country:
    Australia Australia
    Below are screenshots of each of the server config tabs.
    - TV Channels/TV Mappings
    upload_2017-3-22_11-24-15.png

    -DVB EPG
    upload_2017-3-22_11-25-36.png

    - TV Epg grabber
    upload_2017-3-22_11-30-54.png

    -Plugins Tab
    upload_2017-3-22_11-37-18.png

    - XMLTV plugin General Tab
    upload_2017-3-22_11-32-10.png

    - XMLTV plugin Mappings Tab
    upload_2017-3-22_11-32-51.png

    - EPG insde MediaPortal
    upload_2017-3-22_11-35-26.png

    As far as i can tell, i have mapped all channels correctly and i have not got another epg grabber running.
    And MediaPortal 2 is not installed

    Hope this info helps better

    Thanks
     

    Attached Files:

  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    Ahhhh, I see the problem: on the XMLTV plugin general tab you have entered "1000" in the hours field below "apply time compensation...". That will cause TV Server to translate the start/end dates and times for all imported programs to be 1000 hours further in the future than the dates/times recorded in the XMLTV file.
    [edit: To be clear, you see nothing in the guide because you're looking at today and the imported data has been shifted 1000 hours into the future. If you were to look 1000 hours forward you'd see the data.]
    ...and yes that 1000 hour adjustment is applied even though you haven't ticked "apply time compensation". They're separate settings even though they don't look like it.
    So, change the hours value back to zero, click import, wait 5 to 10 minutes, and then guide data should show in MediaPortal.
     
    • Thank You! Thank You! x 1
  8. Bdydrp

    Bdydrp Portal Pro

    Joined:
    July 2, 2015
    Messages:
    56
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +5 / 1
    Home Country:
    Australia Australia
    THANKYOU THANKYOU THANKYOU.
    That did the trick. Cant believe it was something so simple. It was driving me insane.
    So out of curiosity, what does the checkbox do then, if it separate to the time field i had populated?

    Appreciate your help!

    Cheers
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    You're very welcome. :)
    I have to confess, you had me stumped there for awhile as well. Very easy to miss.

    It's explained in the wiki (manual):
    XmlTv Plugin - MediaPortal 1 - MediaPortal Wiki
     
  10. Bdydrp

    Bdydrp Portal Pro

    Joined:
    July 2, 2015
    Messages:
    56
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +5 / 1
    Home Country:
    Australia Australia
    Thanks - Maybe i should have read it better, then i wouldn't be pulling my hair out...
    Glad you spotted it..Thanks

    1 more thing - when i select record on a show, the default setting for "keep recording until" is set to "until space is needed".
    Is there a way to set it for "always" as the default.?
     
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    No, I can't think of any way off the top of my head. You can manually change it for each schedule you create... but I don't think the default can be changed.

    With "until space is needed", recordings will never be automatically deleted unless you choose to enable disk quotas (explained in the manual as well):
    Recording - MediaPortal 1 - MediaPortal Wiki

    ...so I would have thought you should be safe with "until space needed".
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!