[solved] MP will not delete recordings that are on NAS (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I tried just quickly changing the user for tvservice through services.msc to be the normal Windows user and that completely broke it (tvserver not able to run at all by the look of it)
    Yeah, the user running the TV service will need some level of admin privileges because the TV service accesses hardware etc. I'm sorry, I'm not able to tell you exactly what those privileges are. Might be easier to allow the default Windows user that runs the TV service to access the NAS.

    As always, many thanks for the help
    No problem. See you around. :)
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    11,844
    6,694
    Kyiv
    Ukraine Ukraine
    Country flag
    Try add to User - run service run. Somewhere in local policy...

    --
    WBR, ajs :):whistle::coffee:
     

    RobNorthcott

    MP Donator
  • Premium Supporter
  • October 9, 2007
    517
    96
    Dartmoor, England
    United Kingdom United Kingdom
    Country flag
    Thanks again folks.

    I thought just changing the user on the service wasn't likely to work without fiddling with privileges, but didn't take long to try it so I thought I may as well just in case it worked :)

    Giving NAS access to the user tvservice is running under would seem the most sensible solution, but that's where my Windows networking/user policy knowledge runs out... the only way I know of giving a user access to the NAS is to log on as that user and go to the NAS in file explorer so it prompts for the NAS user details - and I don't think you can log into Windows as the "default system account" or whatever it's called. I need to do some research I think and learn more about this stuff, but I'm now sure it's a Windows setup thing and not anything to do with MP or TVServer itself, so you have pointed me in the right direction :)
     

    RobNorthcott

    MP Donator
  • Premium Supporter
  • October 9, 2007
    517
    96
    Dartmoor, England
    United Kingdom United Kingdom
    Country flag
    Well, I've found out what it was :)

    People's advice to run the tvservice as the normal user was correct, but it turns out that Windows won't run a service as a user with no password. It doesn't complain when you set the user in the service properties, but fails with a login error when it tries to start the service.
    Adding a password to the user account fixes this, and everything to do with the TV Server still works - AND I can now delete those recordings from the NAS through the normal interface. Woohoo.

    I purposely has no password on the user so the machine would boot straight back up in the event of a power failure without sitting on the login screen, but setting Windows to auto-login using netplwiz (another thing I didn't know about before) has got round this.

    So, thanks again for all the help - and the moral of the story is if you're changing the user on a service, make sure it has a password!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    jmarc Can't delete recordings after NAS died General Support 5
    R [solved] Unable to delete single recording General 2
    P Recordings not showing up unless re-imported and not possible to delete General 0
    N [Finished] [MP2-781] Enable one-click deletion of grouped TV recordings MediaPortal 2 70
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    N [solved] Cannot delete recordings from remote client MediaPortal 2 32
    R Mediaportal will not delete Recorded TV items that do not exist MediaPortal 1 Talk 0
    H [Finished] [MP2-781] Delete a Folder in TV-Recordings Archive 7
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    coolblue [solved] How to delete Recording? General 16
    M keep check of deleted recording?? General Support 3
    MLH01 MP2 will not delete recordings - log in as admin or user account? General 4
    morpheus_xx Was this spam? I deleted it... Online Facilities 4
    N [Finished] MP2-803 - Delete full series doesn't work when viewing a program in the extended schedule screen MediaPortal 2 12
    G [solved] How do you delete media in Mediaportal2? General 14
    Frans Nijhuis [further infos missing] Deleting all TV channels and all channel groups in "MP 2 TV configuration" fails 2.2 Archive 1
    H [fixed] Series programming/deleting 2.2 Archive 1
    krebbi [solved] Delete Media Files via Context Menu General 8
    toricred Recordings Change : to _ in Series Name General 0
    P Recording films that have an "intermission" General 2
    H MP2 database won't keep in synch with recordings General 3
    toricred Only Show Actual Recordings General 1
    ajs How recreate Recording thumbs TV-Server 4
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    CyberSimian [Proposal] Tool to display time of next recording MediaPortal 1 0
    Similar threads

























    Top Bottom