[solved] MP won't start - CLR20r3 (1 Viewer)

d3cadent

Portal Member
April 19, 2008
47
3
Hi,

I need some tips on where to start looking for my problem.
I have several computers, some run MP successfully for years. I decided to install MP (TV Client) on one machine which is usually used by my children for gaming, and my wife for work.
After a flawless installation procedure, I cannot launch Configuration.exe. Mediaportal.exe automatically tries to launch Configuration.exe, since there exist no initial configuration yet. However, when Configuration.exe starts, the Standard / Expert mode selection appears, but after selecting either one, Windows reports tha Configuration.exe stopped working, with a CLR20r3 error. I cannot collect logs or configs, since there aren't any.
As I understand, this is a .NET error, so I reinstalled the .NET 4.6.1 runtime, but it did not make any difference. Even disabling my antivirus protection software did not help.
This computer has only one "unusual" specific: it has two monitors connected. One is driven by the CPU's internal GPU, the other has a dedicated GPU. Apart from this, I cannot think of anything else which would not be standard.
I would be really thankful if you could give some tips on how to dig deeper to what is the problem here as I have no useful ideas.

System specs:
- Asus H81 mainboard
- Intel Core i5 CPU w/ integrated video
- 8GB RAM
- SSD + HDD
- Windows 7 Home Premium 64, Hungarian language
- additional NVIDIA GT 430 card
- windows update on, all important patches installed
- MP v1.16.0 Final
- Computer has no local media store or TV cards, but there is a MP TV Server on the network to which I'd like to connect. Of course, I can't even get to the point of configuring network as Configuration.exe immediately hangs with the CLR20r3.

Thank you for all tips.
 

d3cadent

Portal Member
April 19, 2008
47
3
Okay, seems I don't have the problem of too many tips to try ;)
Can I do something on my side to provide more info? Logs aren't available since Configuration.exe won't run even for once - but anything else that could help us point into the right direction, I will happily add.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    As always, when any program crashes, check the Windows application event log to find information about the cause.
     

    d3cadent

    Portal Member
    April 19, 2008
    47
    3
    Windows Event Viewer reported an Unhandled Exception for the .NET Runtime.

    Some more digging revealed there was a file corruption in the DirectX 9c runtime. Reinstalling that resolved the problem.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D Getting Started General Support 30
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    ajs Trakt error when start with MP crash Trakt 1
    F Recording starts at second time only MediaPortal 1 Talk 6
    tano_grasa Movie cover not showing when starting a movie aMPed 0
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
    Icaro Close MP when the external player is started General Support 13
    M MP1 stops responding after Starting Plugins General Support 14
    joecool70 Fehlermeldung Error invoking action "Start Timeshift" Allgemeines Support- und Diskussionsforum 1
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
    T MP bricht Videos und Serien beim Start ab. Allgemeines Supportforum 4
    D Enhance "wake on lan" feature (on demand, not on start) Feature Requests 6
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    K How to start Chrome or other programs MediaPortal 1 Talk 41
    R How to I get started with MP2? General 1
    squidina [solved] - MediaPortal 1.22 won't start even with new install General Support 4
    M App Icon starts Configuration Installation, configuration support 3
    O [solved] MP2.2.1 TV-Server Configuration wont start after initial installation General 10
    Terra Videos do not start playing on first attempt, always have to press play twice General Support 9
    Similar threads

























    Top Bottom