[solved] - MP1.20 issue with HD audio stream (not all media)

Discussion in 'watch/edit Videos' started by Cowboy, September 3, 2018.

  1. Cowboy
    • Premium Supporter

    Cowboy MP Donator

    Joined:
    January 25, 2011
    Messages:
    15
    Likes Received:
    7
    Gender:
    Male
    Occupation:
    Developer
    Ratings:
    +11 / 0
    Home Country:
    Germany Germany
    Hi there,
    i've got a problem with the playback of some movies. The sound format is listed as DTS HD 7.1 but the receiver detects it as DTS surround 5.0 input signal (made some screenshots). The sound is not completely missing. It is very silent and kind of stuttering. Playing the same movie with VLC and SPDIF the playback is normal and the receiver detects the stream as DTS surround with 7.1 layout. I think theres a problem with the correct media detection in MP.

    On MP screen
    upload_2018-9-3_17-32-52.png

    AVR display with VLC
    upload_2018-9-3_17-0-42.png

    AVR display with MP and detected input signal as 5.0
    upload_2018-9-3_16-59-49.png

    I am using Mediaportal 1.20 with LAV filters (of course) and tried several audio settings.
    upload_2018-9-3_17-11-41.png

    The MP config uses LAV for all codecs, the audio rendering is set to Direct Sound Maranz AVR. DRRC is disabled.
    upload_2018-9-3_17-3-56.png



    I am using the VMR9 video renderer instead of EVR because i had some stability issues with EVR but tried also with EVR.

    The AVR is a Maranz SR 5012 connectied via HDMI to my htpc.
    upload_2018-9-3_17-3-13.png

    The htpc is an AMD 7700k APU on a Gigabyte GA-F2A88XM-HD3 board. The current AMD drivers with version 18.8.1 are quite actual.

    Logfile of playback:
    Code (Text):
    1. [2018-09-03 15:38:59,702] [Log    ] [MPMain   ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : C:\Data\My_1080p_H264_MPG4_AVC_DTS-HD_HRA_7.1_movie.mkv
    2. [2018-09-03 15:38:59,707] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.AdaptRefreshRate: 'auto refreshrate changer' disabled
    3. [2018-09-03 15:38:59,707] [Log    ] [MPMain   ] [INFO ] - g_Player.Play(C:\Data\My_1080p_H264_MPG4_AVC_DTS-HD_HRA_7.1_movie.mkv Video)
    4. [2018-09-03 15:38:59,712] [Log    ] [MPMain   ] [INFO ] - Loading external players plugins
    5. [2018-09-03 15:38:59,717] [Log    ] [MPMain   ] [INFO ] -   found plugin:MediaPortal.WinampPlayer.WinampPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll
    6. [2018-09-03 15:38:59,717] [Log    ] [MPMain   ] [INFO ] -   player:Winamp.  author: int_20h
    7. [2018-09-03 15:38:59,717] [Log    ] [MPMain   ] [INFO ] -   found plugin:MediaPortal.ITunesPlayer.ITunesPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll
    8. [2018-09-03 15:38:59,717] [Log    ] [MPMain   ] [INFO ] -   player:iTunes.  author: Frodo
    9. [2018-09-03 15:38:59,722] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:play C:\Data\My_1080p_H264_MPG4_AVC_DTS-HD_HRA_7.1_movie.mkv
    10. [2018-09-03 15:38:59,744] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Enabling DX9 exclusive mode
    11. [2018-09-03 15:38:59,745] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
    12. [2018-09-03 15:38:59,772] [Log    ] [MPMain   ] [INFO ] - VMR9: added Video Mixing Renderer 9 to graph
    13. [2018-09-03 15:38:59,872] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found H264 video out pin
    14. [2018-09-03 15:38:59,872] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: found HEVC video out pin
    15. [2018-09-03 15:38:59,987] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Added filter: LAV Video Decoder to graph
    16. [2018-09-03 15:38:59,992] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Attach volume handler device to audio renderer: DirectSound: 1 - marantz-AVR (AMD High Definition Audio Device)
    17. [2018-09-03 15:39:00,062] [Log    ] [MPMain   ] [INFO ] - Mixer: ChangeAudioDevice failed because device DirectSound: 1 - marantz-AVR (AMD High Definition Audio Device) was not found, falling back to default
    18. [2018-09-03 15:39:00,067] [Log    ] [MPMain   ] [INFO ] - DirectShowUtils: First try to insert new audio renderer DirectSound: 1 - marantz-AVR (AMD High Definition Audio Device)
    19. [2018-09-03 15:39:00,067] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Found audio renderer
    20. [2018-09-03 15:39:00,085] [Log    ] [MPMain   ] [INFO ] - DirectShowUtil: Added filter: LAV Audio Decoder to graph
    21. [2018-09-03 15:39:00,150] [Log    ] [MPMain   ] [INFO ] - VMR9: progressive mode detected - no need to de-interlace
    22. [2018-09-03 15:39:00,160] [Log    ] [MPMain   ] [INFO ] - MpcEngine: Subtitle VideoPlayer CultureInfo de
    23. [2018-09-03 15:39:00,169] [Log    ] [MPMain   ] [INFO ] - VideoPlayerVMR7: AudioLanguage CultureInfo de
    24. [2018-09-03 15:39:00,181] [Log    ] [MPMain   ] [WARN ] - Right + Left cropping larger than screenwidth! Setting to 0
    25. [2018-09-03 15:39:00,182] [Log    ] [MPMain   ] [WARN ] - Top + Bottom cropping larger than screenwidth! Setting to 0
    26. [2018-09-03 15:39:00,182] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 0x0
    27. [2018-09-03 15:39:00,183] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 0:0
    28. [2018-09-03 15:39:00,183] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1920x1080
    29. [2018-09-03 15:39:00,183] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    30. [2018-09-03 15:39:00,184] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    31. [2018-09-03 15:39:00,184] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(0,0)
    32. [2018-09-03 15:39:00,185] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,-2147483648)-(1920,0)
    33. [2018-09-03 15:39:00,297] [Log    ] [MPMain   ] [WARN ] - Right + Left cropping larger than screenwidth! Setting to 0
    34. [2018-09-03 15:39:00,298] [Log    ] [MPMain   ] [WARN ] - Top + Bottom cropping larger than screenwidth! Setting to 0
    35. [2018-09-03 15:39:00,299] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 0x0
    36. [2018-09-03 15:39:00,299] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 0:0
    37. [2018-09-03 15:39:00,300] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1920x1080
    38. [2018-09-03 15:39:00,300] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    39. [2018-09-03 15:39:00,301] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    40. [2018-09-03 15:39:00,302] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(0,0)
    41. [2018-09-03 15:39:00,302] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,-2147483648)-(1920,0)
    42. [2018-09-03 15:39:00,303] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:Duration:7513,497708
    43. [2018-09-03 15:39:00,304] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStarted() C:\Data\My_1080p_H264_MPG4_AVC_DTS-HD_HRA_7.1_movie.mkv media:Video
    44. [2018-09-03 15:39:00,378] [Log    ] [55       ] [INFO ] - PlaneScene: video WxH  : 1920x1080
    45. [2018-09-03 15:39:00,379] [Log    ] [55       ] [INFO ] - PlaneScene: screen WxH : 1920x1080
    46. [2018-09-03 15:39:18,324] [Log    ] [MPMain   ] [INFO ] - Main: Stopping media
    47. [2018-09-03 15:39:18,327] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStopped()
    48. [2018-09-03 15:39:18,335] [Log    ] [MPMain   ] [INFO ] - GUIVideoFiles: OnPlayBackStopped idFile=2444 timeMovieStopped=17 resumeData= bdtitle=1000
    49. [2018-09-03 15:39:18,349] [Log    ] [MPMain   ] [INFO ] - overlay: video WxH  : 1920x1080
    50. [2018-09-03 15:39:18,350] [Log    ] [MPMain   ] [INFO ] - overlay: video AR   : 1920:1080
    51. [2018-09-03 15:39:18,350] [Log    ] [MPMain   ] [INFO ] - overlay: screen WxH : 1x1
    52. [2018-09-03 15:39:18,351] [Log    ] [MPMain   ] [INFO ] - overlay: AR type    : Normal
    53. [2018-09-03 15:39:18,351] [Log    ] [MPMain   ] [INFO ] - overlay: PixelRatio : 1
    54. [2018-09-03 15:39:18,352] [Log    ] [MPMain   ] [INFO ] - overlay: src        : (0,0)-(1920,1080)
    55. [2018-09-03 15:39:18,352] [Log    ] [MPMain   ] [INFO ] - overlay: dst        : (0,0)-(1,1)
    56. [2018-09-03 15:39:18,359] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:ended C:\Data\My_1080p_H264_MPG4_AVC_DTS-HD_HRA_7.1_movie.mkv
    57. [2018-09-03 15:39:18,360] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup DShow graph
    58. [2018-09-03 15:39:18,360] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VMR9
    59. [2018-09-03 15:39:18,407] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VideoCodec
    60. [2018-09-03 15:39:18,413] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioCodec
    61. [2018-09-03 15:39:18,415] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioRenderer
    62. [2018-09-03 15:39:18,415] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup InterfaceSourceFilter
    63. [2018-09-03 15:39:18,415] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess
    64. [2018-09-03 15:39:18,415] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess MediaPortal AudioSwitcher
    65. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter 0001
    66. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter Video Mixing Renderer 9
    67. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter TextPassThru099e106c
    68. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] - Disconnecting pin Out
    69. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] -   Not connected
    70. [2018-09-03 15:39:18,420] [Log    ] [MPMain   ] [INFO ] - Playback stopped and reverting volume OSD back to default device.
    71. [2018-09-03 15:39:18,485] [Log    ] [MPMain   ] [INFO ] - Mixer: changed audio device to default : 1 - marantz-AVR (AMD High Definition Audio Device)
    72. [2018-09-03 15:39:18,595] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Graphbuilder
    73. [2018-09-03 15:39:18,595] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Sub/PostProcess
    74. [2018-09-03 15:39:18,600] [Log    ] [MPMain   ] [INFO ] - Playback stopped and reverting volume OSD back to default device.
    75. [2018-09-03 15:39:18,665] [Log    ] [MPMain   ] [INFO ] - Mixer: changed audio device to default : 1 - marantz-AVR (AMD High Definition Audio Device)
    76. [2018-09-03 15:39:18,665] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Disabling DX9 exclusive mode
    77. [2018-09-03 15:39:18,665] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
    78. [2018-09-03 15:39:18,665] [Log    ] [MPMain   ] [INFO ] - GUIVideoFullscreen:stop
    79.  
    I will watch with VLC now but would appreciate a solution for MP.

    KODI has obviously similar playback problems i think. The audio input signal is detected as PCM multi channel but with correct channel layout with these movies.
     
    Last edited: September 4, 2018
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,485
    Likes Received:
    716
    Ratings:
    +1,199 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Try updating LAV to latest release, 0.72.0 is I believe the current released version. There was a problem that could be what you are experiencing in earlier versions, see here for more.
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  4. Cowboy
    • Premium Supporter

    Cowboy MP Donator

    Joined:
    January 25, 2011
    Messages:
    15
    Likes Received:
    7
    Gender:
    Male
    Occupation:
    Developer
    Ratings:
    +11 / 0
    Home Country:
    Germany Germany
    Man thanks for the response. I searched before posting this issue and was sure i am the first. Mostly this is a misbelief. I updated to 0.72 and what should i say. It is fixed. I wonder why the MPE installer did not show the update.
     
    Last edited: September 3, 2018
    • Like Like x 1
  5. azzuro
    • Team MediaPortal

    azzuro Test Group

    Joined:
    May 10, 2007
    Messages:
    8,443
    Likes Received:
    2,515
    Occupation:
    technician HVAC
    Location:
    France - IDF
    Ratings:
    +4,181 / 13
    Home Country:
    France France
    Show System Specs
    because we are not updated our base with latest update.
     
  6. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,485
    Likes Received:
    716
    Ratings:
    +1,199 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Will the MP Extension Manager be updated?
     
  7. azzuro
    • Team MediaPortal

    azzuro Test Group

    Joined:
    May 10, 2007
    Messages:
    8,443
    Likes Received:
    2,515
    Occupation:
    technician HVAC
    Location:
    France - IDF
    Ratings:
    +4,181 / 13
    Home Country:
    France France
    Show System Specs
    maybe it's @Vasilich for done this .
     
  8. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,485
    Likes Received:
    716
    Ratings:
    +1,199 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Would it be possible to automate the process of updating MP Extension Manager with the latest versions of important components?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!