MP1-4341 Add possibility to Deploy Tool to upgrade MySQL dB

Discussion in 'Area 51 - Testing Area' started by Sebastiii, January 24, 2014.

  1. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    Description of Change

    Actually, MySQL 5.6 is only available on clean install.
    This branch adds an option to DeployTool (Installer) to perform MySQL5.6 on upgrade (at own risk!).
    If something fails, the MySQL5.1 db is not touched :)

    Tickets : https://issues.team-mediaportal.com/browse/MP1-4341
    Wiki docs: What's New > 1.8.x > MySQL Upgrade choice
    Steps to install and test
    Installation
    Download the -->> installer <<-- and execute it.

    Testing
    Upgrade your current 1.6.0 Final installation but before :

    You need to have MySQL 5.1 installed by older MP install.
    Install with this installer.
    Select Upgrade and MySQL page should ask if you want to perform an upgrade.
    That's all :)

    Look if all is OK.
    Please do not forget to give some feedback (also if there is no bug). Thank you!

    Sebastiii

    Changelog



    Version 1.6.0 v1
    Build Based on MP 1.6.0 + master

    Version 1.6.0 v2
    Only binary based on MP 1.6.0 + master (Should only ask for upgrade MySQL on Singleseat ot TV Master only)

    Version 1.6.0 v3
    V3 installer should fix MySQL detection and also backup db (detect while debugging).
    This is based on MP 1.6.0 + master.

    Version 1.6.0 v4
    V4 installer display MySQL Upgrade page only if 'Upgrade button is selected and if MySQL 5.1 is installed'
    This is based on MP 1.6.0 + master.

    Version 1.6.0 v5
    V5 installer wiki link should be fixed and migration from MySIAM to Innodb should work too on db from MySQL 5.1.
    The migration of db will only active based on MySQL server 5.6.10 (installed by deploytool)
    This is based on MP 1.6.0 + master.

    Version 1.7.1 v6
    Installer based on 1.7.1 hotfix :)
     
    Last edited: May 7, 2014
    • Thank You! Thank You! x 5
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Tested on a multiseat client install. It asked if I wanted to update MySQL :confused:

    Need to check for TV server install first I guess!
     
    • Like Like x 1
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    Ok :) let's see what happen :)
     
  5. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Can anyone else confirm? I am confident that this happened. ;)

    Would be good to get it fixed before further testing if possible.
     
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    Hi,
    I have a bin for testing soon :) (just deploytool.exe)
     
    • Thank You! Thank You! x 1
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    V2 bin on first post (overwrite original MediaPortal.DeployTool.exe from V1 installer).
    Thanks :)
     
  8. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    That works - doesn't ask to update MySQL on multiseat client. No time to test on server this morning.

    Please can you update the branch?
     
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    Sure :)
     
    • Thank You! Thank You! x 1
  10. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,296
    Likes Received:
    6,248
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,269 / 9
    Home Country:
    France France
    Show System Specs
    Done :) and i will update first post with new installer :)
     
    • Outdated Information Outdated Information x 1
  11. breese
    • Premium Supporter

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I just cleared MP1 server/client off my machine along with the new version of MySQL.
    I have 1.5.0 Final. Does it install the older version of MySQL? If so I will do a Server only install for testing if that is what you need

    I installed 1.5.0 with MySQL 5.1. Doing a channel scan and movie import as a baseline for 1.7.0 upgrade test. This is a server only install
     
    Last edited: January 25, 2014
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!