[Bug] [MP1-4525] freezes when one video is playing (in small win) and play another video will come (1 Viewer)

marttoma

MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Steps to reproduce:
    1. start to play ts video (e.g. recorded TV)
    2. to go to home screen -> video from point 1 is playing in small windows on top of the screen
    3. go to camera video files and start to play any another video file
    4. MP immediately freezes -> just kill MP process helps
    Logs attached.
    Martin
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again :)

    MP is failing to stop the recording. Everything stops here:
    [2014-06-23 23:31:10,992] [Log ] [21 ] [INFO ] - TSReaderPlayer: Cleanup DShow graph True
    Looks like TsReader receives pause:
    [2014-06-23 23:31:10,992] [14680048] [ d80] - CTsReaderFilter::pause() - END - state = 1
    ...but never stop, possibly due to other codecs in the graph.

    The codecs in the graph seem strange:
    [2014-06-23 23:30:52,915] [14680048] [ a58] - audPin:CompleteConnect() ok, filter: Microsoft DTV-DVD Audio Decoder
    [2014-06-23 23:30:52,938] [14680048] [ a58] - demux:GetVideoStreamType(), FPS from DTS/PTS = 25.000000, DTSdiff/PTSdiff/MPEG2 = 0.120000/0.040000/0.040000, DTS/PTS count = 3/9
    [2014-06-23 23:30:53,006] [14680048] [ a58] - vidPin:CompleteConnect() ok, filter: LAV Video Decoder
    [2014-06-23 23:30:53,192] [14680048] [ a58] - vidPin:CompleteConnect() ok, filter: ATI MPEG Video Decoder
    [2014-06-23 23:30:53,251] [14680048] [ a58] - vidPin:CompleteConnect() ok, filter: LAV Video Decoder
    They don't match your configuration. The MS video codec is removed before starting playback:
    [2014-06-23 23:30:53,602] [Log ] [MPMain ] [DEBUG] - Check graph connections for: Microsoft DTV-DVD Video Decoder
    [2014-06-23 23:30:53,605] [Log ] [MPMain ] [DEBUG] - - remove done
    So it is like you have "codec hell/soup". This could be related to the radio issues you were seeing.

    Have you installed codec packs?
    How did you install those encoders?
    How did you install LAV?

    mm
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Hello again:)
    it looks like codecs never ending story:):):)

    MP is failing to stop the recording.
    It is strange as I did not record anything... I just start to play TV recorded ts file and then I went to home screen and then I went to video files and I started to play other video. No recording...


    Have you installed codec packs?
    How did you install those encoders?
    How did you install LAV?
    I installed Win 8.1Pro x64 as clean installation and then I just installed MP, LAV codecs and sw ATI codecs for FM radio -> so I did not do so much with codecs installation, I just installed LAV and ATI codecs this way:
    • I just installed LAV codecs during MP installation (than I upgraded to newer version via "MediaPortal Extension Installer")
    • I just installed ATI audio SW MPEG encoder manually by "regsrv32.exe"
    • I just installed ATI video SW MPEG encoder manually by "regsrv32.exe"
    The codec "Microsoft DTV-DVD Audio Decoder" and "Microsoft DTV-DVD Video Decoder" are available from Windows 8.1 installation I think as I did not install them.

    Martin
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    It is strange as I did not record anything... I just start to play TV recorded ts file and then I went to home screen and then I went to video files and I started to play other video. No recording...
    When I said "recording", I mean the recorded TS file.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Did you buy and/or install the media center pack/add-on for W8?

    Could you please try to use the LAV video codec with the MS DTV-DVD audio codec...
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Did you buy and/or install the media center pack/add-on for W8?
    No, I did not.


    Could you please try to use the LAV video codec with the MS DTV-DVD audio codec...
    Should I set it up (LAV + MS codec) to all - i.e. Video, Blueray, TV and DVD codecs?
    Which audio render then I should use in Video, Blueray, TV and DVD codecs?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 0
    ajs MP2Web - MP1 compatibility MediaPortal 1 20
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 12
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    C Streaming/transcoding MP2 vs MP1? General 1
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    S Shortcuts MP1 My Recorded & TV Guide General 10
    azzuro [WiP] MP1-4999 - Big changes with many related change at once by Sebastiii MediaPortal 1 12
    ajs [Help Us!] MP1 X64 Version MediaPortal 1 20
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    azzuro [WiP] MP1-5019: Replace MySQL with MariaDB MediaPortal 1 40
    catalpa Umsteiger von MP1: Schwierigkeiten Allgemeines Support- und Diskussionsforum 17
    CyberSimian [solved] MP1-4976 Built-in skin variables for current date MediaPortal 1 8
    rbo [solved] Umsteiger MP1 zu MP2 Allgemeines Support- und Diskussionsforum 67
    azzuro [Info] MP2 TVE inside MP1 repo MediaPortal 2 12
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    lisag Can I get MP1 to open in the Recorded TV screen? MediaPortal 1 Talk 2
    M MP1 stops responding after Starting Plugins General Support 14
    R Problem with MP1 and WifiRemote Skins and Plugins Installer (MPEI) 8
    Similar threads

























    Top Bottom