MP2 - V2.1 MP2.1pre: Stuttering and Stills on Live-TV

Status
Not open for further replies.

Palm_Maniac

MP Donator
  • Premium Supporter
  • June 1, 2005
    1,238
    63
    Gießen, Hessen
    Country flag


    Hello

    In my first tests with live TV under MP2.1 I had to notice the same problems as before the improved tsreader.ax and tswriter.ax of @Owlsroost. Still images, hangers, etc. Since the TV-server is the same as in MP1.16pre and where the new files are used, the problem probably comes only from the player, clients.

    Is it possible that in the player the new tsreader.ax was forgotten? So I had not reckoned with the tests that this problem, which is actually already fixed, so again occurs.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,271
    113
    Country flag
    @morpheus_xx verified the tsreader.ax, which is logged as version v4.2.2.32 under MP 2.1 - the same one that the original 1.16pre is using here on my desk.

    The only difference we know of is that the 2.1pre package was built with VisualStudio 2015 while 1.16 has been compiled with VS2013. The different databases in MP1 and MP2 that you mention in another thread are not relevant as the RTSP communication process between client and server for the TV stream has nothing to do with the database.

    Check the tsreader.log of both file versions for this content: [2017-01-01 18:12:47,500] [13acbce8] [27c4] - ------------- v4.2.2.32 ------------- instanceCount:1
    • Is the file version the same in both cases?
    • Are the file sizes different?
     

    Palm_Maniac

    MP Donator
  • Premium Supporter
  • June 1, 2005
    1,238
    63
    Gießen, Hessen
    Country flag
    Hi,

    yes, the file sizes are different. The original supplied has a size of 777kB and the exchanged only 469kB. A TsReader.log file I can not find and is also not captured by the Log Collector.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,271
    113
    Country flag
    Said files have been confirmed to be identical. They were built from the same source with VS2013 and VS2015 respectively. As you are the only one to report this kind of issues, it is not clear what is happening.

    Please use @Owelsroost's separately provided package and exchange The tsreader.ax after each install of MP 2.1.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    @Palm_Maniac - attached are a later TsReader and TsWriter (they should be basically the same as the ones in MP 1.16 pre, but are built with VS2013).

    Can you try the TsReader.ax and see if it behaves any different to the older, pre-HEVC version from the old 'rate matching' thread that you have been using.
     

    Attachments

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,271
    113
    Country flag
    @Owlsroost ,

    Mystery :confused:. I assume you compiled 1.15.0.774 with VS2013. Any chance to do the same with VS2015 and upload it for PalmManiac to test? Or am I completely wrong?
     
    Status
    Not open for further replies.
    Top Bottom