[solved] - MP2.2.1 can't play TV

Discussion in 'General' started by Ralph Holmes, May 2, 2019.

  1. Ralph Holmes
    • Premium Supporter

    Ralph Holmes MP Donator

    Joined:
    August 5, 2015
    Messages:
    47
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    MediaPortal 2 Version: 2.2.1

    Description
    I use MP2 with a Hauppauge WinTV-dualHD USB device on Windows 10. This morning MP2.2 produced an error "No TV provider available (yet)". When I ran MediaPortal 2 TV Configuration I could see all my TV channels and view them using the Preview button. I installed MP2.2.1 to see if that fixed the problem, but it did not.
    Can you sort me out, please?

    Steps to Reproduce:
    Run MP2.2.1 as an administrator. Wait a bit. Select TV. Select the red error cross.


     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Hello,

    You don't need to run MP2 as administrator.

    if this is a single-seat system, i.e. client and server app on the same PC, you my be facing a firewall problem. Please switch it off for testing purposes and repeat the process.
    If the problem persists, please switch log level to DEBUG and provide a new set of log files. Before doing that, kindly delete all the crash reports in your log directory as this is just noise.
     
  4. Ralph Holmes
    • Premium Supporter

    Ralph Holmes MP Donator

    Joined:
    August 5, 2015
    Messages:
    47
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Thank you for your prompt reply.
    I'm the only administrator for this PC, so, I guess, everything runs as administrator. Previously I have run MP2.2 as administrator without this causing a problem.
    The only active firewall I can find is the Windows Defender one, which I have now switched off. The MP2.2.1 problem persists.
    Just now I am reluctant to send you another log, because I do not know how to delete all the crash reports in the log directory - where is this located, please? When I find out how to dlete the reports I will generate a new log and send it to you.
    Cheers
    Ralph
     
  5. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    C:\ProgramData\Team Mediaportal\MP2-Client\Log
     
  6. Ralph Holmes
    • Premium Supporter

    Ralph Holmes MP Donator

    Joined:
    August 5, 2015
    Messages:
    47
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Thank you. I've deleted the previous crash reports.
    MediaPortal 2 LogCollector does not appear to offer any options: it just runs. How do I switch the log level to DEBUG, please?
    Cheers
    Ralph
     
  7. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Open the Settings part of the client: should then be in General/Diagnostics
     
  8. Ralph Holmes
    • Premium Supporter

    Ralph Holmes MP Donator

    Joined:
    August 5, 2015
    Messages:
    47
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Thanks again. Sorry if I appear a bit thick, but one of the reasons I need help is that I am not completely familiar with the operation of MP2.2.1

    Cheers
    Ralph
     

    Attached Files:

  9. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Here is your problem:
    Open your settings, go to Connections and disconnect the client from the server. Then search again for a MP2 server and reconnect the client to it. Then give it a new try.
     
  10. Ralph Holmes
    • Premium Supporter

    Ralph Holmes MP Donator

    Joined:
    August 5, 2015
    Messages:
    47
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +3 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    upload_2019-5-2_13-34-15.png

    I've recently taken out an option with Avast to try out their VPN. Could this be causing the problem?

    There's no great urgency to reply, because I have an appointment to attend this afternoon. I'll be back in four hours or so.

    Cheers

    Ralph
     
  11. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,699
    Likes Received:
    1,118
    Gender:
    Male
    Ratings:
    +2,400 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Yes, you've apparently cut your server off.

    I am not familiar with the VPN setup, but as you can see you need to ensure certain UDP and TCP port communication or MediaPortal is not able to communicate. You can check out the Windows Defender Firewall rules to know which one need to be open. But it might be easier to allow local communications, i.e. anything within the internal network without any Avast restrictions.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!