MP2 - V2.3 [solved] MP2 2.3 Import von Audioquellen / Datenbankprobleme (1 Viewer)

Wintersonne

New Member
November 14, 2020
12
2
Home Country
Germany Germany
Country flag
Hallo liebe Mediaportalcommunity,
da ich recht neu zum MP2 gekommen bin, weiß ich nicht ob mein Problem ein echter Bug oder nur meine eigene Blödheit ist.
Aber ich hoffe, Ihr könnt mir trotzdem helfen.

Kurze Hintergrundgeschichte:
Nach knapp 10 Jahren habe ich meinem HTPC neue Hardware spendiert und bin dabei von Win7+MePo1 auf Win10+MePo2 umgestiegen.
Neue Hardware, frische Installation, keine Altlasten, Nereus als Skin.
Rein lokale Installation, Server und Client auf dem selben Rechner, Mediendaten auf einer lokalen Festplatte.
Soweit läuft auch alles recht problemarm.

Parallel dazu digitalisiere ich meine CD Sammlung.
Mittels Exact Audio Copy erstelle ich .flac Dateien von den CDs.
Die Daten für die Tags kommen von freeDB und werden im EAC gleich mit angelegt.
Alle Audiodaten liegen dann in folgender Ordnerstruktur: "X:/Musik/[Interpret]/[Album]/Dateien

Nun will ich die Musikdaten im MP verfügbar machen.
Einstellungen>Medienquellen>Medienquellen konfiguration>Hinzufügen
Ich wähle "lokales Dateisystem", "X:/Musik" als Pfad und "Audio" als Typ.
Darufhin beginnt der Import und etwas später sind die Medien auch verfügbar.

Zumindest prinzipiell, denn hier beginnen die Probleme.
Versuche ich über Audio>Album oder Audio>Interpret eine CD zu wählen, steht in beiden Fällen nur "Keine Einträge" im Fenster.
Audio>Track liefert eine sehr lange List, Audio>Jahr funktioniert mit Auflistung nach Jahrzehnten.
Über "Ordneransicht" kann ich in der bestehenden Verzeichnisstruktur zu den Alben navigieren, aber die Filterung nach Tags über MP funktioniert fast gar nicht.
Alle Rubriken liefern "Keine Einträge" mit Ausnahme von "Jahr" und "Disk".

Ich vermute, das beim Import momentan nur rein numerische Tags verarbeitet werden und alphanumerische Tags Probleme machen.
Die Tags selbst scheinen aber in Ordnung zu sein.
Sobald ich eine Datei starte, werden alle hinterlegten Informationen wie "Interpret", "Album", "Titel" und die Coverart korrekt angezeigt.
Bisher werden aber auch keinerlei Fanarts angezeigt.
Vermutlich, weil keine Tags zum Auswerten erkannt werden.

Bitte entschuldigt die lange Beschreibung, aber ich hoffe Ihr könnt mein Problem nachvollziehen.
Falls zusätzlich Logs oder Screenshots benötigt werden, lasst es mich wissen.
MP2 funktioniert zwar so auch, aber irgendwie fehlt halt einfach was.

Gruß Wintersonne
 
Last edited:

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,384
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Hallo liebe Mediaportalcommunity,
    da ich recht neu zum MP2 gekommen bin, weiß ich nicht ob mein Problem ein echter Bug oder nur meine eigene Blödheit ist.
    Aber ich hoffe, Ihr könnt mir trotzdem helfen.

    Kurze Hintergrundgeschichte:
    Nach knapp 10 Jahren habe ich meinem HTPC neue Hardware spendiert und bin dabei von Win7+MePo1 auf Win10+MePo2 umgestiegen.
    Neue Hardware, frische Installation, keine Altlasten, Nereus als Skin.
    Rein lokale Installation, Server und Client auf dem selben Rechner, Mediendaten auf einer lokalen Festplatte.
    Soweit läuft auch alles recht problemarm.

    Parallel dazu digitalisiere ich meine CD Sammlung.
    Mittels Exact Audio Copy erstelle ich .flac Dateien von den CDs.
    Die Daten für die Tags kommen von freeDB und werden im EAC gleich mit angelegt.
    Alle Audiodaten liegen dann in folgender Ordnerstruktur: "X:/Musik/[Interpret]/[Album]/Dateien

    Nun will ich die Musikdaten im MP verfügbar machen.
    Einstellungen>Medienquellen>Medienquellen konfiguration>Hinzufügen
    Ich wähle "lokales Dateisystem", "X:/Musik" als Pfad und "Audio" als Typ.
    Darufhin beginnt der Import und etwas später sind die Medien auch verfügbar.

    Zumindest prinzipiell, denn hier beginnen die Probleme.
    Versuche ich über Audio>Album oder Audio>Interpret eine CD zu wählen, steht in beiden Fällen nur "Keine Einträge" im Fenster.
    Audio>Track liefert eine sehr lange List, Audio>Jahr funktioniert mit Auflistung nach Jahrzehnten.
    Über "Ordneransicht" kann ich in der bestehenden Verzeichnisstruktur zu den Alben navigieren, aber die Filterung nach Tags über MP funktioniert fast gar nicht.
    Alle Rubriken liefern "Keine Einträge" mit Ausnahme von "Jahr" und "Disk".

    Ich vermute, das beim Import momentan nur rein numerische Tags verarbeitet werden und alphanumerische Tags Probleme machen.
    Die Tags selbst scheinen aber in Ordnung zu sein.
    Sobald ich eine Datei starte, werden alle hinterlegten Informationen wie "Interpret", "Album", "Titel" und die Coverart korrekt angezeigt.
    Bisher werden aber auch keinerlei Fanarts angezeigt.
    Vermutlich, weil keine Tags zum Auswerten erkannt werden.

    Bitte entschuldigt die lange Beschreibung, aber ich hoffe Ihr könnt mein Problem nachvollziehen.
    Falls zusätzlich Logs oder Screenshots benötigt werden, lasst es mich wissen.
    MP2 funktioniert zwas so auch, aber irgendwie fehlt halt einfach was.

    Gruß Wintersonne
    Schalte wieder auf die Bibliothekansicht und setze den Filter auf Album. Öffne dann ein Album und du siehst alles Tracks. Wenn du noch einmal den Filter auf Disc's setzt, siehst du nochmal die Unterteilung nach Disks. Bei mir haben die auch Inhalte, funktioniert hier Problemlos.
    Teste es einfach noch einmal wie beschrieben und sonst lade mal einen Screenshot hoch.

    Was meinst du mit "eine CD"? Ich hab es jetzt mal als "Disc" gedeutet.
     

    Wintersonne

    New Member
    November 14, 2020
    12
    2
    Home Country
    Germany Germany
    Country flag
    Danke für den Hinweis.
    Leider ist das ja mein Problem.
    Die Dateien sind da, aber Mediaportal zeigt Sie nicht in den gefilterten Ansichten.

    Bezüglich "CD" habe ich mich unklar ausgedrückt.
    Im Umfeld von Mediaportal meinte ich ein Album das mehrere Tracks enthält.

    Hier einige Screenshots zur Erläuterung.
    Die Audio Hauptansicht. Offensichtlich wurden die Medien importiert.
    Audio.jpg


    Wähle ich den Menüpunkt "Tracks" werden auch alle Einträge angezeigt.
    Die Tags der einzelnen Dateien erscheinen korrekt und vollständig.
    Tracks.jpg


    Nun zum Menüpunkt "Album". Hier herrscht gähnende Leere.
    Album.jpg


    Wähle ich den Menüpunkt "Jahr", so werden die Medien wieder korrekt gefunden:
    Jahr.jpg


    Filtern nach "Album und Interpret" liefert nur eine leere Liste:
    Filter_AlbumInterpret.jpg


    Gehe ich auf die Ordneransicht, so sind die Dateien über die Verzeichnisstruktur zugänglich.
    Ordneransicht.jpg


    Wie gesagt, ich vermute, dass der Medienimport schief geht und die Tags der einzelnen Dateien nicht korrekt ausgewertet werden.
    Nur die Filter, die reine Zahlenwerte abfragen, also "Jahr" und "Disk" liefern Ergebnisse.
    Alle anderen Filter liefern <Keine Elemente>.
    Offen bleiben die Fragen "Wieso, weshalb, warum?" und "wie lässt es sich beheben".
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,384
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Hast du Team Viewer installiert? Wenn nicht, könntest du es kurz tun und ich kann es mir mal ansehen.
    Erfahrungsgemäß geht das schneller als etliche Nachrichten hin und her.
    Falls ok, bitte per privater Nachricht und nicht im öffentlichen Forum hier :)

    PS: Da die Alben im Home Bildschirm angezeigt werden, wurden sie schon korrekt erkannt. auch wird bei den Details de Tracks der Albumname korrekt angezeigt.
    In bin in ca. 30 Minuten weg. Falls es bis dahin nicht mit TV klappt. Probiere mal die Audio-Quelle im Importer wieder zu entfernen und füge sie noch einmal neu hinzu, so dass ein neuer Import gestartet wird. Vielleicht ist damit das Problem schon gelöst.
     
    Last edited:

    Wintersonne

    New Member
    November 14, 2020
    12
    2
    Home Country
    Germany Germany
    Country flag
    Die Audioquelle zu entfernen und neu zu importieren habe ich bereits versucht.
    Sowohl mit .flac als auch mit .mp3 Daten und mit unterschiedlichen Verzeichnisstrukturen.
    Das Ergebnis was stets das Selbe.
    Was Team Viewer betrifft, so haben wir uns knapp verpasst. Ich schick Dir eine PN.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,384
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Kannst du bitte deine Logfiles hier hochladen. @henso wird sich diese ansehen.

    @henso he said English is ok for him. So no hesitation to comment here in English.
     

    Wintersonne

    New Member
    November 14, 2020
    12
    2
    Home Country
    Germany Germany
    Country flag
    Okay, please find the logfiles attached.
     

    Attachments

    • MediaPortal2-Logs-2020-11-12-17.11.22.zip
      223.4 KB · Views: 0
    • MediaPortal2-Logs-2020-11-15-18.50.36.zip
      858.7 KB · Views: 0
    • MediaPortal2-Logs-2020-11-16-18.30.59.zip
      942.3 KB · Views: 0

    Wintersonne

    New Member
    November 14, 2020
    12
    2
    Home Country
    Germany Germany
    Country flag
    Just had a little look into the Server Logfiles myself.
    Can't say I really understand them. But every file I try to import throws an error because some value is "NULL"
    Just as an random example:

    [2020-11-15 19:30:12,509] [833698 ] [198 ] [INFO ] - Media item a94bcb60-e95d-41ba-b206-093d406c6372 with name American IV: The Man Comes Around: 12 - I’m So Lonesome I Could Cry (12. I’m So Lonesome I Could Cry - Johnny Cash.flac) imported (1 ms)
    [2020-11-15 19:30:12,511] [833700 ] [178 ] [WARN ] - ImporterWorker.ImportJob(#4).RelationshipExtractorBlock: Error while processing PendingImportResource '{03dd2da6-4da8-4d3e-9e55-80e3165729a3}://D:\Musik/Cash, Johnny/American IV - The Man Comes Around/12. I’m So Lonesome I Could Cry - Johnny Cash.flac' (parent directory={03dd2da6-4da8-4d3e-9e55-80e3165729a3}://D:\Musik/Cash, Johnny/American IV - The Man Comes Around/)
    System.ArgumentNullException: Der Wert darf nicht NULL sein.
    Parametername: source
    bei System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source)
    bei MediaPortal.Extensions.MetadataExtractors.NfoMetadataExtractors.TrackAlbumArtistRelationshipExtractor.<TryExtractRelationshipsAsync>d__17.MoveNext()
    --- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
    bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    bei MediaPortal.Common.Services.MediaManagement.ImportDataflowBlocks.RelationshipExtractorBlock.<ExtractRelationshipMetadata>d__12.MoveNext()
    --- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
    bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    bei MediaPortal.Common.Services.MediaManagement.ImportDataflowBlocks.RelationshipExtractorBlock.<ExtractRelationshipMetadata>d__11.MoveNext()
    --- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
    bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    bei MediaPortal.Common.Services.MediaManagement.ImportDataflowBlocks.RelationshipExtractorBlock.<ExtractRelationships>d__10.MoveNext()
    --- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
    bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    bei MediaPortal.Common.Services.MediaManagement.ImportDataflowBlocks.RelationshipExtractorBlock.<ProcessMediaItem>d__8.MoveNext()

    Apparently the files are corrupted in a way that prevents an import, while either MediaPortal or VLC still are able to play the music.
     

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,324
    811
    Home Country
    Denmark Denmark
    Country flag
    @Wintersonne
    I'm not sure they are corrupted. Maybe they just contain or miss some expected information. Could you provide me with one of your audio files?
     

    Wintersonne

    New Member
    November 14, 2020
    12
    2
    Home Country
    Germany Germany
    Country flag
    Here you go. The zip contains the file I mentioned in the example.
    To avoid any copyright issues, I put a password on the zip file.
    I will send that to you by PM.
     

    Attachments

    • 12. I’m So Lonesome I Could Cry - Johnny Cash.zip
      15 MB · Views: 0

    Users who are viewing this thread

    Similar threads

    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht "blockiert" das CAM Modul die Tuner, weil sie "zugewiesen" sind. Obwol kein Modul enthalten ist, versuchen die Karten wohl darüber ein Signal zu erhalten oder zu entschlüssen. Dies schlägt fehl und blockiert so den...
    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht...
    Hallo. Ich habe ein Problem mit meiner TV Karte und eurer Software. Aus irgendeinen Grund findet die MP2 beim Sendersuchlauf keine...
    Replies
    6
    Views
    372
    Bin kein Experte, hab mir aber trotzdem mal deine logs angesehen. Offensichtliche Probleme hab ich jetzt nicht entdecken können, aber ein paar mögliche Punkte an denen man ansetzen könnte um das Problem weiter einzugrenzen: - In der InfoService.log wird ein fehlender Ordner/Datei beklagt: Error loading default feed logo from...
    Bin kein Experte, hab mir aber trotzdem mal deine logs angesehen. Offensichtliche Probleme hab ich jetzt nicht entdecken können...
    Hallo seit kurzem startet bei mir nicht mehr der MP1 client der splash screen kommt es werden die module geladen doch dann sehe ich...
    Replies
    1
    Views
    213
    • Locked
    @Patrik-See: meine Meinung, ich hoffe jetzt noch auf dieses neue Skin. Es sieht auf den Screenshots so aus, als sei es strukturierter. Die Art und Weise wie die Einstellungen gemacht werden finde ich auch nicht so gut (wie bei Kodi, das muss wohl so wenn man es am Client mit der FB machen will, ich fand das alte Configtool...
    @Patrik-See: meine Meinung, ich hoffe jetzt noch auf dieses neue Skin. Es sieht auf den Screenshots so aus, als sei es...
    Hallo zusammen, war jetzt eine zeitlang inaktiv. Nun dachte ich mir ich schau mal was es neues gibt und update ggf. mein MP2 mal...
    Replies
    42
    Views
    2K
    Hallo zusammen also ohne Klikfinder (leider) läuft MP2.3.2 Ohne Probleme, kein Absturz bis jetzt keine Aufnahme die abgebrochen wurde, nur leider sind die Programm Infos im EPG meistens Komplet Falsch. Lade diese mit EPG Buddy. Diese habe ich soweit ich es begriffen habe Konfiguriert ( bin einfach zu blöd dazu ) so gut ich das...
    Hallo zusammen also ohne Klikfinder (leider) läuft MP2.3.2 Ohne Probleme, kein Absturz bis jetzt keine Aufnahme die abgebrochen...
    Hallo zusammen, Bisher habe ich eigentlich immer alle Updates von Media Portal 2 Client und Server, ohne Probleme gemacht, nur das...
    Replies
    19
    Views
    965
    :eek::rolleyes::D Bei Bildern habe ich im Hauptmenü gedrückt. Dann kam sofort das (Sub)Menü wie auf den Screenshots. Aus irgendeinem Grund verschwindet das Bilder HAUPTMENÜ sofort links. Daher war ich so ratlos und wusste nicht, wovon Du sprichst. Mit einmal Curser / FB zurück nach links kommt es aber dann. Und DANN, ja .. DANN ...
    :eek::rolleyes::D Bei Bildern habe ich im Hauptmenü gedrückt. Dann kam sofort das (Sub)Menü wie auf den Screenshots. Aus...
    Hi, gibt es eine Möglichkeit, die Reihenfolge im Nereus Hauptmenü zu ändern? Konkret: MP2 wird bei mir in erster Linie für TV...
    Replies
    6
    Views
    398
    Top Bottom