MP2 Client Screen Flickering on Resume (1 Viewer)

PN23

Portal Member
November 25, 2019
30
2
44
Home Country
United Kingdom United Kingdom
Country flag
I am running a standalone setup using and AMD/ATI graphics card connected by HDMI to a TV and everything is working pretty well other than a screen flickering issue.

This only occurs when the MP2 client is running and can be re-produced by changing the channel on the TV (to move from the HDMI input connected to the PC to any other input for any length of time and then moving back to the PC HDMI input) or by resuming the PC from sleep/suspend.

Nothing is displayed on the screen at all - it is black and just flickers on and off and this only happens if the MP2 client is running when the TV input is changed or the PC suspended.

This is the exact same rig that I have used flawlessly running Windows Media Center for years without this issue. Does anyone have any ideas or pointers?

I have disabled all AMD/ATI services and applications from starting at boot.
 

HTPCSourcer

Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Hello,

    This only occurs when the MP2 client is running and can be re-produced by changing the channel on the TV (to move from the HDMI input connected to the PC to any other input for any length of time and then moving back to the PC HDMI input) or by resuming the PC from sleep/suspend.
    The "Black screen" problem was introduced with Windows 1709 and is linked to how the DirectShow parts of MediaPortal operate.

    There is no perfect cure to the issue but you can try the following:
    • Change the Windows volume up and down
    • Press the Windows key on your keyboard
    • Bring any other window to the front
    • Toggle MP2 from full screen to windowed mode (Alt-Enter on keyboard).
    On my system I resolved the black screen upon resume by defining a scheduler task (executed on resume only) that just opens a cmd windows and closes it again. However, if you switch off the HDMI, the screen will definitely go black and you will need to use one of the above possibilities to bring it back.

    P.S.: We invite the new members to fill in their hardware specifications in their user profile and set it to visible.
     

    PN23

    Portal Member
    November 25, 2019
    30
    2
    44
    Home Country
    United Kingdom United Kingdom
    Country flag
    Thanks @HTPCSourcer

    I will create a scheduled task and see how I get on with that - I have just been using Alt-F4 until now to quit the MP2 client.

    Have created some systems specs in my profile.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 MP2 DLNA status? DE
    What I meant is that we have a MP2 plugin called UPnP Render that can play media from DLNA servers if I remember correctly. I don't know the current state of the plugin though. That's why MP2 probably never will be certified. ;) Yes, that was also the idea, but it is a big job as all TV's, software etc. seems to not do everything...
    What I meant is that we have a MP2 plugin called UPnP Render that can play media from DLNA servers if I remember correctly. I don't...
    So I'm wondering what the state of play is with MP2 and DLNA functionality? When I started this post, I did see some posts...
    Replies
    10
    Views
    608
    Same issue. Uninstalling & reinstalling worked for me as well. I did delete the folder tree, but looking beforehand showed that there were no files left after the uninstall & reboot.
    Same issue. Uninstalling & reinstalling worked for me as well. I did delete the folder tree, but looking beforehand showed that...
    I just upgraded from MP2 2.2.3 to MP2 2.3 and now my clients start, show the splash screen, and then don't move any further. Is it...
    Replies
    7
    Views
    1K
    Dumb mistake on my part. Forgot my TV signal amplifier was powered by my TV. Whoops. Plugged it into my HTPC and it all works now.
    Dumb mistake on my part. Forgot my TV signal amplifier was powered by my TV. Whoops. Plugged it into my HTPC and it all works now.
    Hi, new user. While debugging why I couldn't watch TV on a remote client via the Kodi Mediaportal PVR add-on, I noticed it only...
    Replies
    1
    Views
    452
    Well it's been a couple of days and we've had no more unable to play errors .
    Well it's been a couple of days and we've had no more unable to play errors .
    I've just upgraded the motherboard, CPU, ram, boot drives and PSU in my TV Server (always on), and am now having intermittent...
    Replies
    8
    Views
    888
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my keyboard just fine (also lightspeed wireless). Suggestions?
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my...
    Good evening, having just fresh installed media portal 2.3.2. Looking at trialing again as it now seems to support what I am...
    Replies
    1
    Views
    77
    Top Bottom