MP2-Server.exe automatic start of Windows service fails

Discussion in 'General' started by Midniteman, July 15, 2017.

  1. Midniteman

    Midniteman Portal Member

    Joined:
    July 15, 2017
    Messages:
    9
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    I just did a fresh Win7 and MP2 installation. All OS and application settings on default. After starting up Windows, the MP2 service (autostart) takes about two minutes to start up, while the network tray icon is "busy/connecting" all the time.

    If I set the service to manual start, the network icon will show "connected" right after Windows has started. Then I start the service manually and it starts within a few seconds.



    If I set the service to delayed start, it won't start at all.

    The logs show that the service takes minutes to start because it can't connect to the internet. I already tried changing the Windows firewall settings and even completely disabled the firewall --> no effect, same behaviour.

    Any idea?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Brownard
    • Team MediaPortal

    Brownard Development Group

    Joined:
    March 21, 2007
    Messages:
    1,919
    Likes Received:
    789
    Gender:
    Male
    Ratings:
    +1,326 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi,
    Can you post your logs please, use the log collector tool that should be on your desktop and post the resultant zip file file here.
     
  4. Midniteman

    Midniteman Portal Member

    Joined:
    July 15, 2017
    Messages:
    9
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
  5. Brownard
    • Team MediaPortal

    Brownard Development Group

    Joined:
    March 21, 2007
    Messages:
    1,919
    Likes Received:
    789
    Gender:
    Male
    Ratings:
    +1,326 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks, I think your issue is slightly different. The server tries to download some language info from thetvdb.com during startup, either it was unreachable or the request was causing a conflict with your (probably not fully initialized) network adapter, and the startup wasn't completed until this request timed out, causing the long delay.

    I have reworked it to try and avoid any web requests during startup - can you install the build from here and see if it resolves your issue?
    EDIT: Changes are included in the 2.1.1 release, so try that and see if it resolves your issue.
     
    Last edited: July 30, 2017
  6. Midniteman

    Midniteman Portal Member

    Joined:
    July 15, 2017
    Messages:
    9
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Thank you so much, now it works perfectly! :)
    Is there a difference between the tinyurl-Build and the 2.1.1 Release?
     
    • Like Like x 1
  7. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,770
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Probably not. Check any log file: the most recent version should show these entries at the top:

    ApplicationCore: Version: 2.1.1707.10312
    ApplicationCore: Source: MP2.1.1_Final-f9acc7
     
  8. Midniteman

    Midniteman Portal Member

    Joined:
    July 15, 2017
    Messages:
    9
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    OK, it's the same, thank you.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!