MP2 - V2.3 MP2 Server stürzt immer nach kurzer Zeit ab (1 Viewer)

Wolfram99

Portal Member
October 24, 2020
16
6
Home Country
Germany Germany
Country flag
Ich habe MP 2.3 installiert (Update von 2.2.3). Der MP-Server stürzt immer nach kurzer Zeit (ca. 20 min) ab. Eine Ursache ist nicht erkennbar. Veränderungen an der Hardware wurden nicht vorgenommen. Der TV Service ist dann unter Dienste als beendet eingetragen und kann nicht mehr gestartet werden. Es ist ein Reboot des gesamten PC notwendig. Danach läuft wieder alles und das Ganze beginnt von vorn. Der Client läuft dagegen Problemlos. Nach Ablauf der Zeit stehen dann plötzlich im Client keine Datenbanken und kein TV mehr zur Verfügung. Eine sichtbare Fehlermeldung erscheint nicht. Von der Version 2.2.3 kenne ich dieses Problem nicht.
Bisher liefen Server und Client sehr stabil. Nach erneuter Installation der Version 2.2.3 ist alles wieder stabil. Vielleicht hat jemand eine Idee zur Abhilfe.
 

Wolfram99

Portal Member
October 24, 2020
16
6
Home Country
Germany Germany
Country flag
Entschuldigung. Logfile hatte ich vergessen hochzuladen. Habe ich soeben nachgeholt. MP1 ist schon lange nicht mehr in Nutzung. Ich nutze schon lange MP2 mit guten Erfahrungen und bin sehr zufrieden. Ein großes Lob an alle Entwickler.
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,494
    2,669
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Entschuldigung. Logfile hatte ich vergessen hochzuladen. Habe ich soeben nachgeholt. MP1 ist schon lange nicht mehr in Nutzung. Ich nutze schon lange MP2 mit guten Erfahrungen und bin sehr zufrieden. Ein großes Lob an alle Entwickler.
    Danke, schönes, dass dir MP2 gut gefällt. Hoffentlich noch bsser mit MP2.3, wenn es läuft.
    Leider sehe ich immer noch keine Logfiles.
     

    Wolfram99

    Portal Member
    October 24, 2020
    16
    6
    Home Country
    Germany Germany
    Country flag
    Neuer Versuch !
     

    Attachments

    • 326791_MediaPortal2-Logs-2020-10-24-17.40.47.zip
      5 MB · Views: 0

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,494
    2,669
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Neuer Versuch !
    Danke, ich sehe in den Logs nur einen Serverabsturz.
    [2020-10-24 09:51:23,844] [22481 ] [TVService] [ERROR] - TV Service failed to start: System.Runtime.InteropServices.COMException (0x80240007): Ausnahme von HRESULT: 0x80240007
    bei WUApiLib.IUpdateSearcher.QueryHistory(Int32 startIndex, Int32 Count)
    bei OSInfo_OSInfo.GetLastInstalledWindowsUpdateTimestamp()
    bei OSInfo_OSInfo.GetLastInstalledWindowsUpdateTimestampAsString()
    bei TvService.TvServiceThread.OnStart()
    Ich habe leider eine Ahnung was hinter dem Error-Code steckt. Es gibt dazu noch keinen einzige Bericht im Forum.
     

    Wolfram99

    Portal Member
    October 24, 2020
    16
    6
    Home Country
    Germany Germany
    Country flag
    ich habe nach den wiederholten Serverabstürzen das System aus einem Acronisbackup wiederhergestellt (Stand MP 2.2.3) vor dem Update auf MP 2.3. Danach noch einmal das Update auf MP 2.3 aufegspielt. Nach dem ersten wieder aufgetretenen Absturz habe ich die Logfiles gesichert und wieder mittels Backup auf MP 2.2.3 zurückgestellt. Seitdem läuft das System mit MP 2.2.3 wieder stabil.

    Der Serverabsturz tritt auch unabhängig von einer Aktion des MP ( Aufnahme, Wiedergabe oder keine Wiedergabe auf)

    Vielleicht gibt es ja in der Zukunft einen Hinweis auf die Ursache bis dahin bleibe ich erst einmal bei dem für mich stabilen MP 2.2.3. Es ist nur schade, weil ich den neuen Skin sehr gelungen finde und auch ein schnelleres Reaktionsverhalten bei MP 2.3 festgestellt habe.

    Tortzdem Danke für die Mühe.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,494
    2,669
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    ich habe nach den wiederholten Serverabstürzen das System aus einem Acronisbackup wiederhergestellt (Stand MP 2.2.3) vor dem Update auf MP 2.3. Danach noch einmal das Update auf MP 2.3 aufegspielt. Nach dem ersten wieder aufgetretenen Absturz habe ich die Logfiles gesichert und wieder mittels Backup auf MP 2.2.3 zurückgestellt. Seitdem läuft das System mit MP 2.2.3 wieder stabil.

    Der Serverabsturz tritt auch unabhängig von einer Aktion des MP ( Aufnahme, Wiedergabe oder keine Wiedergabe auf)

    Vielleicht gibt es ja in der Zukunft einen Hinweis auf die Ursache bis dahin bleibe ich erst einmal bei dem für mich stabilen MP 2.2.3. Es ist nur schade, weil ich den neuen Skin sehr gelungen finde und auch ein schnelleres Reaktionsverhalten bei MP 2.3 festgestellt habe.

    Tortzdem Danke für die Mühe.
    Hast du wirklich alle Windows Updates eingespielt und geprüft dass der Update-Service richtig funktioniert?
    Ich habe etwas recherchiert und der Fehlercode ist spezifisch für ein Windows Update Problem.

    Microsoft empfiehlt folgendes Vorgehen:
    For error 0x80240007 on Windows Update, we usually use two methods.
    Method 1: Modify Windows Update service
    • Stop Windows Update Service
    • Delete temporary update files in C:\Windows\SoftwareDistribution\DataStore and C:\Windows\SoftwareDistribution\Download.
    • Restart Windows Update service

    Method 2: Restart Windows Installer service
    • Type net start msiserver and press the Enter in elevated CMD

    Alternativ:
    1. In Start Search type:
      %windir%\SoftwareDistribution\DataStore in this new window and click OK.
    2. Delete all contents of this folder. (Hint: Use Ctrl + A to select all files and folders)
    3. Retry

    If the above fails:
    • Type the following command as Admin, and then press Enter. It may take several minutes for the command operation to be completed.
    • DISM.exe /Online /Cleanup-image /Restorehealth
    Once it got completed do:
    • sfc /scannow
     

    Wolfram99

    Portal Member
    October 24, 2020
    16
    6
    Home Country
    Germany Germany
    Country flag
    zumindest beihauptet Windows Update, dass alle Updates auf dem aktuellen Stand sind. Aber es ist ein interessanter Ansatz. Werde es in den nächsten Tagen mal genau überprüfen. Melde mich dann zum Ergebnis wieder.

    Danke
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Es handelt sich bei Error 0x80240007 in der Tat um ein Windows Update Problem und zwar um einen fehlenden bzw. beschädigten Index.

    0x80240007 is the error code WU_E_INVALIDINDEX as defined in wuerror.h:

    // MessageId: WU_E_INVALIDINDEX
    //
    // MessageText:
    //
    // The index to a collection was invalid.
    //
    Sollte eigentlich nichts mit MP zu tun haben...
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 Tray Icon DE
    Ok. Ist nicht mein vordringliches Problem :). Hat mich einfach interessiert. Hätte ja sein können, dass dies etwas Spezielles zu bedeuten hätte.
    Ok. Ist nicht mein vordringliches Problem :). Hat mich einfach interessiert. Hätte ja sein können, dass dies etwas Spezielles zu...
    Hallo, bevor ich mich an das neue MP 2.3 mache, hie noch eine Frage zum MP 2.2.3 die mich schon länger beschäftigt: Im Tray sehe...
    Replies
    4
    Views
    405
    Super danke. Genau das war es
    Super danke. Genau das war es
    Hallo zusammen, Ein System ist mit Windows 10.frisch aufgesetzt. Das System geht nach ein paar Minuten in den Standby Modus und...
    Replies
    2
    Views
    598
    Hallo zusammen also ohne Klikfinder (leider) läuft MP2.3.2 Ohne Probleme, kein Absturz bis jetzt keine Aufnahme die abgebrochen wurde, nur leider sind die Programm Infos im EPG meistens Komplet Falsch. Lade diese mit EPG Buddy. Diese habe ich soweit ich es begriffen habe Konfiguriert ( bin einfach zu blöd dazu ) so gut ich das...
    Hallo zusammen also ohne Klikfinder (leider) läuft MP2.3.2 Ohne Probleme, kein Absturz bis jetzt keine Aufnahme die abgebrochen...
    Hallo zusammen, Bisher habe ich eigentlich immer alle Updates von Media Portal 2 Client und Server, ohne Probleme gemacht, nur das...
    Replies
    19
    Views
    1K
    Moin, habe am letzten WE meinen Homeserver (Win10x64) mal komplett upgedatet und danach Festplattenreinigung (mit Windows Hausmitteln) gemacht. Nach einem Neustart lief zwar der MP2-Server aber kein TV-plugin mehr. Ich kam auch nicht mehr in die TV-Konfig. Habe dann 2.2.3 wieder als repair drübergebügelt - hat nichts gebracht. Hatte...
    Moin, habe am letzten WE meinen Homeserver (Win10x64) mal komplett upgedatet und danach Festplattenreinigung (mit Windows...
    Moin, habe am letzten WE meinen Homeserver (Win10x64) mal komplett upgedatet und danach Festplattenreinigung (mit Windows...
    Replies
    0
    Views
    594
    Hi, ich bekomme es einfach nicht hin. Ist mir jetzt auch egal. Ich wollte Kodi ja auch nur mal testen. Ich habe ja ein funktionierendes Windows Server - Client System Danke trotzdem an alle für die Unterstützung
    Hi, ich bekomme es einfach nicht hin. Ist mir jetzt auch egal. Ich wollte Kodi ja auch nur mal testen. Ich habe ja ein...
    Hallo, ich weiß nicht ob ich hier richtig bin. Ich versuche mit Kodi auf den Mediaportal Server zuzugreifen. Es funktioniert aber...
    Replies
    11
    Views
    2K
    Top Bottom