MP2 - V2.3 MP2 Server stürzt immer nach kurzer Zeit ab (3 Viewers)

DarkOrje

MP Donator
  • Premium Supporter
  • November 19, 2011
    73
    9
    Berlin
    Germany Germany
    Country flag
    Ich hatte das gleiche Problem und konnte es nicht lösen. Ich bin wieder voller Panik auf MP2.2.3 zurückgegangen. (Beim System-Restore sind dann natürlich leider die Log-Dateien flöten gegangen). Benutzt Du auch IPTV über eine FRITZ!Box 6490 Cable mit dem AVM_Tuner von morpheus_xx?
     

    rainbowforest

    Portal Member
    June 30, 2010
    40
    2
    Vienna
    Austria Austria
    Country flag
    Hallo Leute,

    leider muss ich mich in die Riege der Anwender mit den Serverabstürzen einreihen. Komplett idente Situation. Server crasht nach 30 Minuten - regelmäßig. Habe den Thread hier verfolgt, keine Update Probleme im System, alles auf aktuellem Stand.

    Gleiche Meldung wie beim Vorposter:5

    Name der fehlerhaften Anwendung: MP2-Server.exe, Version: 2.3.2010.13341, Zeitstempel: 0x5f8fdcac
    Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.19041.610, Zeitstempel: 0xd49544eb
    Ausnahmecode: 0xc0000374
    Fehleroffset: 0x000e6763
    ID des fehlerhaften Prozesses: 0x2768
    Startzeit der fehlerhaften Anwendung: 0x01d6c02b7f339fa6
    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Team MediaPortal\MP2-Server\MP2-Server.exe
    Pfad des fehlerhaften Moduls: C:\WINDOWS\SYSTEM32\ntdll.dll
    Berichtskennung: 306e1e14-2d73-4457-ae44-12d5a0965842
    Vollständiger Name des fehlerhaften Pakets:
    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 5

    Logs anbei5
     

    Attachments

    rainbowforest

    Portal Member
    June 30, 2010
    40
    2
    Vienna
    Austria Austria
    Country flag
    Falls euch das weiter hilft: ich habe jetzt die Windows logs ausgewertet. Es sind exakt 30 Minuten, dann stürzt der mp Server ab.

    Habe noch meine Energieeinstellungen umgestellt auf max. und alles durchgesehen. Nichts deutet auf einem Timer mit 30 min hin
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,202
    3,725
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Nach einem flüchtigen Blick auf die Logs ist auffällig, das der Server immer genau dann abstürzt, wenn die Digital Devices Karte anfängt das DVB-EPG zu grabben. Das könnte sehr wohl per Timer nach 30 Minuten gestartet werden. Ich habe den 2.3 Server hier völlig problemlos laufen. Ich nutze aber auch keine DD Tunerkarte (mehr)... Es ist also wohl kein generelles Problem mit dem DVB-EPG grabben sondern speziell im Zusammenhang mit DD.
    Die Leute, die derartige Probleme haben könnten ja probehalber mal das DVB-EPG grabben deaktivieren um zu sehen, ob der Server dann wie bei mir durchläuft... Um das noch mal klar zu machen, auch ich nutze (wenn auch nur für einen einzigen Sender) DVB-EPG, Nur habe ich einen anderen Tuner in Betrieb...
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,202
    3,725
    Lehmden
    Germany Germany
    Country flag
    Noch mal ein vielleicht wichtiger Nachtrag... Ich sagte ja, ich habe für einen einzigen Sender auch DVB-EPG am laufen. Ich verwende einen Triax TSS 400 SAT>IP Router und vier der eingebauten DVBIP "Tuner" vom TV Server... Doch leider funktioniert das EPG laden nicht. Im Log steht immer drin, das kein PMT gefunden werden konnte. So wie es aussieht, hat dieser eine Sender (Schau TV HD) gar kein EPG...
    Vielleicht ist das ja der einzige Grund, warum der Server bei mir nicht abstürzt während dem DVB-EPG grabben. Dann könnte das tatsächlich auch ein generelles Problem mit dem DVB-EPG grabben sein und nicht nur mit DigitalDevices Tunern....
    Ich werde das jetzt sowieso erst mal deaktivieren, da es in meinem Fall ja sowieso nichts liefert...
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,202
    3,725
    Lehmden
    Germany Germany
    Country flag
    Hi
    [2020-11-22 09:53:13,884] [212347 ] [96 ] [INFO ] - Timeshifting epg grabber started.
    Der Eintrag im Log ist 0,2 Sekunden vor dem Server crash um [2020-11-22 09:53:14,195] geschrieben worden. Also wohl doch nicht alles beim EPG-Grabben erwischt...
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,597
    7,059
    Germany Germany
    Country flag
    Ich denke auch, dass der Absturz vom DVB-EPG grabben kommt. Die letzten Zeilen im TsWriter.log beziehen sich darauf:
    Code:
    [2020-11-21 18:52:09,457] [1518949] [DVB EPG timer] [INFO ] - **************************************************
    [2020-11-21 18:52:09,457] [1518949] [DVB EPG timer] [INFO ] - ***** SIGNAL LEVEL: 100, SIGNAL QUALITY: 100 *****
    [2020-11-21 18:52:09,458] [1518950] [DVB EPG timer] [INFO ] - **************************************************
    [2020-11-21 18:52:09,458] [1518950] [DVB EPG timer] [INFO ] - user:epg add
    [2020-11-21 18:52:09,459] [1518951] [DVB EPG timer] [INFO ] - card: SignalTuneEvent card: 6 / subch: 0
    [2020-11-21 18:52:09,460] [1518952] [DVB EPG timer] [INFO ] - Controller: GrabEpg on card ID == 6
    Code:
    [2020-11-21 18:52:09,098] [709d6a8] [f88] - pmtgrabber: set callback:50cfd18
    [2020-11-21 18:52:09,098] [709d6a8] [f88] - pmtgrabber: grab pmt:414 sid:7864
    [2020-11-21 18:52:09,453] [709d6a8] [914] - pmtgrabber: got pmt 414 sid:7864
    [2020-11-21 18:52:09,454] [709d6a8] [914] - pmtgrabber: PMT pids changed from:
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  pcr      pid:    0 
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  pmt      pid:    0 
    [2020-11-21 18:52:09,454] [709d6a8] [914] - pmtgrabber: PMT pids changed to:
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  pcr      pid:   ac 
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  pmt      pid:  414 
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  video    pid:   ac type: H264
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  audio    pid:   96 language: UNK type: AC3
    [2020-11-21 18:52:09,454] [709d6a8] [914] -  audio    pid:   97 language: dos type: AC3
    [2020-11-21 18:52:09,454] [709d6a8] [914] - pmtgrabber: got new pmt version:1 ffffffff, service_id:7864
    [2020-11-21 18:52:09,454] [709d6a8] [914] - pmtgrabber: do callback pid 414
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: set video pid:ac
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: reset
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: set audio pid:96
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: reset
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: set audio pid:97
    [2020-11-21 18:52:09,456] [709d6a8] [f88] - analyzer: reset
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - epg: set callback
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - EpgScanner::GrabEPG
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - epg:GrabEPG
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - epg:ResetEPG()
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - epg:GrabEPG()
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - EpgScanner::GrabMHW
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - mhw grab
    [2020-11-21 18:52:09,461] [709d6a8] [f88] - mhw reset
    Ich habe erstmal geprüft, ob in den neueren MP1-Releases irgendwelche Bugfixes in diesem Bereich sind, aber die DirectShow-Filter sind ungeändert. Das bedeutet, ein Update der TVE3 in MP2 zu machen, wird erstmal nichts dran ändern.

    Ich kann nur empfehlen, den EPG-Scan auch beim Timeshift abzuschalten. Außerdem gab es glaube ich dort auch eine Checkbox, um die CRC-Prüfung zu deaktivieren. Das sollte man z.B. nicht tun, da fehlerhafte Datenpakete dann zu Abstürzen führen können.

    Denkbar ist auch, dass gerade bestimmte Sender "ungewöhnliche" oder neue Encodings für DVB-EPG verwenden, die in TVE3 einfach nicht unterstützt werden.
     

    Users who are viewing this thread

  • Similar threads
    OP Title Forum Replies Date
    Lehmden [WiP] [MP2-824] DLNA Server functionality MediaPortal 2 27
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    raffe How do I setup MP2 as an UPnP server? General 3
    Tim [further infos missing] MP2 Server crashes on channel scan 2.2 Archive 9
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    joecool70 [solved] Installationsprobleme: MP2-Server failed to start Allgemeines Support- und Diskussionsforum 25
    BlueMax1916 [Question] What does MP2 Server Service have to do with ...microsoft.com/filestreamingservice...? MediaPortal 2 3
    J [solved] Clients do not see available MP2 server in the network General 3
    Patrik-See Win 10 Benutzer bei verschiedenen Clients Betriebssysteme 4
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    M MP2 - V2.3 MP2 & USB Problems Submit: Bug Reports 10
    L MP2 - V2.3 Troubles upgrading from MP2 2.2.3 to 2.3 General 0
    T MP2 - V2.3 MP2 x64 won't run Submit: Bug Reports 5
    J Copying Old VHS tapes Newcomers Forum 8
    W MP2 - V2.3 MP2 2.3 Import von Audioquellen / Datenbankprobleme Allgemeines Support- und Diskussionsforum 26
    G MP2 - V2.3 New install and crashing MP2-2.3 General 6
    S MP2 - V2.3 MP2 No video General 6
    toricred MP2 - V2.3 MP2 2.3 Client won't start General 6
    Grisu002 MP2 - V2.3 MP2 2.3 Client startet nicht - bleibt beim Laden hängen Allgemeines Support- und Diskussionsforum 61
    M [solved] MP2 PROBLEME Standby Allgemeines Support- und Diskussionsforum 2
    Scheibes Was passiert bei MP2? Allgemeines Support- und Diskussionsforum 42
    S Programmierte Aufnahme in MP2 - kein Aufwachen des PC Allgemeines Support- und Diskussionsforum 5
    morpheus_xx [Finished] "What's New" plugin for MP2 upgrades MediaPortal 2 20

    Similar threads

    Top Bottom