MP2 Summer '15 Edition - Can not add the same drive as media source the 3rd time.

UNOPARATOR

MP Donator
  • Premium Supporter
  • September 19, 2007
    231
    28
    Istanbul
    Home Country
    Turkey Turkey

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    11,961
    113
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    Must be something special to you. I have seven subfolders from my drive D: as different media sources for different types of media items and never had such an issue.
    Your logs are flooded by messages about OneTrueError not working properly. This is nothing to worry about, it is an online error reporting and monitoring service MP2 uses for quality controls. But since the Summer15 release the service seems to be overloaded. So please stop your MP2 Server and then remove the plugin "1TrueError" from Server and Client plugins folders. Try to save them for later usage. Then start your Server again and try to replicate the error. With this done it's much easier to read the logs and see what's wrong...
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    83
    61
    Arlington Heights, Illinois
    Home Country
    United States of America United States of America
    Country flag
    Root cause for most of the errors

    [2015-07-14 19:19:13,310] [939554 ] [54 ] [ERROR] -
    TvLibrary.TvExceptionSWEncoderMissing: No video compressor filter found. You must install a supported video encoder!
    at TvLibrary.Implementations.Analog.Components.Encoder.CreateFilterInstance(IFilterGraph2 _graphBuilder, Tuner _tuner, TvAudio _tvAudio, Crossbar _crossbar, Capture _capture)
    at TvLibrary.Implementations.Analog.TvCardAnalog.BuildGraph()
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,188
    113
    Home Country
    Germany Germany
    Country flag
    Root cause for most of the errors

    [2015-07-14 19:19:13,310] [939554 ] [54 ] [ERROR] -
    TvLibrary.TvExceptionSWEncoderMissing: No video compressor filter found. You must install a supported video encoder!
    at TvLibrary.Implementations.Analog.Components.Encoder.CreateFilterInstance(IFilterGraph2 _graphBuilder, Tuner _tuner, TvAudio _tvAudio, Crossbar _crossbar, Capture _capture)
    at TvLibrary.Implementations.Analog.TvCardAnalog.BuildGraph()
    Damn, they should have been excluded from submitting:
    // TVE 3 names
    "TVLibrary.Interfaces.TvExceptionNoPMT",
    "TVLibrary.Interfaces.TvExceptionNoSignal",
    "TVLibrary.Interfaces.TvExceptionSWEncoderMissing",
    "TVLibrary.Interfaces.TvExceptionTuneCancelled",
    unfortunately the names are wrong :(

    Will fix this
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,188
    113
    Home Country
    Germany Germany
    Country flag
    First part of the fix: an updated OTE plugin which filters out the TVE3 exceptions (this time by correct namespace ;))

    Next topic would be the remaining issues:
    @mm1352000 do you think the latter is an interim solution we can live with?
     

    Attachments

    UNOPARATOR

    MP Donator
  • Premium Supporter
  • September 19, 2007
    231
    28
    Istanbul
    Home Country
    Turkey Turkey
    After overwriting the 1TE plugin in both client and server plugin folders and also disabling my analog tuners from server configuration, I was able to add another folder from my E: drive as a media source (movies). Also before trying to add the new media source, also the Pictures media source that I manually added before was able to start the reimport process. While these 2 were importing, I also added another drive (G: ) as a media source (movies) and MP2 client just hanged, no UI response but not "Not Responding" either. I will wait for awhile before killing the process. I'll post new logs after that...

    Edit: Still stuck UI but when checked the logs, all I see can this is this from ServerLog:
    Code:
    [2015-07-15 00:13:47,488] [352453 ] [FanArt Downloader 0] [WARN ] - OnlineLibraries.Downloader: Exception when downloading file C:\ProgramData\Team MediaPortal\MP2-Server\TheMovieDB\23127\Backdrops\dzJluqCVR7nQlHKKWpUa55721fj.jpg from http://image.tmdb.org/t/p/original/dzJluqCVR7nQlHKKWpUa55721fj.jpg (The operation has timed out)
    The last entry of ClientLog:
    Code:
    [2015-07-15 00:09:44,575] [100493 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'shares_config_overview' successfully shown
    Edit2: Client killed, Server manually stopped from services.msc, here the new logs.
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom