MP2 - V2.1 MP2 TV Service won't start (1 Viewer)

Status
Not open for further replies.

Fesnor

New Member
April 6, 2018
1
0
Canada Canada
MediaPortal 2 Version: 2.1.3

Description
Hi guys,

This actually applies to all MP2 attempts at installation. As the topic says, the TV service simply will not start. I have tried EVERYTHING that I can think of, over the past few months, before finally crumbling and making a profile just to post this. I sincerely do not understand what is happening - but I know I am not the only one, as I have found others having the same issue.

I do have MP1 installed. It has taken me a long time to get it to a point where I am happy, so unless it is absolutely necessary, I do not want to uninstall it. I do disable the TV service when attempting to install MP2. I have gone so far as to disable pretty much anything media related, but to no avail.

I believe I have narrowed down the culprit. It appears that the TV service cannot communicate out, claiming a blocked 31456 port to be the culprit. This is not true as I have enabled this port, along with a host of others I found online from older forum threads. I have attempted installation with my firewall off and connected JUST to my modem (no router involvement). No go. The TV service simply will not start.

The most common error message to see is:

"Failed to startup tvserviceSystem.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 192.168.1.42:31456"

But once in awhile I receive:

"Failed to startup tvservice.System.Runtime.Remoting.RemotingException: Requested Service not found"

The best link to a forum I can find is here:

MediaPortal 2 System.Net.Sockets.SocketException (0x80004005)

The English translated page can be found at:

Google Translate

Anyhow, I am just totally stumped. I don't believe it's my computer rig since it's just a TV server service startup error. I'm using Windows 7 Ultimate 64 bit with a Gigabyte GA-990FXA-UD3 F9 motherboard, AMD Phenom(tm) II X6 1100T Processor 3.30 GHz, NVIDIA GeForce GTX 750 Ti graphics card, two Hauppauge WinTV-HVR-2250 TV Tuners and a Hauppauge Collossus 2 card, and a Sound Blaster Z sound card. It all works really, really well. All drivers are up-to-date. No crashes, no issues with the build.

But the TV server service simply will not start during installation of MP2. i'm attaching my error logs and maybe you will see something that I do not.

Thanks for taking the time to look into this!

Steps to Reproduce:
installing MP2. The TV Server service will not initiate.
 

Attachments

ge2301

MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,615
    2,385
    Stuttgart
    Germany Germany
    Country flag
    Try to remove all MP2 related things from your PC.
    • Uninstall MP2
    • Remove everything in .../ProgramData/TeamMediaPortal/...
    • Reboot your PC
    • Deactivate Firewall (basically not necessary, it should ask you to release the port automatically)
    Install MP2 again. I had the same issue once and this was the only way to solve the problem.
    If this doesn't work we have to see further.
     

    JJDoherty

    MP Donator
  • Premium Supporter
  • July 10, 2013
    143
    72
    42
    Dublin
    Ireland Ireland
    Country flag
    Hi guys,

    While I encountered the very same problem as @Fesnor last night, after successfully tuning the DVB-T2 channels I then tuned the DVB-S2 channels and at some point after doing some organising of the channels I encountered the issue. I was, however able to resolve it by simply repairing the install, that is re-running the installation setup and selecting "Repair". This seemed to do the trick and all was well after that.

    This is the first successful installation of MP2 that I have managed in little over an 1 hour, from first installation to watching TV with P'nP working and some of my channel groups etc. setup. I've previously tried this, a year or more ago and indeed last week (last night was a more concerted effort) but having series link for recording TV and P'nP available made it too good to not try again. Now I don't have all the bells and whistles that I have working in my MP1 installation but it certainly is an improved process.

    Hope this helps...
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
    BlueMax1916 [Question] What does MP2 Server Service have to do with ...microsoft.com/filestreamingservice...? MediaPortal 2 3
    T MP2.2 Pre Release fails installation with not starting the MP2-service 2.2 Archive 4
    H MP2 database won't keep in synch with recordings General 2
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 58
    F Problems with new install of MP2 Newcomers Forum 3
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    ge2301 Android based client for MP2 MediaPortal 2 3
    R MP2 GUI Issues General 7
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    Lichloathe MP2 importing keyart instead of poster General 0
    Lichloathe Trakt for MP2 question General 7
    C Streaming/transcoding MP2 vs MP1? General 1
    P MP 2 - Request to add an additional TV series Filename protocal Feature Requests 0
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    CyberSimian MP2 synchronising of stoptime MediaPortal 1 Talk 5
    M Initial Setup MP2 (On Wndows 10) General 2
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    T Amazon und Netflix in MP2 - Wie? Allgemeines Support- und Diskussionsforum 6
    J [solved] How to in MP2 General 19
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    Similar threads

























    Top Bottom