MP2 - V2.3 MP2 & USB Problems (1 Viewer)

MP2 Fan

Portal Member
November 20, 2020
38
4
Home Country
United Kingdom United Kingdom
Country flag
Direct Connect Tests

I think this is about all we can do. The following screenshots are from a clean v2.2.3 Client installation, using firstly a Logitech Trackman which connects directly to USB then secondly using my preferred Trackman Marble FX which connects via a PS2/USB adapter.

The results show that the system works perfectly under these circumstances.

Therefore, as previously stated, the errors only occur when both the KVM AND ShellLibHID are both present (note that the equipment list appears completely different here compared to above with the KVM in place.

As I don't have space to have a second keyboard/mouse just for MP2 testing, I'll have to just do what I can on my client machines ~(both Win10 Intel NUCs).

Trackman shots

HID 20201128 Devices Trackman.jpg

HID 20201128 Log with USB Trackman.jpg


Marble FX shots

HID 20201128 Devices Marble.jpg

HID 20201128 Log with Marble.jpg
 

henso

Development Group
  • Team MediaPortal
  • February 16, 2012
    2,334
    819
    Home Country
    Denmark Denmark
    Country flag
    I only included them because Henso asked me to above. I presume that's why they are not enabled by default in HID Demo.
    Yes, I know. ;) I wanted to check if the mouse sends messages when not used. Can you check if there are messages logged when not touching the mouse or keyboard at all?
    I also presume MP2 client uses it to basically 'debounce' replicated messages.
    It ignores mouse move messages, but it still has to process each message.
    How come SharpLibHID is listed as an installed NuGet package and yet all references to it in 'InputDeviceManagement.cs' are greyed out (the Includes statements)?
    You mean the usings in InputDeviceManager.cs? They are shown as used for me (which they are).

    Could you try the attached ClientLauncher with KVM switch? You need to have MP2 client installed and put this in the same location as the existing one. Then start and check if you still have the issue. If you have then close it (right click and select close from the notification area) and attach the ClientLauncher.log file.
     

    Attachments

    • MP2-ClientLauncher.zip
      18 KB · Views: 0

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    HID Demo run with KVM. No spurious events logged.

    usings in InputDeviceManager.cs, yes. They are greyed out and all code references further down the page are underscored in red as errors. Also ShellDllHID is not in any of the module references, nor in the Project Dependencies list. I have 97 projects in the Client solution.
    I downloaded it because I was going to start looking at developing a skin. The few that there are seem to come from in-house and I have a few things I would like to try.

    Back to the tests. The new ClientLauncher made no difference at all. Keyboard still buffers out at 22 characters. You then have to wait 3/4 seconds to the response to pick up. Anything typed in those few seconds goes down the sink :D

    BTW. The test ClientLauncher is v2.3 only. It crashed when I tried it with the v2.2 Client that I already had installed.
     

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    Yes, I should have mentioned that. What about the log file I requested?
    Two here. First after initial install. Then I switched it off to get some normality.

    Then ran it again manually to give you another set for this post.
     

    Attachments

    • MediaPortal2-Logs-2020-11-28-16.14.08.zip
      171.3 KB · Views: 0
    • MediaPortal2-Logs-2020-11-28-16.19.44.zip
      172.9 KB · Views: 0

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    New CllientLauncher installed and run. Logs attached.

    Done for tonight. 18:30 here.
     

    Attachments

    • MediaPortal2-Logs-2020-11-28-18.26.32.zip
      177.8 KB · Views: 0

    Users who are viewing this thread

    Similar threads

    Thanks @high, bug report options look good now.
    Thanks @high, bug report options look good now.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    8
    Views
    615
    Workaround:- Use the close "x" button in the top right hand corner of the screen and MP2 should restart without need to reboot.
    Workaround:- Use the close "x" button in the top right hand corner of the screen and MP2 should restart without need to reboot.
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    2
    Views
    464
    I just recently had an epiphany around QueryDisplayConfig w.r.t. how Windows deals with displays. The MS documentation uses the word 'display' to refer to both GDI-devices and the monitors themselves. There is also a zoo of different Id formats that refer to these things (adapters, displays, monitors, etc), and often no apparent way...
    I just recently had an epiphany around QueryDisplayConfig w.r.t. how Windows deals with displays. The MS documentation uses the...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    4
    Views
    415
    @Tomkon The reported issue was fixed. The fix will be part of next release. If you are interested I might create a test version and provide the link by message.
    @Tomkon The reported issue was fixed. The fix will be part of next release. If you are interested I might create a test version...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    7
    Views
    605
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only update after the import is completed. Maybe we could have the force behavior during import only and after it completes the home content should always be up to date?
    I remember that the home content was not always up to date. One situation I think can cause this is during import as the list only...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    725
    Top Bottom