Multiple programs responding to IR commands since upgrade from 1.12 (1 Viewer)

johns11

Portal Pro
February 7, 2007
112
38
Auckland
New Zealand New Zealand
Country flag
Hi all.

I've been running MP 1.12 for quite a while and have recently upgraded to 1.21. I now have a remote control issue which did not previously exist, and to be honest I'm not sure where to start with debugging.

I use the good old MCE remote controls (MCE 2/1039) on media PCs around my house (in other words I'd prefer not to change).

I also have MediaMonkey and Spotify running on the same machine as where I'm having this issue. These sit behind Mediaportal, as it's set to "Keep Mediaportal Always on top"

Since the 1.12 to 1.21 upgrade:
- when I use the PLAY button in Mediaportal, either MediaMonkey or Spotify immediately starts playing music, rendering the Play button useless in Mediaportal.
- and when I use the PAUSE button a Spotify Pause menu pops up on top of Mediaportal.

In the "Remotes and Input devices" I have the HID tab with "Enable HID" ticked with Classic profile selected.

It's as though Mediaportal was previously the app with the focus for input commands, but now it is letting these commands go through to other apps.

Note for completeness: I also use an old version of LM Remote Keymap, and also Eventghost, which could have some impact on remote commands but neither of these have changed.

Does anyone have any thoughts on how to configure it so that only Mediaportal responds to the IR Remote commands?

Thanks a lot for any ideas
Johns11
 

johns11

Portal Pro
February 7, 2007
112
38
Auckland
New Zealand New Zealand
Country flag
I expected this would have affected many others, but it seems not. I guess that's mostly good news.

Unfortunately it's a big issue for me when my wife presses the Play button to play a TV recording (for example), my amplifier automatically changes to a stereo input and music starts playing at twice the volume (from something other than Mediaportal)... in that situation it's all my fault! :cry: On the upside my kids think it's hilarious.

For now at least, I've downgraded to 1.12 and this problem has gone away. I'd prefer not to be on 1.12 forever but right now I don't know of any other option.
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,015
    1,245
    Southampton
    United Kingdom United Kingdom
    Country flag
    For now at least, I've downgraded to 1.12 and this problem has gone away.
    The support for MCE RC6 remote controls was completely rewritten in a release of MP following 1.12, but I don't remember in which release this change occurred. Unfortunately, the rewrite was not transparent. I use an Ortek/Hama remote control (not an MCE RC6 remote), and it was affected by the rewrite, necessitating changes to the Ortek config file in order to restore normal behaviour.

    I don't know how to cure your problem, but I would suggest that you look carefully at the EventGhost and LM Remote Keymap tools that you are using. You may need to modify their action, or remove them completely.

    Unfortunately, it is not likely that the support for MCE RC6 will be changed now, as it works correctly for most people (and the team member who authored the rewrite is no longer active).

    -- from CyberSimian in the UK
     

    johns11

    Portal Pro
    February 7, 2007
    112
    38
    Auckland
    New Zealand New Zealand
    Country flag
    Thanks CyberSimian, I appreciate the reply. I have the source code for both 1.12 and 1.21 so one day if I have some time I might try to compare the two and see what I can find. I do suspect that the changes could be quite extensive though. I'll update here if I figure anything out of course, and in the meantime I still have a functioning system :)

    Cheers
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
    Frans Nijhuis Tv/Radio channel Import Export xml and multiple identical channel names Newcomers Forum 0
    H [solved] Multiple Network Interfaces Server Issue General 1
    S folder.jpg doesn't work properly with multiple subfolders (Videos) 1.19 4
    P Multiple clients - share resume/watched data General 1
    Lehmden Small glitch with multiple video resolutions for one movie... MediaPortal 2 4
    R MP 2.2.3 Search TV program only with the correct begin of show title General 7
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    R Visual status of watched TV programs MediaPortal 1 Talk 2
    A [solved] Cant see all recorded programs General 9
    L [solved] Modifying programmed recording after setting it General 0
    G Switch to new channel at begining of program automatically Feature Requests 0
    K How to start Chrome or other programs MediaPortal 1 Talk 41
    drumrob Time and Genre overlap in program description 1.22 Pre Release 7
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    N [Finished] MP2-803 - Delete full series doesn't work when viewing a program in the extended schedule screen MediaPortal 2 12
    N What do the series recording options mean, and why is MP2 recording random programs? General 3
    M Problem With Sending Channel to External Program from TV3 Blaster IR Server Suite (IRSS) 1
    M Forwarding Cmd Line Arg in IRSS Run Program MediaPortal 1 Plugins 0
    A UK - BBC2 EPG suddenly has several programs daily with 'No information' Electronic Program Guide 57
    A [solved] XmlTv not importing programs General 8
    J Option to rename the programs during advance scheduling Feature Requests 0
    H [fixed] Series programming/deleting 2.2 Archive 1
    S Why open source fails and Integration wins for complex programs General 15
    Alberto83 [Evaluate] {Program Title} is starting Reminders MediaPortal 2 5
    Similar threads

























    Top Bottom