Multiple programs responding to IR commands since upgrade from 1.12

Discussion in 'Remotes' started by johns11, June 5, 2019.

  1. johns11

    johns11 Portal Pro

    Joined:
    February 7, 2007
    Messages:
    112
    Likes Received:
    19
    Gender:
    Male
    Location:
    Auckland
    Ratings:
    +20 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Hi all.



    I've been running MP 1.12 for quite a while and have recently upgraded to 1.21. I now have a remote control issue which did not previously exist, and to be honest I'm not sure where to start with debugging.

    I use the good old MCE remote controls (MCE 2/1039) on media PCs around my house (in other words I'd prefer not to change).

    I also have MediaMonkey and Spotify running on the same machine as where I'm having this issue. These sit behind Mediaportal, as it's set to "Keep Mediaportal Always on top"

    Since the 1.12 to 1.21 upgrade:
    - when I use the PLAY button in Mediaportal, either MediaMonkey or Spotify immediately starts playing music, rendering the Play button useless in Mediaportal.
    - and when I use the PAUSE button a Spotify Pause menu pops up on top of Mediaportal.

    In the "Remotes and Input devices" I have the HID tab with "Enable HID" ticked with Classic profile selected.

    It's as though Mediaportal was previously the app with the focus for input commands, but now it is letting these commands go through to other apps.

    Note for completeness: I also use an old version of LM Remote Keymap, and also Eventghost, which could have some impact on remote commands but neither of these have changed.

    Does anyone have any thoughts on how to configure it so that only Mediaportal responds to the IR Remote commands?

    Thanks a lot for any ideas
    Johns11
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. johns11

    johns11 Portal Pro

    Joined:
    February 7, 2007
    Messages:
    112
    Likes Received:
    19
    Gender:
    Male
    Location:
    Auckland
    Ratings:
    +20 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    I expected this would have affected many others, but it seems not. I guess that's mostly good news.

    Unfortunately it's a big issue for me when my wife presses the Play button to play a TV recording (for example), my amplifier automatically changes to a stereo input and music starts playing at twice the volume (from something other than Mediaportal)... in that situation it's all my fault! :cry: On the upside my kids think it's hilarious.

    For now at least, I've downgraded to 1.12 and this problem has gone away. I'd prefer not to be on 1.12 forever but right now I don't know of any other option.
     
  4. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,676
    Likes Received:
    556
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +981 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    The support for MCE RC6 remote controls was completely rewritten in a release of MP following 1.12, but I don't remember in which release this change occurred. Unfortunately, the rewrite was not transparent. I use an Ortek/Hama remote control (not an MCE RC6 remote), and it was affected by the rewrite, necessitating changes to the Ortek config file in order to restore normal behaviour.

    I don't know how to cure your problem, but I would suggest that you look carefully at the EventGhost and LM Remote Keymap tools that you are using. You may need to modify their action, or remove them completely.

    Unfortunately, it is not likely that the support for MCE RC6 will be changed now, as it works correctly for most people (and the team member who authored the rewrite is no longer active).

    -- from CyberSimian in the UK
     
  5. johns11

    johns11 Portal Pro

    Joined:
    February 7, 2007
    Messages:
    112
    Likes Received:
    19
    Gender:
    Male
    Location:
    Auckland
    Ratings:
    +20 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    Thanks CyberSimian, I appreciate the reply. I have the source code for both 1.12 and 1.21 so one day if I have some time I might try to compare the two and see what I can find. I do suspect that the changes could be quite extensive though. I'll update here if I figure anything out of course, and in the meantime I still have a functioning system :)

    Cheers
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!