MUSIC section will not open (1 Viewer)

GDkitty

New Member
March 18, 2013
12
0
42
Georgina, Ontario
Home Country
Canada Canada
Hey folks. New Media-portal user, so bear with me, if this is an EASY fix, that I missed.

First off.. LOVING Media portal. Already have 1.3 installed, with titan, have my movies /w database already set up and working... MPTV series set up, and databasing the TV series... even have the MyANime3 plugin working.

Now.. came to trying to setup the music.
Setup, is as per below
music1.jpg

music2.jpg


Music IS in the database it appears (not sure about album art, etc..) but when you try to update from the share, scans all, and says no new after going through 1700 or so.. so should be all in the database)

music3.jpg


Now.. the problem...

Initially, when I clicked on the MUSIC button, in the TITAN theme.. it would start to fade out like it was transitioning.. then NOTHING, came right back to the menu.

Found the MUSIC under plugins, was DISABLED. So I enabled that.
It now... goes INTO that section... it completely locks up MP.

I have also tried it, under the regular theme.. same thing, completely locks up MP.



Anyone have any ideas??
 

legnod

MP Donator
  • Premium Supporter
  • September 24, 2011
    1,115
    323
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Please check the "plugins" section and take a look at the "music" plugin. Is it enabled? if not....enable it and it should work

    EDIT: sorry...hadnt read the whole posting :)
    Have you made an manual scan for your Music folders inside the configuration? Click "update database from selected shares"
     
    Last edited:

    GDkitty

    New Member
    March 18, 2013
    12
    0
    42
    Georgina, Ontario
    Home Country
    Canada Canada
    Yes, the initial not opening period, I solved by enabling the plug :)

    Yes, I had already did the manual scan. Just ran it again, just incase.
    0 added / 4575 skipped. initial time I ran it, I am pretty sure is said that it added them... so its now skipping them, since they are in there.[DOUBLEPOST=1363706305][/DOUBLEPOST]Im going to try, a full 'overwrite' of the database.. just incase something is corrupt.

    It just sucks, there is no DATABASE VIWER, like there is for the videos, TV addons, etc.

    It updated/added a good portion of them.. still locks up completely though.

    Going to head to lunch shortly, will leave it running, and see if it maybe is just trying to cache things and needs time, etc.
     
    Last edited:

    GDkitty

    New Member
    March 18, 2013
    12
    0
    42
    Georgina, Ontario
    Home Country
    Canada Canada
    Not sure WHAT these errors mean.. but I am guessing its the CAUSE?
    Taken from the mediaportal.log

    Code:
    2013-03-19 11:26:56.422600 [Warn.][MPMain(1)]: GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\mymusicsongs.xml' is missing control id 8 (window property: btnSearch)
    2013-03-19 11:26:56.428600 [Warn.][MPMain(1)]: GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\mymusicsongs.xml' is missing control id 12 (window property: btnPlayCd)
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,750
    New Zealand
    Home Country
    New Zealand New Zealand
    Country flag
    When in the music section of MP Client, does MP Crash is that why you had to kill it.
    What happens when you change to 'shares view' instead of 'database' view (Go into music, access the side menu and choose view)
     

    GDkitty

    New Member
    March 18, 2013
    12
    0
    42
    Georgina, Ontario
    Home Country
    Canada Canada
    Success, I think!
    Well, when I went INTO that section to begin with, I want able to bring up ANY menu at all, it would hard lock before you could select anything.

    I went into the config, and changed the view on it in there for that share.. I think it was on icon.. to list. Then It let me into the music section!
    Everything seems to be there.. just need to play with the settings, to get it to display album art properly.. and will have to test if I can change the list/etc views without it locking again.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,750
    New Zealand
    Home Country
    New Zealand New Zealand
    Country flag
    'Shares view' does not use the music database, it is essentially a file viewer. You will not get fancy fanart, artist images, and album art in 'share view', you need to be in 'database view' for that to happen.

    I suggest delete your music database and rescan
    Start -> All Progs -> Team MP -> MP -> User Files
     

    GDkitty

    New Member
    March 18, 2013
    12
    0
    42
    Georgina, Ontario
    Home Country
    Canada Canada
    Well, the other views, appear to be working.. like it needed to get past SOME form of bad data in share view first.

    But seeing how bad my wife has messed up the music folder >.<.

    Most of the stuff she has ripped, has put all folders by artist, then album, and the database is picking it up, all as separate albums (with the same name, etc).

    I am going to do some MAJOR cleaning on the folders/files... and then likely do a database wipe for the music and let it rebuild then again.

    Thank you all for your help though :D
    I am LOVING MP!
     

    Users who are viewing this thread

    Similar threads

    This is not possible if it is a self made series, like personal travel videos etc.
    This is not possible if it is a self made series, like personal travel videos etc.
    Hi! I have videos that I want to show in TV-Series, such as personal TV series and educational series. As some examples I have...
    Replies
    8
    Views
    841
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my keyboard just fine (also lightspeed wireless). Suggestions?
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my...
    Good evening, having just fresh installed media portal 2.3.2. Looking at trialing again as it now seems to support what I am...
    Replies
    1
    Views
    247
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    435
    Good catch. (y) When the OS encounters a bad disk block during a read or a write, it repeats the operation many many times to see if the operation will succeed. I recollect seeing the value of 100 times (but that may not be accurate). The OS does this for each block. If there are many defective blocks, the system slows down due to...
    Good catch. (y) When the OS encounters a bad disk block during a read or a write, it repeats the operation many many times to see...
    Hello folks, I recently upgraded from Win7 to Win10, and have had some problems with MediaPortal, the main problem was my TVServer...
    Replies
    7
    Views
    944
    Hey guys, though I might say that I seem to be having the same issues. Not my keyboard playing up, but my logitech G903 mouse is very unresponsive. yet to test HID demo and see what it brings up but will have to do when im back in town from work. Will be keeping any eye on this thread to see what you find.
    Hey guys, though I might say that I seem to be having the same issues. Not my keyboard playing up, but my logitech G903 mouse is...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    44
    Views
    3K
    Top Bottom