mysqld.exe CPU load (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Is the problem 31300 rows of data? That seems a lot.
    I don't know, but it does seem a lot of data given the number of channels and EPG-days-per-channel.

    I copied the data files and folders over from the 5.1 folder, but I get this when attempting to start it.
    Yeah, that's never going to work.

    The least technically challenging way to transfer would be to export (ie. TV Server Configuration->import/export) from TV Server with MySQL 5.1, then configure TV Server to use 5.6 and create a new database, then import the 5.1 export.

    how many channels do you have: 59
    Sky?
    If yes, is this the standard version of TV Server? (ie. not the "DJBlu" version)

    Some of the slow queries are associated with 192.168.0.7 while others are associated with 192.168.1.100. What's the deal with that?
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    It is the standard version of VT Server, not DjBlu.

    The local server does have a 192.168.0.7 IP address allocated by a remote VPN server. I don't know why it selected that IP for logging but its local IP is 192.168.1.112.

    192.168.1.100 is my workstation with MP client installed where I loaded the Scheduled page.

    I thought about export/import and uninstalling MySQL 5.6 and the data I copied, then reinstalling 5.6. I'll give that a go.
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    Ok, I went through the process of exporting all data. That took perhaps 5 minutes. Uninstalled MediaPortal client and TV Server including databases. Installed MP again, which installed MySQL 5.6. Imported the export.xml and it say "Imported 24 channels, 0 tv channel groups, 1 radio channel groups, 0 schedules, and 451 settings" !!!!!

    I've lost everything. The 24 channels it imported are only FM radio channels.

    This is a disaster. I can't start all this from scratch! I've got a backup of the MySQL 5.1 data folder. Can perhaps someone help export this to 5.6 so I can recover everything?
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    I have a complete backup of the drive from a few months ago. I installed MySQL 5.1 and then copied the Program Files\MySQL and a recently backup of ProgramData\MySQL. MySQL starts but TV Server will not...

    [2017-12-04 00:46:42,716] [Log ] [4 ] [DEBUG] - Setting up EventWaitHandle with name: Global\MPTVServiceInitializedEvent
    [2017-12-04 00:46:43,005] [Log ] [4 ] [ERROR] - applyProcessPriority: exception is at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
    at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
    at Gentle.Provider.MySQL.MySQLAnalyzer.Analyze(String tableName)
    at Gentle.Framework.GentleAnalyzer.UpdateObjectMap(ObjectMap map)
    at Gentle.Framework.ObjectFactory.ConstructMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.ObjectFactory.GetMap(PersistenceBroker broker, Type type)
    at Gentle.Framework.SqlBuilder..ctor(IGentleProvider provider, StatementType stmtType, Type type, LogicalOperator logicalOperator)
    at TvDatabase.TvBusinessLayer.GetSetting(String tagName, String defaultValue)
    at TvService.Service1.applyProcessPriority()

    Anything I can do to get this working?
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    In the meantime, I worked till the early hours reinstating a semi-working system for the family. Really just missing the 96 schedules which I would dearly like to recover somehow.

    The only issue I'm experiencing is DVB-S EPG is failing. I'm fairly sure it is configured exactly as it was before with SKY EPG Background Audio selected and required checkboxes unchecked etc. I am seeing this in the log. Any ideas?

    [2017-12-04 05:15:21,037] [Log ] [DVB EPG timer] [ERROR] - Exception :confused:ystem.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 192.168.1.112:31456

    Server stack trace:
    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
    at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(EndPoint ipEndPoint)
    at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
    at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
    at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
    at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
    at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
    at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]:
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    at TvControl.IController.IsRecording(IUser& user)
    at TvService.EpgCard.IsCardIdle(Int32 cardId)
    at TvService.EpgCard.GrabEpgForChannel(Channel channel, IChannel tuning, Card card)
    at TvService.EpgCard.GrabEpg()
    at TvService.EpgGrabber.GrabEpgOnCard(EpgCard epgCard)
    at TvService.EpgGrabber._epgTimer_Elapsed(Object sender, ElapsedEventArgs e)
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I've lost everything.
    Oh man!

    This wasn't part of the instruction set:
    Uninstalled MediaPortal client and TV Server including databases.
    My intention was that you would configure TV Server to use a new database, and that the old database would still be around and available as a backup in case anything went wrong. That's why I specifically said configure and didn't mention uninstall at all.

    Really just missing the 96 schedules which I would dearly like to recover somehow.
    Sorry mate, they're unrecoverable now unless your export included them. You can open the export XML file in any text editor (notepad etc.) to check what's actually in there.
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    It looks like the export didn't work. It must have crashed silently. I had done 3 or 4 exports as backups over the years but the file was dated 2014 which was one of the first backups before I added satellite to the system. The previous few exports must have also failed. It said do I want to overwrite the existing file, but it never did.

    It appeared the only option to get MySQL 5.6 installed was to uninstall MP. I tried a standard reinstall with no MySQL installed but MP wouldn't install it. An attempt to manually install MySQL 5.6 didn't work. MediaPortal couldn't access it for some reason, although I used "MediaPortal" as the root password, etc.

    I do have a full backup of the 5.1 data folder. Is there any method to access this data if I install MySQL 5.1 and MP on a virtual machine? I suspect I will get the same errors from my 12:52AM message above.

    After waking today, the EPG data had been read, so not sure what that problem was in my 5:24AM message.
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    MM, I created a virtual machine to play with this. I thought my original issue restoring the data was due to security permissions. I created a virtual machine and installed MySQL 5.1 and MediaPortal TV Server, restored the data folder and gave "Everyone" full permissions to this folder and files. I was then able to start MySQL and TV Server, but I can't load SetupTv.exe. Perhaps related to no TV cards installed? Is there a re way to force this to load so I can export the schedules? Logs included.

    I don't understand why it doesn't work if the data is exactly the same and the my.ini is the same. Is there data stored somewhere else?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    It must have crashed silently.
    Extremely unlikely!

    It appeared the only option to get MySQL 5.6 installed was to uninstall MP.
    For the record, this is categorically false.
    You can install MySQL 5.6 manually [without touching MP, TV Server or MySQL 5.1!], then change MP and TV Server configuration parameters to switch over to a new database.

    I was then able to start MySQL and TV Server, but I can't load SetupTv.exe.
    On the contrary: the log files show that TV Server has not started successfully. A cursory examination would have shown this:
    [2017-12-04 19:09:49,015] [Log ] [TVService] [ERROR] - Controller: sorry, master/slave server setups are not supported. Since there is already another server in the db, we exit here.

    Perhaps related to no TV cards installed?
    That's got nothing to do with it.

    I don't understand why it doesn't work if the data is exactly the same and the my.ini is the same. Is there data stored somewhere else?
    The TV Server database is tied to the corresponding machine/PC because it references to the machine/PC's IP address or host name. That's why the import/export section is needed when migrating PC or database.


    The only non-technical way to load up the old database in the VM and successfully start TV Server (which in turn would enable use of TV Server Config and the import/export functionality) would be to set the IP address and hostname of the VM to match the IP address and hostname of the machine/PC from which the database was taken.
     

    rlevis

    MP Donator
  • Premium Supporter
  • August 15, 2008
    492
    25
    New Zealand New Zealand
    Country flag
    Windows Services said TV Server had started but it must have been mistaken.

    I restored the original Program Files\MySQL and ProgramData\MySQL on the actual computer where it was installed, but it didn't work. Perhaps it was folder security issues, I don't know.

    I tried the same on a VM which is set to the exact same computer name and IP address, causing a conflict that Windows reported, and TV server still won't load, so I guess that's the end of it. I'll just have to spend 30 minutes once a week for a year manually checking all channels for tv series and other programs that are always recorded.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom