No analog channels on tv server (1 Viewer)


Portal Pro
February 1, 2007
TV-Server Version: 1.0.1
MediaPortal Version: 1.0.1
MediaPortal Skin: Streamed
Windows Version: Windows 2003
CPU Type: amd dual core
HDD: 500gb
Memory: 4gb
1. TV Card: Hauppauge PVR-150
1. TV Card Type: Analog
2. TV Card: Pinacle 310i
2. TV Card Type: Dvb-t + analog

i'm using MP + TVServer since it's first version.
But honestly, it's been some time since i've last used TV on my HTPC. Recently i've noticed that after several SVN, the TV in MP is not working anymore.

I've then upgraded to 1.0.1 hoping to have tuners working again, but, when doing a previev on the tvserver config program, i still get a "NoAudioVideoDetected" (on analog channels). I tried the original WinTV application to check if the Hauppauge is working, but, as in the TVserver config, i can scan for channels, find them, but not see them.
I've tried reinstalling drivers for the tuner but i keep getting that error.

In the tvserver log file i've found this strange message:

2009-04-19 [8]: Error while checking if a com object is installed - b2f3a67c-29da-4c78-8831-091ed509a475 - System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {B2F3A67C-29DA-4C78-8831-091ED509A475} failed due to the following error: 80040154.
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
at System.Activator.CreateInstance(Type type, Boolean nonPublic)
at TvLibrary.Implementations.DVB.FilterGraphTools.IsThisComObjectInstalled(Guid clsid)

I think it can be a dll problem, but i don't know where to bang my head.
Reinstalling the computer is not an option.

Any advivce/help?


MP Donator
  • Premium Supporter
  • April 20, 2009
    Home Country
    Spain Spain
    It's stange because my card is detected and everything seems to work right, but after a while if I execute SetupTV it happens nothing and I can see the process at task administrator. If I execute it again it works, but the first one is hanged up.

    When this happens with a scheduled recording this doesn't start.... :-(

    Any help will be appreciated.



    Portal Member
    December 4, 2007
    Home Country
    Greece Greece
    Same Problem Here

    I have the same problem. I can see the channels in the TV Setup (I can actually Watch them in the preview window) but there are not appear in the list o available channels in the MediaPortal. Only the Digital Channels apears.

    Any Ideas??????

    Users who are viewing this thread

    Top Bottom