No EPG for radio channels since retune. (1 Viewer)

Digsy

Portal Pro
August 29, 2018
206
21
53
Home Country
Great Britain (UK) Great Britain (UK)
Following on from this thread:

Previously I used EPG Collector very successfully to grab a 7 day OTA EPG which included the EPG for radio channels.

For some reason, since my rescan, although I can still get a solid EPG for all my TV channels, I cannot get an EPG for any radio channels at all.
I am using EPG collector with two different grabs, one using the Sky preset and the other using the Freesat preset, loaded into MP2 using the XMLTV plugin.

I can see in EPG collector that it is grabbing the EPG for the radio channels (or at least they appear in the EPG collector channels list). But I cannot use the data in XMLTV. In fact when I tick on the "load radio channels" in the "Mappings" tab in XMLTV, none of the radio channels appear at all.

I have tried using the MP2 TV server grabber for radio instead, but at best all I get is "now/next".

Can anyone advise when I could change to get my radio EPG back?
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,873
    1,801
    Southampton
    Home Country
    United Kingdom United Kingdom
    I can see in EPG collector that it is grabbing the EPG for the radio channels (or at least they appear in the EPG collector channels list).
    I have never used satellite TV, nor EPG Collector, nor XMLTV, so my suggestions are probably worthless.

    Have you actually looked in the XML file produced by EPG Collector to see if it contains the radio channels that you are expecting?

    I have tried using the MP2 TV server grabber for radio instead, but at best all I get is "now/next".
    Did you update the transponder list before performing the scan? This post contains an updated transponder list.

    What is the name of the channel that you selected as your grabber channel?

    -- from CyberSimian in the UK
     

    Digsy

    Portal Pro
    August 29, 2018
    206
    21
    53
    Home Country
    Great Britain (UK) Great Britain (UK)
    I haven't looked at the file. Will do so later. As per my other post, yes I did update the transponder list.

    EDIT I just checked it, and there doesnt seem to be any mention of any of the radio channels in the WML file so I guess that's the issue. So it looks like there's now no EPG data included in any of the the radio streams regardless of provider, which seems odd to me. I am seeing my parents today and they have a normal Freesat box so I will see if their Satellite radio channels have a full EPG.

    I actually ticked all the channels to grab from which I now realise is wrong, or at least sub-optimal.
     
    Last edited:

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,873
    1,801
    Southampton
    Home Country
    United Kingdom United Kingdom
    I actually ticked all the channels to grab from which I now realise is wrong, or at least sub-optimal.
    There is one specific radio channel that supplies the EPG for both TV and radio. This is the only channel that you need to select for EPG grabbing.

    I am not sure of the name, but something like "Programme Info" or "Freesat Info" or similar. Look through your list of radio channels to see if you can find one that looks likely.

    -- from CyberSimian in the UK
     

    Digsy

    Portal Pro
    August 29, 2018
    206
    21
    53
    Home Country
    Great Britain (UK) Great Britain (UK)
    Thanks for that. I found "Chnlineup" in the Sky grab and "FreesatEPG" in the Freesat grab and enabled them both in EPG Collector, and also set them as the EPG grabber for radio in MP2.
    But here's the odd thing: The next time I opened the XMLTV EPG mapper (where you map actual channels to channels available in the EPG), the radio channels appeared before I did another EPG grab. Its more like the the "load radio channels" option in XMLTV suddenly started working like it should.

    So now I mapped as many radio channels as I could find EPG matches for, did another grab and now I have a full EPG for most of my radio channels, and now/next for most of the others.

    So all of this helped but I am at a loss to explain what exactly got it working in the end!

    Thanks for your assistance.
     

    Users who are viewing this thread

    Top Bottom