OnlineVideos 0.5.0 01/06/2009 | Page 10

Discussion in 'OnlineVideos' started by gregmac45, December 18, 2008.

Thread Status:
Not open for further replies.
  1. armandp
    • Team MediaPortal

    armandp Retired Team Member

    Joined:
    April 6, 2008
    Messages:
    990
    Likes Received:
    584
    Gender:
    Male
    Occupation:
    Application Designer
    Location:
    Zoetermeer
    Ratings:
    +616 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    For what it's worth... I'm currently in the process of creating a generic video browser plugin much like Online Videos. It will use scriptable datasources (using the Scriptable Scraper Engine from the Cornerstone framework used in Moving Pictures). This means the community can add / maintain video sources (using XML) without the need to compile/release new plugin versions.



    I say "generic" because i will only focus on a "search/navigate and play" framework with some default image/text labels available to the skinner.
    I won't add source specific information because i believe when you take that route it's better to do a standalone plugin.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Spragleknas
    • Team MediaPortal
    • Administrator

    Spragleknas Administrator

    Joined:
    December 21, 2005
    Messages:
    9,472
    Likes Received:
    1,385
    Gender:
    Male
    Occupation:
    Occupied
    Location:
    Located
    Ratings:
    +1,892 / 12
    Home Country:
    Norway Norway
    Show System Specs
    Sounds great!
    Keep us posted :)
     
  4. Paglioni

    Paglioni Portal Pro

    Joined:
    February 1, 2007
    Messages:
    54
    Likes Received:
    0
    Ratings:
    +0 / 0
    I've tried OnlineVideos but i can't get it to work
    besides configuring all codecs and players, i don't even get anything from the plugin.

    If i try to configure it from the configuration manager, i get a windows with some blank fields on the upper part, where only the thumb pat and apple trailers max quality with values, and the "sites" and "sites categories" parts blank with disabled fields (only the "Enabled" field in sites is working, but it does nothing).

    if i go to the plugin inside media portal, i only get a "favourite" line that does nothing.

    What i'm missing?
     
  5. SunnyFunny

    SunnyFunny Portal Member

    Joined:
    March 10, 2007
    Messages:
    45
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    hi,

    i installed onlinevideos addon today. but the only think getting work is apple. youtube show me nothink. the other site show me the preview pics, but when i select a video nothing happens :(

    i installed mplayer addon and the latest mplayer. is there a guide how to config all the addons and the player?
     
  6. Paglioni

    Paglioni Portal Pro

    Joined:
    February 1, 2007
    Messages:
    54
    Likes Received:
    0
    Ratings:
    +0 / 0
    I get this in the mp log



    2009-03-16 11.59.45.338438 [Info.][MPMain]: Load plugins from : C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\windows\OnlineVideos.dll
    2009-03-16 11.59.45.341438 [Info.][MPMain]: File Version : 1.0.0.0
    2009-03-16 11.59.45.359438 [Info.][MPMain]: Exception :confused:ystem.NullReferenceException: Object reference not set to an instance of an object.
    at OnlineVideos.OnlineVideoSettings.loadSettings()
    2009-03-16 11.59.45.359438 [Info.][MPMain]: Exception :Object reference not set to an instance of an object.
    2009-03-16 11.59.45.359438 [Info.][MPMain]: site :Void loadSettings()
    2009-03-16 11.59.45.360438 [Info.][MPMain]: source :OnlineVideos
    2009-03-16 11.59.45.360438 [Info.][MPMain]: stacktrace: at OnlineVideos.OnlineVideoSettings.loadSettings()
     
  7. thesystemera

    thesystemera Portal Pro

    Joined:
    May 26, 2008
    Messages:
    810
    Likes Received:
    22
    Occupation:
    Audio Engineer, Media Guru
    Location:
    Auckland
    Ratings:
    +22 / 0
    Home Country:
    New Zealand New Zealand
    armandp you are a legend, your stuff should so come included with MP packaged...

    Great idea on the scripting notion, sounds very simular to the technique BOXEE is using, and for that reason alone it is a great one... Thanks
     
  8. Wolfmage

    Wolfmage Portal Member

    Joined:
    July 28, 2008
    Messages:
    11
    Likes Received:
    0
    Ratings:
    +0 / 0
    Any particular reason that everything but youtube would be working? I select a youtube site category, but nothing happens. Tried checking the RSS in the config and it's the right one. Tried with and without login details. I'm using the .51 version with the latest StreamedMP.

    EDIT: that's weird it's working fully now.
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!