OnlineVideos-Netflix not working in Australia (1 Viewer)

Rustyapron

Portal Member
June 24, 2015
18
3
Melbourne
Australia Australia
Hi, i'm trying to get Onlinevideos Netflix to work but just get "error getting dynamic categories". I have been using online videos for a little while and it does work ok with other sites. I live in Australia, and running Win 10. I am able to log in to Netflix, I can select my profile and I get the top level categories, then the second level, but beyond that I get the dynamic categories error after about 3 seconds. I have Silverlight installed but the error occurred before I installed that. Any help would be much appreciated.
 

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    Hi,

    I'm at work at the moment so just a quick reply (hope the time difference won't be a problem...).

    First check that you have disabled test participation https://www.netflix.com/DoNotTest?fullpage=true

    Secondly, are you a new Netflix user? It might be that you have to use Netflix in the browser for some time before it works in OnlineVideos (it was a problem for another user some time ago). It might enough to click around, play some content and add something to My List.

    The third thing to do is to collect logs
    Remove all old logs (in your start menu you have a folder link to mediaportal user files, open that shortcut and find the logs folder and remove all old log files)
    Enable verbose logging in site setting (the same place you entered your credentials)
    Start mediaportal with the WatchDog, pick the second alternative and reproduce the error.
    Report with the logs and an exact description on what you did to get your error.
     

    Rustyapron

    Portal Member
    June 24, 2015
    18
    3
    Melbourne
    Australia Australia
    Hi again, Onlinevideos-Netflix has stopped working. I can select videos but they don't play. The spiral runs for 20 seconds then it falls back to the menu again. The 20 second time-out is very consistent. I've changed the netflix webrequest timeout to 30 seconds but that didnt make any difference. I've also changed the onlinevideos generic webrequest time-outs to 30 seconds, again no change. Is there a 20 second time-out somewhere else? Your help to get this running again would be most appreciated.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    Hi,

    I've quoted some instructions from the Netflix threads opening post:

    remove cache and cookies from internet explorer.
    Problems with timeouts? Or does the player window close before the actual video start to play - try setting a higher "Webrequest timeout" in OnlineVideos configuration and BrowserHostWaitTimeout in the OnlineVideos.WebAutomation.BrowserHost.exe.config file (found in [MP-INSTALL-PATH]l\plugins\Windows\OnlineVideos)
    You can see what's happening in the browser player while loading if you disable the loading spinner in the Netflix context menu. This can be good to report in a bug report
    Collect logs:

    Edit the OnlineVideos.WebAutomation.BrowserHost.exe.config file (found in [MP-INSTALL-PATH]l\plugins\Windows\OnlineVideos)
    Change the WriteDebugLog value to true

    You also might want to enable verbose logging in site setting.

    Use the WatchDog, pick the second alternative and reproduce the error.
     

    Rustyapron

    Portal Member
    June 24, 2015
    18
    3
    Melbourne
    Australia Australia
    Hi again, thanks for the prompts above. I did the Internet Explorer thing, and changed the BrowserHost timeout to 40 seconds from 20 seconds. On trying the first video it went to the 40 second timeout before closing and returning to the menu. Then I tried a new video that I had not tried to open before and it worked, this time it starts the video at around 15 seconds from selection. Before the changes I had tried quite a few new videos but always got the 20 second timeout so something has certainly changed, but still a bit curious. Anyhow its working again so thank you. :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A OnlineVideos MediaPortal 1 Plugins 3
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    J Debug OnlineVideos, How To? OnlineVideos 1
    Predpray OnlineVideo 2 Probleme Allgemeines Support- und Diskussionsforum 12
    HTPCSourcer MP2 OnlineVideos Overhaul MediaPortal 2 46
    HTPCSourcer OnlineVideos is not remembering my sites MediaPortal 2 25
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    E OnlineVideo Plugins - eigene Videostreams hinzufügen Plugins & Erweiterungen 0
    fischy667 Money Heist - Netflix Order My TVSeries 7
    T Amazon und Netflix in MP2 - Wie? Allgemeines Support- und Diskussionsforum 6
    M.Hulot [solved] Netflix und amazon Prime in MP1 möglich? TV / Streaming 6
    BlueMax1916 [Evaluate] Windows 10 Apps for Sky, Netflix, Amazon etc. to be accessible via MP2 Plugin Feature Requests 3
    H MP2.2 Netflix kein Player registriert OnlineVideos for MediaPortal 2 11
    T [Evaluate] Own plugins for AmazonPrime and Netflix Feature Requests 2
    C Netflix My List & Continue Watching Blank OnlineVideos 4
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 1
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    Similar threads

























    Top Bottom