OnlineVideos Standalone Application (1 Viewer)

offbyone

Development Group
  • Team MediaPortal
  • April 26, 2008
    3,981
    3,703
    Stuttgart
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #1
    I have been working on a WPF Application as Front-End for OnlineVideos. It uses the same core and all the sites are available as with MediaPortal. The original idea was to get a base for the MediaPortal2 Plugin, but has somehow evolved to get an app I can use on my touchpad running Windows7.

    Requirements are DirectX9 and .Net 4.0 Full and playback is done via DirectShow Codecs (same as in MediaPortal).

    Have fun.

    [Download updated 10/4/2015]
     

    Attachments

    Last edited:

    KitanaiYatsu

    Portal Member
    February 23, 2011
    18
    0
    United States of America United States of America
    This is way cool!

    But... Whenever I add a site to my list, the application dies.

    The database is updated as the new site appears in my list of sites. So I can't say what is going on when the app dies.
     

    KitanaiYatsu

    Portal Member
    February 23, 2011
    18
    0
    United States of America United States of America
    Dude! Can't say for sure what's going on... OnlineVideosStandalone crashes just after start up now.

    Attached is my log.txt file.
     

    offbyone

    Development Group
  • Team MediaPortal
  • April 26, 2008
    3,981
    3,703
    Stuttgart
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #6
    I need to release an update to that application, it is no longer compatible with the current siteutil dlls. Will do that when I get the time.
     

    offbyone

    Development Group
  • Team MediaPortal
  • April 26, 2008
    3,981
    3,703
    Stuttgart
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #7
    The zip attached to the first post has been updated today and should now work again!
     

    2thor

    Portal Pro
    November 1, 2009
    57
    1
    Denmark Denmark
    Hi Offbyone!

    For testing I tried installing on a xp pro laptop.
    Seems to work, but when try to play any video, an error promt is shown as on attatched pic.
    Also I am not able to uninstall the standalone program. Errors as attatched:
    Translation of the last one is something like: A serious error happened with the installer.

    Any ideas?

    Thanks/thor
     

    Attachments

    offbyone

    Development Group
  • Team MediaPortal
  • April 26, 2008
    3,981
    3,703
    Stuttgart
    Germany Germany
    Country flag
    • Thread starter
    • Moderator
    • #9
    Hi first error sounds strange:
    Do you have the EVRPresenter32.dll in the same folder where the Standalone application is installed?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom