Only background sound for some TV channels

Discussion in 'Television (MyTV frontend and TV-Server)' started by rsbrux, February 10, 2016.

  1. rsbrux
    • Team MediaPortal

    rsbrux Documentation Group

    Joined:
    April 15, 2007
    Messages:
    1,022
    Likes Received:
    67
    Ratings:
    +91 / 1
    Home Country:
    Switzerland Switzerland
    Show System Specs
    In my single-seat installation, more and more channels produce only background sound (no front channel sound). In some cases I can get around this by changing the audio selection to the channel with narration, but I now have some channels with no audio channel options at all. The attached sample is from a channel which the MP GUI shows to have both German and English audio. However, I get only background audio on the German channel, and nothing at all on the English channel. Any suggestions as to how I can get front (and center) audio on such channels would be appreciated.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,204 / 17
    Home Country:
    New Zealand New Zealand
    How many speakers does your setup have? (stereo [2], stereo + sub [2.1], surround [5.1/7.1])
    If you have "only" 2 or 2.1, have you enabled down-mixing in the LAV audio codec settings? (If not, you should.)
     
    Last edited: February 11, 2016
    • Thank You! Thank You! x 1
  4. rsbrux
    • Team MediaPortal

    rsbrux Documentation Group

    Joined:
    April 15, 2007
    Messages:
    1,022
    Likes Received:
    67
    Ratings:
    +91 / 1
    Home Country:
    Switzerland Switzerland
    Show System Specs
    I have surround 5.1 speakers, but I tried changing the LAV settings to "stereo" anyway, as I sometimes use headphones (see attached screenshots).
    The symptoms are still the same. For example, the relaunch of Akte X (from which the previously uploaded sample comes) gives me no foreground sound on two different HD channels (ORF1 and 3+). If I watch or record it on Pro7 (SD), I can get foreground sound.

    P.S. I also tried MS DTV and MPC codecs (where possible)
    With MS DTV codecs, I got no sound at all from the affected channels/programs, with MPC codecs (reconfigured to stereo 2.0) I got background sound only, as with LAV. The problem does not affect all (or even most) HD channels. Even on the affected channels, the problem is not always manifest. It appears to depend on the program material.
     

    Attached Files:

    Last edited: February 11, 2016
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,204 / 17
    Home Country:
    New Zealand New Zealand
    Okay, your LAV audio settings seem to be a bit... strange. ;)

    For bit-streaming you have ticked DD and DTS. Normally when bit-streaming is activated, the audio stream would be sent directly to the TV or AVR without any change (eg. mixing, equalisation etc.) on the PC. Therefore I think (not 100% sure) mixing would have no effect for TV channels with those audio formats. Either way, since you have 5.1 speakers, I would recommend to disable mixing (unless you are dealing with lots of 7.1 channel sources, in which case you could enable mixing for 7.1 => 5.1 conversion only).

    You have also ticked "use legacy 5.1 channel layout". Was that intentional? If not, I recommend to try unticking that setting. Along with your original mixing configuration, I think that setting could be a reason for your problem.

    Finally, I see you have enabled Dolby Pro Logic II matrix encoding on the mixing tab. My understanding is that DPL is for encoding surround sound audio into stereo outputs in such a way that the receiver/decoder can recover the surround sound. Since you have a 5.1 system I think that should be unnecessary. Therefore I recommend to set "matrix encoding" to "none".
     
    • Thank You! Thank You! x 1
  6. rsbrux
    • Team MediaPortal

    rsbrux Documentation Group

    Joined:
    April 15, 2007
    Messages:
    1,022
    Likes Received:
    67
    Ratings:
    +91 / 1
    Home Country:
    Switzerland Switzerland
    Show System Specs
    Thanks for your suggestions. I have tried them all, but to no avail. The symptoms remain unchanged.
    All of the selections were intentional, but I confess to not understanding the wealth of options in LAV filters very well so I might have screwed up ;-}
    • I selected DD and DTS bit-streaming because my AVR understands these formats, and can presumably do a better A/D conversion than the PC (or at least with a better S/N ratio).
    • I have no idea whether or not any of my sources are 7.1, nor do I know how to find out.
    • I previously had "legacy 5.1 channel" unselected, with the same results concerning background vs. foreground sound. I selected it recently, because my back speakers are really in back, not on the sides.
    • I chose the DPL matrix encoding setting in the expectation that it would give me better results with the headphones (Sennheiser RS-170), which are surround-capable, but have only a stereo input. In fact, I do get very convincing surround effects with the headphones on some programs, but I can't be sure that I have this setting to thank for that.
    Thanks again for your help!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!