Participation De La Team Fr Au Développement De Mp I I (1 Viewer)

zebons

Portal Pro
January 2, 2006
1,484
114
<div class='quotetop'>CITATION(framug @ 27 Mar 2008, 20:57 ) <{POST_SNAPBACK}></div>
Oui, c'est vrai qu'il n'y a pas d'accès en écriture, comme pour mp1, d'ailleurs :( mais, cela permet déjà de voir ce qu'ils ont fait (et c'est impressionnant, ils sont vraiment balaises).
Ceci dit, rien n'empêche de développer quelque chose par soi-même et, éventuellement, de proposer une intégration par la suite.
Je trouve tout de même que la base de conception actuelle de MP2 n'est pas du tout figée et qu'elle bouge beaucoup pour l'instant.
Pour s'en convaincre, il suffit de regarder le plugin "hello world", par exemple.
Donc, à moins d'être "une bête" en dev C# et, de pouvoir participer activement à la conception (c'est à dire, savoir quelle direction ils souhaitent prendre), cela est réservé tout de même à une certaine élite.

A+[/b]
On peut le trouver ou le plugin "hello world" ?
 

zebons

Portal Pro
January 2, 2006
1,484
114
Il faut quelle version de .net et quel outil de développement pour MP-II ?
J'ai actuellement .NET 2.0 et Visual c# 2005 Express (gartuit) et pas mal d'erreurs avec MP-II pour la compilation (j'ai pourtany suivi et installé les comosants indiqués sur la page off pour compilation de MP-II -.NET SDX et DIRECTX SDK- :
- manque Microsoft.WinFX.Targets. Semble t-il apporté par WinFX Runtime Components mais que je ne trouve pas sur le site msdn.com
- lors de la compil, pas mal d'erreurs car il ne trouve pas 'type ou espace de nom Windows dans la classe System'
 

framug

Super Moderator
  • Team MediaPortal
  • January 31, 2005
    4,504
    523
    South of France
    France France
    Country flag
    <div class='quotetop'>CITATION(zebons @ 29 Mar 2008, 10:31 ) <{POST_SNAPBACK}></div>
    Il faut quelle version de .net et quel outil de développement pour MP-II ?
    J'ai actuellement .NET 2.0 et Visual c# 2005 Express (gartuit) et pas mal d'erreurs avec MP-II pour la compilation (j'ai pourtany suivi et installé les comosants indiqués sur la page off pour compilation de MP-II -.NET SDX et DIRECTX SDK- :
    - manque Microsoft.WinFX.Targets. Semble t-il apporté par WinFX Runtime Components mais que je ne trouve pas sur le site msdn.com
    - lors de la compil, pas mal d'erreurs car il ne trouve pas 'type ou espace de nom Windows dans la classe System'[/b]
    J'ai pas mal galéré avec ça, il te faut dotnet 3.0 et Visual Studio 2005 Extensions for Windows Workflow Foundation (FR).exe.

    Par contre, ça fait quelques jours/semaines que je compile correctement MP 2 mais, que ça ne fonctionne plus à l'éxecution.
    Il me semble que j'avais réussi à le faire fonctionner en virant le projet meteo.
    Faudra que j'essaie à nouveau.

    Sinon, je ne suis pas sûr que ça fonctionne avec VS Express.
    A essayer. ;)
     

    zebons

    Portal Pro
    January 2, 2006
    1,484
    114
    <div class='quotetop'>CITATION(framug @ 29 Mar 2008, 10:40 ) <{POST_SNAPBACK}></div>
    J'ai pas mal galéré avec ça, il te faut dotnet 3.0 et Visual Studio 2005 Extensions for Windows Workflow Foundation (FR).exe.

    Par contre, ça fait quelques jours/semaines que je compile correctement MP 2 mais, que ça ne fonctionne plus à l'éxecution.
    Il me semble que j'avais réussi à le faire fonctionner en virant le projet meteo.
    Faudra que j'essaie à nouveau.

    Sinon, je ne suis pas sûr que ça fonctionne avec VS Express.
    A essayer. ;)[/b]
    dotnet 3.0 ne pose pas de pbs avec des plugins pour MP I ? Lors de mes tests précédents, j'avais lorsque je compilais des Mesfilms des références à des composants mis à pour par le 3.0 qui posaient pbs sur un pc avec uniquement le runtime de la 2.0 mais j'ai pas trop creusé....
    J'avais réussi à utilisé Visual Express avec MP II mais j'avais aussi pas mal galéré et je me souviens plus comment j'avais fait..... Et à l'époque on trouvait encore facilement les modules d'extensions pour VS 2005 (maintenant on ne trouve plus que 2008 et .net 3.0 ou 3.5...)
     

    framug

    Super Moderator
  • Team MediaPortal
  • January 31, 2005
    4,504
    523
    South of France
    France France
    Country flag
    <div class='quotetop'>CITATION(zebons @ 29 Mar 2008, 11:59 ) <{POST_SNAPBACK}></div>
    dotnet 3.0 ne pose pas de pbs avec des plugins pour MP I ? Lors de mes tests précédents, j'avais lorsque je compilais des Mesfilms des références à des composants mis à pour par le 3.0 qui posaient pbs sur un pc avec uniquement le runtime de la 2.0 mais j'ai pas trop creusé....[/b]
    non non, mesfilms compile bien avec net 3.0 ;) (ne pas prendre le 3.5).
    De toutes façons, il faut bien sûr laisser le dotnet 2.0.

    <div class='quotetop'>CITATION(zebons @ 29 Mar 2008, 11:59 ) <{POST_SNAPBACK}></div>
    J'avais réussi à utilisé Visual Express avec MP II mais j'avais aussi pas mal galéré et je me souviens plus comment j'avais fait..... Et à l'époque on trouvait encore facilement les modules d'extensions pour VS 2005 (maintenant on ne trouve plus que 2008 et .net 3.0 ou 3.5...)[/b]
    VS 2008 caca, j'ai installé et, au secours, plus rien ne marche.
    De plus, les projets ont besoin d'être convertis et après, adios la compatibilité descendante. :!@$£%%:
     

    zebons

    Portal Pro
    January 2, 2006
    1,484
    114
    <div class='quotetop'>CITATION(framug @ 29 Mar 2008, 12:51 ) <{POST_SNAPBACK}></div>
    non non, mesfilms compile bien avec net 3.0 ;) (ne pas prendre le 3.5).
    De toutes façons, il faut bien sûr laisser le dotnet 2.0.

    VS 2008 caca, j'ai installé et, au secours, plus rien ne marche.
    De plus, les projets ont besoin d'être convertis et après, adios la compatibilité descendante. :!@$£%%:[/b]
    Tu utilises quoi pour développer VS 2005 Express ou Visual Studio 2005 ?
     

    framug

    Super Moderator
  • Team MediaPortal
  • January 31, 2005
    4,504
    523
    South of France
    France France
    Country flag
    <div class='quotetop'>CITATION(zebons @ 29 Mar 2008, 13:10 ) <{POST_SNAPBACK}></div>
    Tu utilises quoi pour développer VS 2005 Express ou Visual Studio 2005 ?[/b]
    Depuis que j'ai essayé 2008 sans succès, j'ai mis la version 2005 non express (Pour une fois : "Merci Patron") ;)
    A+
     

    carreno

    Moderateur
  • Premium Supporter
  • July 31, 2005
    251
    25
    33
    France
    France France
    <div class='quotetop'>CITATION(zebons @ 29 Mar 2008, 10:31 ) <{POST_SNAPBACK}></div>
    Il faut quelle version de .net et quel outil de développement pour MP-II ?
    J'ai actuellement .NET 2.0 et Visual c# 2005 Express (gartuit) et pas mal d'erreurs avec MP-II pour la compilation (j'ai pourtany suivi et installé les comosants indiqués sur la page off pour compilation de MP-II -.NET SDX et DIRECTX SDK- :
    - manque Microsoft.WinFX.Targets. Semble t-il apporté par WinFX Runtime Components mais que je ne trouve pas sur le site msdn.com
    - lors de la compil, pas mal d'erreurs car il ne trouve pas 'type ou espace de nom Windows dans la classe System'[/b]
    Moi j'utilise .net3.5 et Visual c# 2005 Express, malgré des erreurs au lancement du projet, MPII compile bien.
    Par contre moi aussi depuis quelques jours, MPII crash au démarrage. Si vous trouvez une solution, informer nous.

    ;)
     

    framug

    Super Moderator
  • Team MediaPortal
  • January 31, 2005
    4,504
    523
    South of France
    France France
    Country flag
    carreno : c'est pas normal d'avoir des erreurs (autres que des warnings de compils).
    Essaies le 3.0

    @tous :
    Quand je vois comme ça a encore changé en début d'après-midi, je réitére mon sentiment :
    Il est bien trop tôt pour dev quoi que ce soit pour MP 2 pour l'instant.
    En tout cas, chacun fait ce qui lui plait mais, non merci for me.
    On ne va pas s'amuser à coder à nouveau toutes les 5 minutes, c'est idiot.
    A+
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom