Playback of recorded TV is very unreliable (1 Viewer)

willemx

MP Donator
  • Premium Supporter
  • November 20, 2008
    48
    8
    Netherlands Netherlands
    When trying to playback recorded TV, I often get an error message: ''unable to play'' with some (seemingly random) numerical code.
    Sometimes however, the recording plays fine and also sometimes I just get a black screen or just one static videoframe.
    Also, more often than not, when the recording plays and I want to skip a few seconds, the recording just stops instead of skipping to the next part.
    I have a multiseat setup with two dedicated MP PC's: a TV server and a media playback PC (see system specs)
     

    te3hpurp

    Retired Team Member
  • Premium Supporter
  • September 23, 2008
    904
    231
    Rovaniemi
    Finland Finland
    Country flag
    Hi.

    Allthough Im not an expert, main issue seems to be that
    file cannot be accesses properly in Tvserver8 machine

    mediaportal.log:
    [2017-06-23 21:34:29,847] [Error ] [MPMain ] [ERROR] - TSReaderPlayer: Failed to open file:rtsp://tvserver8:554/D2132F2C :0x80004005

    tsreader.log:
    Which is probably caused by:

    [2017-06-23 21:34:29,844] [1f046850] [1b38] - CRTSPClient::UpdateDuration(): RTSP DESCRIBE timed out, message = liveMedia1

    Br,
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    When trying to playback recorded TV, I often get an error message: ''unable to play'' with some (seemingly random) numerical code.
    Sometimes however, the recording plays fine and also sometimes I just get a black screen or just one static videoframe.
    Also, more often than not, when the recording plays and I want to skip a few seconds, the recording just stops instead of skipping to the next part.
    I have a multiseat setup with two dedicated MP PC's: a TV server and a media playback PC (see system specs)
    On the clients, please try the TsReader.ax (version 4.2.2.35) attached to this post - MP1.16 Remote Client Unable to Play: B43534E1 error watching Recorded TV

    To install, replace TsReader.ax in C:\Program Files (x86)\Team MediaPortal\MediaPortal with the new version, after making a backup copy of the original MP 1.16 file.

    It has longer timeouts for some of the RTSP commands, which will hopefully fix the problems.
     

    willemx

    MP Donator
  • Premium Supporter
  • November 20, 2008
    48
    8
    Netherlands Netherlands
    Thanks for looking into this!
    I have installed the new TsReader.ax (version 4.2.2.35) and will test it during the coming days and will report back here...
     

    willemx

    MP Donator
  • Premium Supporter
  • November 20, 2008
    48
    8
    Netherlands Netherlands
    After a week of testing I can say that this fix has resulted in a huge improvement. I have had very few freezes since the fix and the skipping of steps has become useable again. Thanks a lot!
    BTW: I noticed that the changelog for V1.17 has a fix for TsReader RTSP request timeouts. Is this the same fix that I have just tested?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    S Resume Playback Annoyance Newcomers Forum 3
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    I Video Playback Stuttering General Support 45
    horned_reaper [solved] Music playback hangs General Support 58
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    A 1.24.0 1.24 Kills 3D MVC playback on MadVr 1.24 Pre Release 66
    Z [solved] DVD playback is super glitchy General 2
    A Working server, no video playback on client General 5
    L MP Playback Freezes When Unpausing from Minimized Screen General Support 6
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    Glith Sound stops working after first playback 1.21 88
    G Mediaportal2 supported formats General 1
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    joecrow Refresh rate not returned to default after 3D playback 1.21 Pre Release 0
    A TV playback intermittently stops on clients Television (MyTV frontend and TV-Server) 4
    T frequent black screen no audio on playback NOT from beginning Watch / Listen Media 0
    M Music playback stops after certain files 1.19 0
    J Bluray playback: How to revert back to Select Play Mode after stopping playback? Watch / Listen Media 2
    joecrow BD Playback with External Player (Unnecessary Menu) 1.19 5
    osre Audio issues with MKV Playback in MP2.1.3 General 5
    joecrow MP 1.19 BD Playback with External Player (Unnecessary Menu) General Support 0
    Similar threads

























    Top Bottom