Playback problem with .m4v files

Discussion in 'Codecs, External Players' started by porky996t, January 26, 2012.

  1. porky996t
    • Premium Supporter

    porky996t MP Donator

    Joined:
    May 21, 2008
    Messages:
    1,013
    Likes Received:
    75
    Gender:
    Male
    Occupation:
    Chartered Surveyor
    Location:
    Bolton, Lancashire, England
    Ratings:
    +82 / 0
    Home Country:
    England England
    Show System Specs
    Hi Guys,

    I have recently been converting my films and TV series to a .m4v format using Handbrake. This is to enable them to be played on the GF's iTouch.

    I have now come up against a codec problem, in that the converted files will not play in MP (although they do play well in VLC). Whenever I try to play them I get a dialog box popping up saying "unable to play... video codec: AVC "

    I currently use SAF 6 unlocked and also the MS-DVD codec that comes with Win7. I have rarely had codec problems, so would be grateful if someone could offer a solution to this one.


    Many thanks in advance.





    M.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. matpe

    matpe Portal Pro

    Joined:
    June 14, 2007
    Messages:
    73
    Likes Received:
    16
    Ratings:
    +16 / 0
    Home Country:
    Sweden Sweden
    Show System Specs
    I think i only have one m4v file, and it works in MP after i have added the extension.
    In MP and MPC-HC, LAV Filters are being used (Splitter, Audio, Video)
    In GraphStudio, Lav Splitter and Microsoft DTV-DVD Video/Audio Decoder are being used.
    Tested with ATI 5770 and only LAV Filters installed.
     
  4. porky996t
    • Premium Supporter

    porky996t MP Donator

    Joined:
    May 21, 2008
    Messages:
    1,013
    Likes Received:
    75
    Gender:
    Male
    Occupation:
    Chartered Surveyor
    Location:
    Bolton, Lancashire, England
    Ratings:
    +82 / 0
    Home Country:
    England England
    Show System Specs
    Hi Matpe,


    Thanks for the reply.

    After thinking about this, I have now found out the cause. The first thing I did was add the .m4v extension to the video extensions list in MP and I had no problems playing these file types at all.

    I realised that I had added VLC player so I could easily check the playback of these converted files. This must have added something to the codec list that was preventing MP's codecs playing back the file. I un-installed VLC, and just to be sure, re-installed SAF6 and all was OK again.

    Now I am happy with my settings for video file conversion, I don't need to check the video files in an external player - so have no need for VLC now. I suspect the problem will not occur again.



    M.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!