Playing with hyperlinkParameter and List Control indexes (1 Viewer)

Rob Hexenmeister

MP Donator
  • Premium Supporter
  • May 12, 2011
    169
    38
    Slaithwaite
    United Kingdom United Kingdom
    Country flag
    Evening all!

    Here's a challenge.

    I would like a button on Basic Home, or wherever, to take me to a specific item in a listcontrol on another page.

    I was wondering if this is even possible and whether hyperlinkParameter could be used. On jumping to the hyperlink, the newly loaded screen I think would have to:

    1. Set the listcontrol to ascending date order
    2. Set #selectedindex to the parameter passed by hyperlinkParameter

    eg: BasicHome(35)

    <control>
    <description>Jump to list button #3</description>
    <type>button</type>
    <id>103</id>
    <posX>300</posX>
    <posY>200</posY>
    <width>190</width>
    <height>32</height>
    <textureFocus>buttonfocus.png</textureFocus>
    <textureNoFocus>buttonnofocus.png</textureNoFocus>
    <label>#latestMediaHandler.tvrecordings.scheduled3.title</label>
    <hyperlinkParameter>3</hyperlinkParameter>
    <hyperlink>601</hyperlink>
    </control>


    >>>>TVSchedulerServer(601)
    How to ....

    Set the listcontrol to ascending date order
    Set the #selectedindex to the hyperlink parameter (in the example '3')
    Set the focus to the listcontrol


    This would open up all sorts of possibilities for my skin theme if it can be done

    Kind regards to all
    RH
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,310
    1,403
    Southampton
    United Kingdom United Kingdom
    Country flag
    Set #selectedindex to the parameter passed by hyperlinkParameter
    The skin engine sets #selectedindex to the item in the list that has the focus (usually the first one), and the user can move the focus by using the UP and DOWN keys on the remote control or keyboard.

    If I have understood you correctly, you want to do the reverse -- you want to set #selectedindex to a specific value, and have the skin engine use that to set the focus. I don't think that that is possible :(, but I am happy to be corrected.

    -- from CyberSimian in the UK
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    169
    38
    Slaithwaite
    United Kingdom United Kingdom
    Country flag
    The skin engine sets #selectedindex to the item in the list that has the focus (usually the first one), and the user can move the focus by using the UP and DOWN keys on the remote control or keyboard.

    If I have understood you correctly, you want to do the reverse -- you want to set #selectedindex to a specific value, and have the skin engine use that to set the focus. I don't think that that is possible :(, but I am happy to be corrected.

    -- from CyberSimian in the UK
    Yes that's more or less correct. I would like to set the #selectedindex to a value passed by hyperlinkParameter and set the focus.

    Of course we would know the control ID of what we want to focus, that should be the easy part by setting the default control on the screen we are jumping to but it is jumping to the correct item in the listcontrol that is the challenge.

    I wonder if anyone will think of a solution or way round! It would create all sorts of possibilities if it could be done.

    :cool: :cautious: :unsure:
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    H Cannot play music after full MP reinstall from scratch General Support 3
    bta489 Sometimes no image rendered when playing video watch/edit Videos 49
    R 1.27.0 Random "Unable to play" errors after server hardware upgrade. Television (MyTV frontend and TV-Server) 8
    M MP Sometimes Unresponsive When Playing Playlist General Support 0
    squizeer Sound only when playing 4k UHD (HEVC 265) Codecs, External Players 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 26
    P 1.26.0 Can't play blu-ray disc Bugreports 1
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 11
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 30
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 9

    Similar threads

    Top Bottom