Pre 1.16: Problem with BD-J and external codec video (1 Viewer)

Icaro

Portal Pro
November 29, 2013
68
18
47
Italy Italy
Country flag
Today I finally managed to do some tests with 1.1Pre and BD-J and madVR
(MadVR renderer will try it best after arranging the video codec)

So far I have always uses Arcosft TotalMedia Theatre as an external player in MP,
first because I still consider the best video codec for image quality:
Definition, color accuracy, and in general a natural made without digital artificiality.

Second, for the lack of the full menu support

Of course MediaPortal worksperfectly with TMT Video codec,
only that so far it lacked the BD-J support in MP.

Today, after several tests I found that BD-J works perfectly with disc menus that I have tried so far, with LAV filter no problem.

Instead the problem is when I use the video codecs TMT:
if I run the film from the main title is no problem,
but if I run the disc from the menu, the movie starts but then can not view or manage the menu screens:
with some disc, appear unmarked keys or directions,
with other disc black screen.

I tried to register other .ax from TMT folder, but without success.
It can be a problem of DirectX or Java?

attached log

Thank you :)
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    Hello again

    but if I run the disc from the menu, the movie starts but then can not view or manage the menu screens:
    with some disc, appear unmarked keys or directions,
    with other disc black screen.
    The attached patch should solve this problem. :)
    1. Close MP and MP Config.
    2. Open Windows File Explorer.
    3. Navigate to your MP install folder (c:\Program Files (x86)\Team MediaPortal\MediaPortal).
    4. Make a backup copy of Core.dll.
    5. Extract the attached Core.dll to replace the standard/current one.
     

    Attachments

    Icaro

    Portal Pro
    November 29, 2013
    68
    18
    47
    Italy Italy
    Country flag
    Wow, Thank you very much, Works !!!! :)

    Now MP runs with TMT codecs and full support to the full menu.
    Now, however, trying madVR, I discovered that in combination with TMT codec does not work, or rather, I press start and appears a pink screen, with audio that runs in the background, however, the start bar I see two windows, one pink and one where you see the video.
    to help you understand I had prepared a video, but it is too large to load ..

     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    in post-processing I did not put anything.
    Hmmm, your previous log files show that you did:
    [collapse]<section name="bdplayer">
    ...
    <entry name="filter0">ArcSoft Audio Decoder</entry>
    <entry name="usefilter0">yes</entry>
    <entry name="filter1">ArcSoft Audio Decoder HD</entry>
    <entry name="usefilter1">yes</entry>
    <entry name="filter2">ArcSoft Audio Encoder</entry>
    <entry name="usefilter2">yes</entry>
    <entry name="filter3">ArcSoft Video Decoder</entry>
    <entry name="usefilter3">yes</entry>
    <entry name="filter4">undefined</entry>
    <entry name="usefilter4">yes</entry>
    <entry name="filter5">ArcSoft Audio Decoder HD</entry>
    <entry name="usefilter5">yes</entry>
    <entry name="filter6">ArcSoft Audio Encoder</entry>
    <entry name="usefilter6">yes</entry>
    <entry name="filter7">ArcSoft BDAV Navigator</entry>
    <entry name="usefilter7">yes</entry>
    <entry name="filter8">ArcSoft BDMV Navigator</entry>
    <entry name="usefilter8">yes</entry>
    <entry name="filter9">Arcsoft Closed Caption Decoder for BD/DVD</entry>
    <entry name="usefilter9">yes</entry>
    <entry name="filter10">ArcSoft DVD-VR Navigator</entry>
    <entry name="usefilter10">yes</entry>
    <entry name="filter11">ArcSoft DVD Navigator</entry>
    <entry name="usefilter11">yes</entry>
    <entry name="filter12">ArcSoft FLV Splitter</entry>
    <entry name="usefilter12">yes</entry>
    <entry name="filter13">Arcsoft HDDVD Sub-picture Decoder</entry>
    <entry name="usefilter13">yes</entry>
    <entry name="filter14">ArcSoft Lossless Splitter</entry>
    <entry name="usefilter14">yes</entry>
    <entry name="filter15">ArcSoft MPEG Demux</entry>
    <entry name="usefilter15">yes</entry>
    <entry name="filter16">ArcSoft URL Source Filter</entry>
    <entry name="usefilter16">yes</entry>
    <entry name="filter17">ArcSoft Video Decoder</entry>
    <entry name="usefilter17">yes</entry>
    <entry name="filter18">ASCDReader Filter</entry>
    <entry name="usefilter18">yes</entry>
    [/collapse]
     

    Icaro

    Portal Pro
    November 29, 2013
    68
    18
    47
    Italy Italy
    Country flag
    it is likely, but then I saw that nothing changed and I took everything.
    This is the last log, no codec in post-processing
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    This is the last log, no codec in post-processing
    Okay. :)

    Log shows these filters are in the graph::
    [2017-02-01 11:20:49,443] [Log ] [MPMain ] [DEBUG] - Check graph connections for: Video Renderer
    [2017-02-01 11:20:49,443] [Log ] [MPMain ] [DEBUG] - Check graph connections for: madVR
    [2017-02-01 11:20:49,443] [Log ] [MPMain ] [DEBUG] - Check graph connections for: Default DirectSound Device
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: Color Space Converter
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: ArcSoft Audio Decoder
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: Line 21 Decoder
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: LAV Audio Decoder
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: ArcSoft Video Decoder
    [2017-02-01 11:20:49,444] [Log ] [MPMain ] [DEBUG] - Check graph connections for: MediaPortal BD Reader

    Two video renderers will give two windows. That's why you see the purple and video windows.

    Can you use GraphStudio to get a picture of the graph?
     

    Icaro

    Portal Pro
    November 29, 2013
    68
    18
    47
    Italy Italy
    Country flag
    Could you explain the steps for using GraphStudio ?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    fischy667 Problems with MP 1.23 Pre My TVSeries 12
    rbo Mp 1.21 pre - probleme livetv und videos Allgemeines Supportforum 5
    ajs [Action Required] MP 1.27 Pre Release thread MediaPortal 1 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    T TOP BAR disappears in MP 1.24 pre!! (also in 1.23) General Support 31
    ajs [Action Required] MP 1.26 Pre Release thread MediaPortal 1 343
    ajs [Action Required] MP 1.25 Pre Release thread MediaPortal 1 515
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    cbr954rr How to disable a pre-configured plugin? General 2
    azzuro [Action Required] MP 1.24 Pre Release thread MediaPortal 1 207
    ajs [News] MediaPortal 1.23 Pre-Release ready for testing! News and Announcements 6
    ajs [Action Required] 1.23 Pre-Release thread MediaPortal 1 276
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    D Mediaportal 1.22 Pre-Release didnt start up 1.22 Pre Release 8
    O [News] MediaPortal 1.22 Pre-Release ready for testing! News and Announcements 2
    ajs [Action Required] 1.22 Pre-Release thread MediaPortal 1 210
    A 1.20 issues still exists in 1.21 pre-release Watch / Listen Media 13
    O [News] MediaPortal 1.21 Pre-Release ready for testing! News and Announcements 6
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    T MP2.2 Pre Release fails installation with not starting the MP2-service 2.2 Archive 4
    ge2301 [News] MediaPortal 2 - 2.2 Pre-Release News and Announcements 0
    ge2301 MP2.2 Pre-Release Discussions General 28
    Similar threads

























    Top Bottom