Problem mit Netzwerklaufwerken

Discussion in 'Software' started by Krejci, December 24, 2014.

  1. Krejci

    Krejci Portal Pro

    Joined:
    December 16, 2011
    Messages:
    104
    Likes Received:
    3
    Ratings:
    +4 / 0
    Hi Leute,

    habe vor ein paar Tagen eine neue Fritzbox in mein Netzwerk integriert. Seitdem habe ich, wenn ich den HTPC und MP starte, das Problem, das alle eingehängten Netzlaufwerke (vom QNAP NAS) mit einem roten x versehen sind.

    Wenn ich dann im MP eine Datei starten will, bekomme ich eine Fehlermeldung, das ich das Medium verbinden soll. Dann schließe ich MP, öffne den Explorer und klicke einmal alle eingehängten Laufwerke an. Dann springen alle auf "grün".

    Danach läuft im MP alles reibungslos. Gibt es ne Möglichkeit das beim Starten des HTPC´s automatisch machen zu lassen?
    Liegt das an den Fritzbox Einstellungen?

    Jemand ne Idee?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. larry_S
    • Premium Supporter

    larry_S MP Donator

    Joined:
    December 11, 2008
    Messages:
    1,420
    Likes Received:
    93
    Ratings:
    +149 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Generell sollte man im MP eher direkte UNC Pfade anstelle von Netzlaufwerken verwenden.
    Bei einer neuen Fritzbox hat Windows ggf. das Netzwerk nicht als Heimnetz, sondern als öffentlichen Netzwerk identifiziert.
     
  4. Krejci

    Krejci Portal Pro

    Joined:
    December 16, 2011
    Messages:
    104
    Likes Received:
    3
    Ratings:
    +4 / 0
    Hmm, habe im Windows den HTPC in die "Heimnetzgruppe" integriert. Gibt es da noch irgendwelche Einstellungsmöglichkeiten?

    WIe kann ich denn einen UNC Pfad erstellen, bzw. was ist das?
     
  5. Lehmden
    • Premium Supporter

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,893
    Likes Received:
    2,151
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,626 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    Ist nicht wirklich ein "Problem" des Heimnetzwerks (oder nicht Heimnetzwerk) und auch nicht der Fritz.Box. Ich hab zwar auch eine, aber das Problem schon vorher gehabt und auch schon vorher beseitigt. Das Problem ist, das Windows beim Start nicht lange genug auf das Wiederverbinden der Netzlaufwerke wartet. Dieses Problem existiert schon so lange, wie es diese Netzlaufwerke gibt.

    Beheben lässt sich das ganz einfach, in dem man die Laufwerke erst beim ersten Zugriff darauf automatisch verbinden lässt. Neben dem Effekt, das solche Meckereien der Vergangenheit angehören, startet Windows obendrein sogar noch ein wenig schneller.
    Dazu muss nur ein Schlüssel in der Registry angelegt werden, und zwar in:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider]
    Dort muss ein neuer Schlüssel vom Typ "DWord" mit dem Namen "RestoreConnection" angelegt und als Wert "0" eingetragen werden.

    Oder man nutzt einfach die angehängte .reg Datei ;)

    Seitdem ich das auf jedem Rechner nach der Installation einmal gemacht habe, habe ich nie wieder irgendwelche Probleme mit den Netzlaufwerken gehabt.

    Edit:
    Nachdem man den Schlüssel angelegt hat, muss man den Rechner neu starten, damit die neue Einstellung greift.
     

    Attached Files:

  6. mister.xyz

    mister.xyz Portal User

    Joined:
    February 21, 2008
    Messages:
    64
    Likes Received:
    1
    Gender:
    Male
    Ratings:
    +10 / 0
    Home Country:
    Austria Austria
    Show System Specs
    Bei meinem Test-System unter windows 7 hatte ich das Problem auch.
    Ich habe es so gelöst, das ich bei jedem Start mit einem Autoit script die Netzlaufwerke verbinde und dann mediaportal starte.
    Alternativ kannst du auch mittels script den explorer und den Laufwerksbuchstaben aufrufen z.b explorer x:
     
  7. larry_S
    • Premium Supporter

    larry_S MP Donator

    Joined:
    December 11, 2008
    Messages:
    1,420
    Likes Received:
    93
    Ratings:
    +149 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Die Heimnetzgruppe ist etwas anderes und hat damit nichts zu tun.
    Es geht um die Art des Netzwerks im "Netzwerk- und Freigabecenter". Bei "öffentliches Netzwerk" sind einige Funktionen deaktiviert.

    siehe: http://de.wikipedia.org/wiki/Uniform_Naming_Convention
     
  8. Krejci

    Krejci Portal Pro

    Joined:
    December 16, 2011
    Messages:
    104
    Likes Received:
    3
    Ratings:
    +4 / 0
  9. larry_S
    • Premium Supporter

    larry_S MP Donator

    Joined:
    December 11, 2008
    Messages:
    1,420
    Likes Received:
    93
    Ratings:
    +149 / 1
    Home Country:
    Germany Germany
    Show System Specs
    UNC Pfad geht nicht?
     
  10. Krejci

    Krejci Portal Pro

    Joined:
    December 16, 2011
    Messages:
    104
    Likes Received:
    3
    Ratings:
    +4 / 0
    So, habe mir selbst eine Batch Datei geschrieben und sie in den Autustart gelegt. Nun klappt das Verbinden.

    Danke für eure Hilfe!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!