Problems with Audio / Subtitle selection for BD discs (1 Viewer)

yhoogi

MP Donator
  • Premium Supporter
  • March 9, 2008
    596
    47
    Germany Germany
    Country flag
    Hello,

    seems like there is a problem withaudio/subtitle selection using the BD(-J?) menu
    The settings as per MP config(audio/sub set to German; no subs enabled ) are retained in the menu
    (still set to German/No subs).


    But at playing-start audio is forced to english; sometimes with & sometimes w/o subs enabled
    Selection from BD Menu for audio & subs are ignored

    Only way to reliably correct it is via F9 and manual selection.


    Logs attached

    Cheers,


    Update:
    Seems like audio selection is set to first audio track - whatever it is (normally an english track)
    I tested a BD where the first track was German and BD started in German. Changing the track via BD menu to english didn't worked (logb)
    Crashed at the end while stopping the movie
     

    Attachments

    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi yhoogi

    It's difficult to confirm and investigate your claims because you haven't used the Watchdog tool. That means we don't have your MediaPortal config (MediaPortal.xml) to check your BD audio and subtitle language settings, and we don't have the Windows application event log to check the cause of the crash.

    Please always try to use the Watchdog tool to collect log files in future.

    Regards,
    mm
     

    DaBaSe

    MP Donator
  • Premium Supporter
  • November 4, 2009
    101
    7
    Germany Germany
    Country flag
    Hello everyone,

    I have the same issue as yhoogi, but one point more. So i decided to post in this thread.
    In MP 1.15 Final the Blue ray part worked like a charm for me. After the update to MP1.16pre i have following issues:

    1. The same problem as yhoogi, but without the subtitle problem. I have to change the Audiostream manualy after start the blue ray.

    2. When i start a Blue ray, somtimes it work fine at the beginning, but when the blue ray reader change the file to the next file on the disc, i have framedrops. Sometimes only 5 but sometimes without ending. So i have to pause, restart and make a skip forward to stopt the framedrop.
    Sometimes the Blueray starts with framedrop every 3 seconds.

    I have attached the logs from watchdogs. In this case i have had a Image that was mount by Daemon tools light.
    The framesdrops begin at the same time as the file "switched" (12:41:35 i think). Then i stoped the blue ray.

    Perhaps you find somthing in the logs.

    Thanks for the work you and all Devs do. I enjoy your work every Day(y). Keep on your good work.

    greetings Lars
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi DaBaSe

    Thanks for the log files (y)

    It looks like MP is selecting the correct audio stream in this case:
    [collapse]
    04-01-2017 12:37:00.487 [ 1674]Playlist Manager new Playlist 401 clip 0 start 11.651 clipOffset 11.651 Audio 1 duration 79.371
    04-01-2017 12:37:00.487 [ 1674] Video [4113] H264
    04-01-2017 12:37:00.487 [ 1674] Audio #0:[4352] eng DTS-HD Master 5
    04-01-2017 12:37:00.487 [ 1674] Audio #1:[4356] deu DTS-HD Master 5
    04-01-2017 12:37:00.487 [ 1674] Audio #2:[4357] eng AC3 2
    04-01-2017 12:37:00.488 [ 1674] Audio #3:[4358] eng AC3 2
    04-01-2017 12:37:00.488 [ 1674]demux: ParseAudioStreams - Audio track #1 selected
    ...
    04-01-2017 12:38:22.115 [ 1490] Video [4113] H264
    04-01-2017 12:38:22.116 [ 1490] Audio #0:[4352] eng DTS-HD Master 5
    04-01-2017 12:38:22.116 [ 1490] Audio #1:[4356] deu DTS-HD Master 5
    04-01-2017 12:38:22.116 [ 1490] Audio #2:[4357] eng AC3 2
    04-01-2017 12:38:22.116 [ 1490] Audio #3:[4358] eng AC3 2
    04-01-2017 12:38:22.116 [ 1490]demux: ParseAudioStreams - Audio track #1 selected
    ...
    04-01-2017 12:38:48.831 [ 1198] Video [4113] H264
    04-01-2017 12:38:48.832 [ 1198] Audio #0:[4352] eng DTS-HD Master 5
    04-01-2017 12:38:48.832 [ 1198] Audio #1:[4356] deu DTS-HD Master 5
    04-01-2017 12:38:48.832 [ 1198] Audio #2:[4357] eng AC3 2
    04-01-2017 12:38:48.832 [ 1198] Audio #3:[4358] eng AC3 2
    04-01-2017 12:38:48.832 [ 1198]demux: ParseAudioStreams - Audio track #1 selected
    ...
    04-01-2017 12:42:35.647 [ 1198] Video [4113] H264
    04-01-2017 12:42:35.647 [ 1198] Audio #0:[4352] eng DTS-HD Master 5
    04-01-2017 12:42:35.648 [ 1198] Audio #1:[4356] deu DTS-HD Master 5
    04-01-2017 12:42:35.648 [ 1198] Audio #2:[4357] eng AC3 2
    04-01-2017 12:42:35.648 [ 1198] Audio #3:[4358] eng AC3 2
    04-01-2017 12:42:35.648 [ 1198]demux: ParseAudioStreams - Audio track #1 selected
    [/collapse]

    Can you confirm?

    About the frame drops...
    The framesdrops begin at the same time as the file "switched" (12:41:35 i think).
    Nothing is happening at 12:41:35. :confused:
    Do you mean 12:42:35?

    Regards,
    mm
     

    yhoogi

    MP Donator
  • Premium Supporter
  • March 9, 2008
    596
    47
    Germany Germany
    Country flag
    I made now a new attempt with watchdog (attached)

    Steps Done:
    1) select movie & Start
    2) Select region during start-up (German)
    3) 2 commericals sequentially (each skipped to the end after start)
    4) selected in Main Menu
    a) Language: German
    b) Subtitels: None​
    5) Started Playback
    a) Language: English
    b) subtitles: None​
    6) Interrupt playback with call of main Menu
    a) select Language: german​
    7) select play (Movie continues)
    a) Language German
    b) subtitles: none​
    8) Interrupt playback with call of main Menu
    a) select subtitle: German​
    9) select play (Movie continues)
    a) Language French
    b) subtitles: .. some skandinavian​
    10) Stopped MP

    Cheers,


    Note: Strange to see several audio-selections but no subtitle selection in the BD-Log
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Startup settings:
    05-01-2017 01:18:21.880 [ 9a8]CLibBlurayWrapper - Settings: Audio(deu), Menu(deu), Sub(deu), Ctry(de), Reg(2), Prtl(99)

    5) Started Playback
    a) Language: English
    Please keep in mind that it looks like all audio except the main movie is English only. I wonder if this is causing the German selection to be lost and English to be selected even for the main movie.

    b) subtitles: none
    I'm not so sure about this. From the start it looks like German subtitles are selected where available:
    [collapse]start:
    05-01-2017 01:18:27.369 [ 9a8] BD_EVENT_PG_TEXTST - 0 [sub-titles enabled]
    05-01-2017 01:18:27.369 [ 9a8] BD_EVENT_PG_TEXTST_STREAM - 4095
    ...
    05-01-2017 01:19:06.158 [ 25ec] Subtitle [4608] fra PGS
    05-01-2017 01:19:06.159 [ 25ec] Subtitle [4609] deu PGS
    05-01-2017 01:19:06.159 [ 25ec] Subtitle [4610] spa PGS
    05-01-2017 01:19:06.159 [ 25ec] BD_EVENT_PG_TEXTST - 1 [sub-titles enabled]
    05-01-2017 01:19:06.159 [ 25ec] BD_EVENT_PG_TEXTST_STREAM - 2 [deu selected - correct!]
    ...
    05-01-2017 01:19:11.190 [ 4c48] Subtitle [4616] eng PGS
    05-01-2017 01:19:11.190 [ 4c48] Subtitle [4608] fra PGS
    05-01-2017 01:19:11.190 [ 4c48] Subtitle [4609] deu PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4610] ita PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4611] spa PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4612] nld PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4613] por PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4614] tur PGS
    05-01-2017 01:19:11.191 [ 4c48] Subtitle [4615] ara PGS
    05-01-2017 01:19:11.191 [ 4c48] BD_EVENT_CHAPTER - 1
    05-01-2017 01:19:11.191 [ 4c48] BD_EVENT_PG_TEXTST - 1 [sub-titles enabled]
    05-01-2017 01:19:11.192 [ 4c48] BD_EVENT_PG_TEXTST_STREAM - 3 [again, deu selected - correct!]
    ...
    05-01-2017 01:19:11.763 [ 25ec] BD_EVENT_PG_TEXTST - 1
    05-01-2017 01:19:11.763 [ 25ec] BD_EVENT_PG_TEXTST_STREAM - 1
    05-01-2017 01:19:11.815 [ 25ec] BD_EVENT_PG_TEXTST - 1
    05-01-2017 01:19:11.816 [ 25ec] BD_EVENT_PG_TEXTST_STREAM - 2
    ...
    05-01-2017 01:19:45.668 [ 25ec] Subtitle [4608] eng PGS
    05-01-2017 01:19:45.668 [ 25ec] Subtitle [4609] fra PGS
    05-01-2017 01:19:45.668 [ 25ec] Subtitle [4610] deu PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4611] ita PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4627] spa PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4612] nld PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4613] dan PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4614] fin PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4615] nor PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4616] swe PGS
    05-01-2017 01:19:45.669 [ 25ec] Subtitle [4617] por PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4618] tur PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4619] hin PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4620] ara PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4621] isl PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4622] fra PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4623] deu PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4624] ita PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4625] spa PGS
    05-01-2017 01:19:45.670 [ 25ec] Subtitle [4626] tur PGS
    ...
    05-01-2017 01:19:45.672 [ 25ec] BD_EVENT_PG_TEXTST - 1 [sub-titles enabled]
    05-01-2017 01:19:45.672 [ 25ec] BD_EVENT_PG_TEXTST_STREAM - 17 [second deu selected; I'm not sure what the difference is between the first (3) and second (17) deu options][/collapse]

    As I said in the spoiler comment above: I'm not sure what the difference is between the 2 German sub-title tracks. BDReader probably selects the last option that matches the selected language, and that leads to selection of #17 over #3.

    9) select play (Movie continues)
    a) Language French
    b) subtitles: .. some skandinavian
    This part is weird. Log file shows:
    [collapse]
    05-01-2017 01:21:43.067 [ 4c48]CClip:: Clip Reset (800,0) stream Offset 1858453334
    05-01-2017 01:21:43.067 [ 4c48] Video [4113] H264
    05-01-2017 01:21:43.067 [ 4c48] Audio #0:[4352] eng DTS-HD Master 5
    05-01-2017 01:21:43.067 [ 4c48] Audio #1:[4353] eng DTS 2
    05-01-2017 01:21:43.067 [ 4c48] Audio #2:[4354] fra DTS-HD 5
    05-01-2017 01:21:43.067 [ 4c48] Audio #3:[4355] deu DTS-HD 5
    05-01-2017 01:21:43.068 [ 4c48] Audio #4:[4356] ita DTS 5
    05-01-2017 01:21:43.068 [ 4c48] Audio #5:[4357] spa DTS 5
    05-01-2017 01:21:43.068 [ 4c48] Audio #6:[4358] tur DTS 5
    05-01-2017 01:21:43.068 [ 4c48]demux: ParseAudioStreams - Audio track #0 selected
    05-01-2017 01:21:43.068 [ 4c48] Subtitle [4608] eng PGS
    05-01-2017 01:21:43.068 [ 4c48] Subtitle [4609] fra PGS
    05-01-2017 01:21:43.068 [ 4c48] Subtitle [4610] deu PGS
    05-01-2017 01:21:43.068 [ 4c48] Subtitle [4611] ita PGS
    05-01-2017 01:21:43.068 [ 4c48] Subtitle [4627] spa PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4612] nld PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4613] dan PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4614] fin PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4615] nor PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4616] swe PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4617] por PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4618] tur PGS
    05-01-2017 01:21:43.069 [ 4c48] Subtitle [4619] hin PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4620] ara PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4621] isl PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4622] fra PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4623] deu PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4624] ita PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4625] spa PGS
    05-01-2017 01:21:43.070 [ 4c48] Subtitle [4626] tur PGS
    ...
    05-01-2017 01:21:43.073 [ 4c48] BD_EVENT_AUDIO_STREAM - 4
    05-01-2017 01:21:43.073 [ 4c48] Audio #0:[4352] eng DTS-HD Master 5
    05-01-2017 01:21:43.073 [ 4c48] Audio #1:[4353] eng DTS 2
    05-01-2017 01:21:43.073 [ 4c48] Audio #2:[4354] fra DTS-HD 5
    05-01-2017 01:21:43.074 [ 4c48] Audio #3:[4355] deu DTS-HD 5
    05-01-2017 01:21:43.074 [ 4c48] Audio #4:[4356] ita DTS 5
    05-01-2017 01:21:43.074 [ 4c48] Audio #5:[4357] spa DTS 5
    05-01-2017 01:21:43.074 [ 4c48] Audio #6:[4358] tur DTS 5
    05-01-2017 01:21:43.074 [ 4c48]demux: ParseAudioStreams - Audio track #3 selected
    05-01-2017 01:21:43.074 [ 4c48] BD_EVENT_PG_TEXTST - 1
    05-01-2017 01:21:43.074 [ 4c48] BD_EVENT_PG_TEXTST_STREAM - 3
    05-01-2017 01:21:43.075 [ 4c48]demux: ParseAudioFormat - failed to parse audio format!
    05-01-2017 01:21:43.075 [ 4c48]demux: ParseAudioFormat - succeeded
    ...
    05-01-2017 01:21:43.096 [ 9a8]CBDReaderFilter::Run(32314.93) state 1
    05-01-2017 01:21:43.096 [ 9a8]CBDReaderFilter::Run(32314.93) state 2 -->done
    05-01-2017 01:21:43.575 [ 25ec] BD_EVENT_PG_TEXTST - 1
    05-01-2017 01:21:43.575 [ 25ec] BD_EVENT_PG_TEXTST_STREAM - 10
    05-01-2017 01:21:43.608 [ 9a8]demux: no change in audio type (DTS-HD)
    05-01-2017 01:21:43.636 [ 4c48]demux: ParseAudioFormat - succeeded
    [/collapse]

    For the audio part...
    Note the "failed to parse audio format" message. I wonder if BDReader fails to select the audio stream that you ask for.

    For the sub-titles part...
    It looks like the first German sub-titles (#3) are successfully selected ("BD_EVENT_PG_TEXTST_STREAM - 3") at the start, but then later ("BD_EVENT_PG_TEXTST_STREAM - 10") when playback starts again it seems that Swedish (#10) sub-titles are activated. I don't understand how/why that happens. :confused:

    In the menu, are there 2 choices for German sub-titles?
    Are you sure that there were really no sub-titles when the second German sub-titles stream (#17) was automatically selected?
     

    yhoogi

    MP Donator
  • Premium Supporter
  • March 9, 2008
    596
    47
    Germany Germany
    Country flag
    In the menu, are there 2 choices for German sub-titles?
    Are you sure that there were really no sub-titles when the second German sub-titles stream (#17) was automatically selected?
    Ia am sure, in the BD Menu - selection marker was on "No Subs"
    There was also only one entry for german subs in BD Menu

    Wrt appearance of subs:
    As far is I looked into the movie (first minutes) nothing appeared.

    A potential reason for the additional ger subs could reside in the LAV Splitter settings I have

    in LAV Splitter settings:
    • preferences language (jap,ger,eng) & subs (ger,eng)
    • With Subtitle Selection Mode "No subtitles"
    • In addition "Enable Automatic Forced Subtite Stream" was enabled => which creates for ger & eng additional streams with subs marked as forced only

    I deleted the LAV Splitter settings, restarted computer and
    reproduced above steps with no change in behaviour, though

    Side-Note:
    The BD Menu showed the correct settings

    Log attached

    Cheers
     
    Last edited:

    yhoogi

    MP Donator
  • Premium Supporter
  • March 9, 2008
    596
    47
    Germany Germany
    Country flag
    I made now a repeat of the logb movie


    made now a new attempt with watchdog (attached)

    Steps Done:
    1) select movie & Start
    2) N/A
    3) 2 commericals sequentially (each skipped to the end after start; all had german language / no subs)
    4) selected in Main Menu
    a) Language: German
    b) Subtitels: None​
    5) Started Playback
    a) Language: German
    b) subtitles: None​
    6) Interrupt playback with call of main Menu
    a) select Language: german
    b) select subtitle: None​
    7) select play (Movie continues)
    a) Language English
    b) subtitles: German​
    8) Interrupt playback with call of main Menu
    a) select language: German
    b) select subtitle: German​
    9) select play (Movie continues)
    a) Language English
    b) subtitles: German​

    LAV Splitter settings on pref & forced subs: none

    duno if this will help to narrow down the cause

    Note: in the BD Menu you have to select language & sub before you can leave the submenu

    Cheers,


    Update:
    To introduce further confusion, I re-performed the test (in different orders & sequences)
    it became apparent that steps are not reliably to reprocude; eg:
    • lang: ger / sub: none now maintained ger/none (differ frome above)
    • lang: ger / subs: ger retained eng/ger
    • lang: eng / subs: none: resulted in ger/none
    I attached this as well, but doubt that it will help w/o clear order of selection
     
    Last edited:

    DaBaSe

    MP Donator
  • Premium Supporter
  • November 4, 2009
    101
    7
    Germany Germany
    Country flag
    Sorry, double post
     
    Last edited:

    DaBaSe

    MP Donator
  • Premium Supporter
  • November 4, 2009
    101
    7
    Germany Germany
    Country flag
    Hello mm,

    thx for support
    It looks like MP is selecting the correct audio stream in this case:
    ...

    Can you confirm?
    I will try it again.

    Nothing is happening at 12:41:35. :confused:
    Do you mean 12:42:35?
    :oops:Sorry, you are right.
    Yesterday, i try a extract file from the Blue ray and it has also dropping frames. I will test it again in some other ways and report back.

    greetings Lars
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    A Audio sync problems on LAV filters 1.21 Pre Release 31
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    W BluRay audio problem since update to MP 1.19 Watch / Listen Media 19
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 12
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    Top Bottom