Problems with MP1 client dying after resuming from standby (1 Viewer)

BlueMax1916

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Home Country
    Germany Germany
    Country flag
    Hi,

    I have problems with one of my HTPC (HTPC 2 in the system specs). All of a sudden the MP1 client porcess dies when resuming from S3 standby. That never happened before but now it happens for several days. Not always but sometimes.

    The only thing I changed recently was to update LAV from 0.69.0 to 0.70.2 in the MP Extension Manager. I can not think about this being the reason of the problem. Also HTPC 1 does not have a problem with this.

    From the logs I see errors but I can not interpret them. Some errors show the TV Wishlist plugin. This was installed for a test I think half a year ago and after some 15 minutes deinstalled again. Yet there are errors related to that. Som missing skin files. But those errors must have been there all the time since the deinstallation and should not be the cause. I am still running Windows 10 1703 so this should not be the cause either.

    Attached are the logs collected with the Watchdog.

    Thanks and cheers

    Blue Max
     

    Attachments

    • MediaPortalLogs_28_01_18__18_16 - Client error after wake up from S3 standby.zip
      5.5 MB · Views: 29

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,222
    Home Country
    New Zealand New Zealand
    Country flag
    Hello

    Actually, it looks like MP is crashing when going into standby.

    The main log file contains an obvious exception/error right at the end:
    [collapse]
    [2018-01-28 18:01:49,949] [Error ] [PathScanner] [ERROR] - MediaPortal: Unhandled exception occured
    [2018-01-28 18:01:49,965] [Log ] [PathScanner] [ERROR] - Exception: System.OperationCanceledException: Der Vorgang wurde abgebrochen.
    bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    bei System.IO.FileSystemEnumerableIterator`1.CommonInit()
    bei System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
    bei System.IO.DirectoryInfo.InternalGetDirectories(String searchPattern, SearchOption searchOption)
    bei System.IO.DirectoryInfo.GetDirectories()
    bei Cornerstone.Extensions.IO.DirectoryInfoExtensions.IsAccessible(DirectoryInfo self)
    bei MediaPortal.Plugins.MovingPictures.LocalMediaManagement.MovieImporter.UpdateFileSystemWatchers()
    bei MediaPortal.Plugins.MovingPictures.LocalMediaManagement.MovieImporter.ScanAndMonitorPaths()
    bei System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    bei System.Threading.ThreadHelper.ThreadStart() Message: Der Vorgang wurde abgebrochen. Site : Void WinIOError(Int32, System.String) Source : mscorlib Stack Trace: bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    bei System.IO.FileSystemEnumerableIterator`1.CommonInit()
    bei System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
    bei System.IO.DirectoryInfo.InternalGetDirectories(String searchPattern, SearchOption searchOption)
    bei System.IO.DirectoryInfo.GetDirectories()
    bei Cornerstone.Extensions.IO.DirectoryInfoExtensions.IsAccessible(DirectoryInfo self)
    bei MediaPortal.Plugins.MovingPictures.LocalMediaManagement.MovieImporter.UpdateFileSystemWatchers()
    bei MediaPortal.Plugins.MovingPictures.LocalMediaManagement.MovieImporter.ScanAndMonitorPaths()
    bei System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    bei System.Threading.ThreadHelper.ThreadStart()[/collapse]

    From the "bei MediaPortal.Plugins.MovingPictures.LocalMediaManagement.MovieImporter.UpdateFileSystemWatchers()" line you could be fairly sure that the problem is something to do with the MovingPictures plugin, and guess that it might be something to do with file system watchers. Therefore I recommend:
    1. To update to the newest version of MovingPictures, AND...
    2. ...if (1) does not help, to reach out for MovingPictures support.
     

    BlueMax1916

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Home Country
    Germany Germany
    Country flag
    Hi mm,

    thank you very much for taking time to analyze this. MovingPictures is up to date, the newest version 1.8.1 is already installed. So I will take your advice and ask for support in the Moving Pictures subforum.

    Cheers

    Blue Max
     

    Users who are viewing this thread

    Similar threads

    I think I have a better way of showing what is happening I just turned on the TV from sleeping and then opened the guide to select one of my IPTV channels. After a few seconds, the client throws an "Unknown Error" and then nothing more. As you can see in the mediaportal attachment, on the left side there is nothing playing. On the...
    I think I have a better way of showing what is happening I just turned on the TV from sleeping and then opened the guide to select...
    I'm not sure exactly when this started, I've been dealing with it for a while until I had time to troubleshoot it. I'm pretty sure...
    Replies
    4
    Views
    193
    @joecrow: Thanks a million for this! I have had this weird issue for ages and with one simple uncheck, it's gone! Never understood what the option was for, like AlunS. And I still don't... It's probably something else, but when starting a video the audio doesn't start IMMEDIATELY along with the video. So maybe a second or two are...
    @joecrow: Thanks a million for this! I have had this weird issue for ages and with one simple uncheck, it's gone! Never understood...
    I'm having a strange one here ... it seems to have started after getting a new Sony 4k TV, and manifests itself by refusing to...
    Replies
    6
    Views
    903
    I just found this: On the German page of the PCTV application (only on the German page and not on the driver pages :rolleyes:): TVC 6.4.8 Download (pctvsystems.com) My English translation: I didn't test it because I already switched to another TV card (so I found this piece of information to late) but maybe this can help others...
    I just found this: On the German page of the PCTV application (only on the German page and not on the driver pages :rolleyes:)...
    Hello Yesterday, I updated my computer running MediaPortal Client and TVServer (and also occasionally providing another laptop...
    Replies
    13
    Views
    3K
    Thanks for that but it does seem to me that Madvr is the issue here, I guess it is not as robust as the EVR or does not get shut down as elegantly, I also suspect, though I have not tried it, that the result would be the same for playback of any video, i.e. not just TV. Given that German TV is now all transmitted as full HD, the need...
    Thanks for that but it does seem to me that Madvr is the issue here, I guess it is not as robust as the EVR or does not get shut...
    When I finish watching TV I always stop the playback and exit to the home gui before putting the HTPC to sleep and have no...
    Replies
    2
    Views
    3K
    For me not ;) -- Tapatalk | WBR, ajs
    For me not ;) -- Tapatalk | WBR, ajs
    Description: After a resume from sleep the Radio Time plugin will no longer play any radio stations and gives the error shown in...
    Replies
    10
    Views
    1K
    Top Bottom